Adium

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#14331 closed defect (fixed)

renkoo scrolls to bottom on new content regardless of scroll position

Reported by: mathuaerknedam Owned by: earthmkii
Milestone: Adium 1.4.2 Component: Message View
Version: 1.4b19 Severity: minor
Keywords: Cc:
Patch Status:

Description (last modified by mathuaerknedam)

Summary

Adium's default behavior (as set in template.html) is that if the user has scrolled <10% from the bottom of the scroll window, Adium will not scroll to the bottom of the window if new content arrives. Renkoo scrolls to be bottom regardless of the scroll position. It does this because of an override of Coalesced HTML methods introduced with http://hg.adium.im/adium-1.4/rev/6beac534df5b. This was done to preserve Renkoo's fade in for new messages.

Steps to reproduce

  1. Select Renkoo in the messages prefpane
  2. Open a chat and wait for enough content to force a scrollbar with a height <1/2 of the window height. (#ubuntu on freenode is high traffic; you won't wait long.)
  3. scroll to the top of the window.
  4. Wait for more content to arrive.

Expected results

The window will remain scrolled to the top when new content arrives.

Actual results

The window will scroll to the bottom when new content arrives.

Regression

Any version of Adium 1.4 or 1.5 after the revision above.

Change History (11)

comment:1 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4
  • Owner set to mathuaerknedam
  • Severity changed from normal to regression

A regression from 1.3, right?

comment:2 Changed 9 years ago by mathuaerknedam

Actually, this problem existed in 1.3.10 also.

comment:3 Changed 9 years ago by Robby

  • Severity changed from regression to minor

comment:4 Changed 9 years ago by zacw

  • Milestone changed from Adium 1.4 to Adium 1.4.1

comment:5 Changed 9 years ago by mathuaerknedam

  • Description modified (diff)

The coalesce override is in place because coalescing break the fade-in of new messages. I'd guess someone more javascript-capable than myself needs to resolve the conflict between coalescing and the fade (without breaking smooth scroll).

comment:6 Changed 9 years ago by evands

  • Milestone changed from Adium 1.4.1 to Adium 1.4.2

comment:7 Changed 9 years ago by earthmkii

  • Owner changed from mathuaerknedam to earthmkii
  • Status changed from new to assigned

This may have been preexisting behavior, but I'll look into it and see if it's fixable.

comment:8 Changed 9 years ago by ShawnRisk

I just tested this with 1.3.10 and this still happening there.

comment:9 Changed 9 years ago by kbotc

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:10 Changed 9 years ago by mathuaerknedam

(In ad22153998f9) Renkoo: don't scroll down on new messages when scrolled up in the chat. Good find by kbotc. Fixes #14331.

comment:11 Changed 9 years ago by mathuaerknedam

(In 40cac356e9ea) Renkoo: don't scroll down on new messages when scrolled up in the chat. Good find by kbotc. Fixes #14331.

Note: See TracTickets for help on using tickets.