Adium

Opened 9 years ago

Closed 9 years ago

#14229 closed defect (fixed)

Adium loses ICQ connection but doesn't show

Reported by: eruhenon Owned by:
Milestone: Adium 1.4.2 Component: Service/ICQ
Version: 1.4b18 Severity: major
Keywords: Cc:
Patch Status:

Description (last modified by Robby)

While connected to ICQ at some point Adium doesn't receive any more messages. Still displays as away.
As soon as I disconnect and connect, I receive some of the old messages but not all.

This happens only while being connected via Port 443 (due to closed ports on my side).

  • OS X 10.6.4
  • Adium 1.4b18
  • Language: German

Edit:
It looks this problem is unrelated to being connected using SSL.

Attachments (5)

debug.txt (71.9 KB) - added by eruhenon 9 years ago.
console-log.rtf (1016 bytes) - added by wankaxd 9 years ago.
console-log.txt (673 bytes) - added by Robby 9 years ago.
wankaxd's console logging in .txt format
adium.txt (672 bytes) - added by wankaxd 9 years ago.
same error, now in 1.4.1
bildschirmfoto20101124u.png (106.2 KB) - added by Robby 9 years ago.

Download all attachments as: .zip

Change History (48)

comment:1 Changed 9 years ago by Robby

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

Changed 9 years ago by eruhenon

comment:2 Changed 9 years ago by eruhenon

  • Status changed from pending to new

Attachment (debug.txt) added by ticket reporter.

comment:4 Changed 9 years ago by eruhenon

added the debug log. what I thing is pretty interesting.. the message was displayed in the debug log but not in the chat. here's the message:

18:39:00: adiumPurpleConvWriteIm: Received da hab ich ne marktlücke entdeckt: haargummi verkauf bei konzerten from 49xxxxxxx

comment:5 Changed 9 years ago by Robby

  • Component changed from Adium Core to Service/ICQ
  • Milestone set to Adium 1.4
  • Severity changed from normal to major

There's a similar report on the forum: http://forums.cocoaforge.com/viewtopic.php?f=10&t=22248#p126924. It, however, states that this started happening with b19 whereas this ticket reports it for b18.

Personally, I've had problems with ICQ recently in connection with Wifi. Sometimes, I would lose connection but Adium would not notice and I'd send messages to nowhere. I use the default port, 5190.

comment:6 Changed 9 years ago by Robby

  • Summary changed from Adium looses Connection on ICQ but doesn't show to Adium loses ICQ connection but doesn't show

comment:8 Changed 9 years ago by Robby

eruhenon, are you connecting using SSL?

comment:9 Changed 9 years ago by Robby

I believe this is related to the SSL connection. I haven't found any similar tickets in Pidgin's Trac. Might there be something wrong in libpurple glue code?

comment:10 in reply to: ↑ 7 Changed 9 years ago by Robby

  • Description modified (diff)

comment:11 follow-up: Changed 9 years ago by Zachary West <zacw@…>

(In be7c1eabdec8) Add some debug logging for message receipt. Refs #14229 if only because we need more debug logging in this path.

comment:12 Changed 9 years ago by Robby

Another report for b19 here: http://idzr.org/5a6n0w. Using 5190.

comment:13 Changed 9 years ago by Robby

  • Description modified (diff)

comment:14 Changed 9 years ago by zacw

Are all of you using the same German ISP? It's possible it's silently killing the connection; it's likely Adium has no way of knowing the connection was severed.

comment:15 Changed 9 years ago by Robby

  • Description modified (diff)

Well, this doesn't seem that unlikely due to my torrenting. My ISP is T-Online.

However, both the reporter at Cocoaforge and the user at macuser.de state this problem popped up with b19 and was not there in b18.

eruhenon, do you have something to add? When did the problems start? Which is your ISP?

comment:16 Changed 9 years ago by pboese

Same problem here on several german ISPs: Unitymedia, Netcologne, Vodafone (3g). Started with an update to b19. Only solution for me is downgrading to a non-beta version, which works perfectly fine. But who wants to use non-beta versions?! :-)

comment:17 in reply to: ↑ 11 Changed 9 years ago by Robby

eruhenon, pboese and others (I am not seeing this currently), please download a nightly (http://nightly.adium.im) and post a debug log. The nightlies include extra logging zacw added:

(In be7c1eabdec8) Add some debug logging for message receipt. Refs #14229 if only because we need more debug logging in this path.

comment:18 Changed 9 years ago by evands

  • Status changed from new to pending

comment:19 follow-up: Changed 9 years ago by sphynx

Could this be a message stuck in a AIContentFilter somewhere which chokes the whole conversation? It's a completely different part of Adium, and I don't really know how it could only apply to ICQ, but I'm mostly basing this on:

Noch ein Problem mit der letzten Beta. Das Beenden über -Q klappt nicht mehr. Auch Fenster werden über -W nicht mehr geschlossen. Man muss den Prozess beenden. Nicht immer, aber ab und an.

(Another problem with the latest beta. Quitting with -Q does not work anymore. Also windows can not be closed with -W. The process has to be terminated. Not always, but occasionally.)

from the macuser thread. This can happen when there are still messages pending for a chat that are stuck so it refuses to close.

Could someone check Console.app when this happens? Maybe there is an exception being thrown somewhere.

comment:20 Changed 9 years ago by evands

That's an excellent theory, sphynx. An AIContentFilter seizing up would lock up the conversation for the user and would prevent the chat from being closed.

It shouldn't stop -Q from quitting, though. An NSException having been thrown could do that, so I agree - Console logging would be helpful.

Changed 9 years ago by wankaxd

comment:21 in reply to: ↑ 19 Changed 9 years ago by wankaxd

Replying to sphynx:

Noch ein Problem mit der letzten Beta. Das Beenden über -Q klappt nicht mehr. Auch Fenster werden über -W nicht mehr geschlossen. Man muss den Prozess beenden. Nicht immer, aber ab und an.

(Another problem with the latest beta. Quitting with -Q does not work anymore. Also windows can not be closed with -W. The process has to be terminated. Not always, but occasionally.)

I got the same problem (send messages + can't close).
I attached the the log of Console.app.

comment:22 Changed 9 years ago by David Munch

  • Status changed from pending to new

Changed 9 years ago by Robby

wankaxd's console logging in .txt format

comment:23 Changed 9 years ago by Robby

This should be fixed by a04fddfc715b.

We will have another release candidate (rc2) for everyone to test (and hopefully confirm). :)

comment:24 Changed 9 years ago by Robby

  • Milestone Adium 1.4 deleted
  • Resolution set to fixed
  • Status changed from new to closed

comment:25 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4.1
  • Resolution fixed deleted
  • Status changed from closed to new

comment:26 Changed 9 years ago by evands

  • Milestone changed from Adium 1.4.1 to Adium 1.4.2

Changed 9 years ago by wankaxd

same error, now in 1.4.1

Changed 9 years ago by Robby

comment:27 Changed 9 years ago by Robby

I've attached a screenshot of Console.app logging from a guy in #adium who has had this happen with 1.4.1.

comment:28 Changed 9 years ago by Thijs Alkemade <thijsalkemade@…>

(In 1cd209516587) Just like in the patch from our anonymous source, log a lot but don't assert when adding nil via addObject:.

Refs #14229.

comment:29 Changed 9 years ago by Robby

Ticket #14561 has been marked as a duplicate of this ticket.

comment:30 Changed 9 years ago by Morpheus0001

I got a version of Adium which should have fixed it (via IRC support). It didn't work though. Adium just froze again giving this error message in the console:
01.12.10 12:46:04 com.apple.launchd[81] ([0x0-0x32032].com.adiumX.adiumX[368]) Exited: Terminated

comment:31 Changed 9 years ago by sphynx

Some extra info from kld1, who also tried a 1.4hg build: it still occurs. They could reproduce it by someone using the official client copy/pasting something and sending that.

comment:32 Changed 9 years ago by Lasse

I've got an addition to the ticket, or a very a similar issue - ICQ stops to receive (and send) messages, though it appears as if it's only related to one contact (several other conversations appeared to be working just fine, but I'm not chatting as much with them as with this person, so it could be it just didn't happen with other contacts yet).

Whenever I try to send a message to that contact, Adium will show the spinning ball, and it takes >1-2mins before the contact's tab appears. The same happens if I close and reopen the contact's window or tab after not receiving messages. If the contact initiates a conversation, we'll be able to exchange message but then Adium will stop to send&receive messages.

Adium 1.4.1 b629a9b200c8 on 10.6.5 (Build 10H574)
Language: German
ISP: 1&1 (via Mediaways backbone)
Connected to login.icq.com via Port 5190 with WiFi (WPA2) (Fritz.Box 7230). Port is open. SSL is not checked.
ISO-8859-1

I'll add a log as soon as it happens again.

comment:33 Changed 9 years ago by sphynx

Because no-one has attached a stack trace yet that was added:

01:11:47: Attempted to add null to AIXMLElement (null), backtrace available in debug mode
01:11:48: 0   Adium                               0x0036d591 AILogBacktrace_impl + 40
1   Adium                               0x003a58e8 -[AIHTMLDecoder rootStrictXHTMLElementForAttributedString:imagesPath:] + 2100
2   Adium                               0x003a28a0 -[AIHTMLDecoder encodeStrictXHTML:imagesPath:] + 49
3   Adium                               0x000d4533 0x0 + 869683
4   Foundation                          0x9026b4df _nsnote_callback + 176
5   CoreFoundation                      0x90aab793 __CFXNotificationPost + 947
6   CoreFoundation                      0x90aab19a _CFXNotificationPostNotification + 186
7   Foundation                          0x90260384 -[NSNotificationCenter postNotificationName:object:userInfo:] + 128
8   Adium                               0x000f38ac 0x0 + 997548
9   CoreFoundation                      0x90ac9edd __invoking___ + 29
10  CoreFoundation                      0x90ac9e48 -[NSInvocation invoke] + 136
11  Adium                               0x00108228 0x0 + 1081896
12  Adium                               0x000f3d4a 0x0 + 998730
13  Adium                               0x000f4445 0x0 + 1000517
14  CoreFoundation                      0x90ac9edd __invoking___ + 29
15  CoreFoundation                      0x90ac9e48 -[NSInvocation invoke] + 136
16  Adium                               0x00108228 0x0 + 1081896
17  Adium                               0x000f4a3f 0x0 + 1002047
18  AdiumLibpurple                      0x002bb7b2 -[CBPurpleAccount receivedIMChatMessage:inChat:] + 293
19  libpurple                           0x006027d1 purple_conv_im_write + 179
20  libpurple                           0x006351ce serv_got_im + 539
21  libpurple                           0x0073e55e incomingim_chan1 + 1516
22  libpurple                           0x0073fa48 purple_parse_incoming_im + 137
23  libpurple                           0x0072b9b0 incomingim_ch1 + 582
24  libpurple                           0x0072ca24 incomingim + 313
25  libpurple                           0x0072e10c snachandler + 199
26  libpurple                           0x00736595 parse_snac + 239
27  libpurple                           0x00736809 parse_flap + 153
28  libpurple                           0x00736b74 flap_connection_recv + 832
29  libpurple                           0x00736bcc flap_connection_recv_cb + 23
30  CoreFoundation                      0x90ad5e2e __CFSocketDoCallback + 702
31  CoreFoundation                      0x90ad57b7 __CFSocketPerformV0 + 311
32  CoreFoundation                      0x90a8f4cb __CFRunLoopDoSources0 + 1563
33  CoreFoundation                      0x90a8cf8f __CFRunLoopRun + 1071
34  CoreFoundation                      0x90a8c464 CFRunLoopRunSpecific + 452
35  CoreFoundation                      0x90a8c291 CFRunLoopRunInMode + 97
36  HIToolbox                           0x98da7f9c RunCurrentEventLoopInMode + 392
37  HIToolbox                           0x98da7d51 ReceiveNextEventCommon + 354
38  HIToolbox                           0x98da7bd6 BlockUntilNextEventMatchingListInMode + 81
39  AppKit                              0x9351878d _DPSNextEvent + 847
40  AppKit                              0x93517fce -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156
41  AppKit                              0x934da247 -[NSApplication run] + 821
42  AppKit                              0x934d22d9 NSApplicationMain + 574
43  Adium                               0x000029aa 0x0 + 10666

comment:34 Changed 9 years ago by sphynx

I'm reasonably confident it is now fully fixed in http://hg.adium.im/adium-1.4/rev/ccb09f0e6c8c. I'll put up a build for whoever wants to test tomorrow.

comment:35 follow-up: Changed 9 years ago by sphynx

For anyone who wants to test this: http://xnyhps.nl/~thijs/linked/adium/Adium.ccb09f0e6c8c.app.zip is a 'nightly' build of 1.4.2 where this is hopefully completely fixed.

comment:36 Changed 9 years ago by mnott

No, it is still not working. ICQ incoming messages do not come through.

comment:37 Changed 9 years ago by mnott

does work with 1.3.10 which doesn’t have irc.

hmm.

comment:38 Changed 9 years ago by sphynx

mnott: do you mean with 1.4.1, or the developer build in my previous comment?

comment:39 Changed 9 years ago by mnott

the dev build you named in your previous comment

I've tried with 1.3.10 also, and there it works fine

I have seen that in 1.4.1 and the more current built that you have named, I can well see that someone is writing something - but the msg doesn’t come in.

comment:40 Changed 9 years ago by MetalSnake

I'm using sphynx's version since almost 4 weeks, now and have no problems anymore. :)

comment:41 Changed 9 years ago by mnott

MetalSnake: Which version exactly are you using? I tried with the one that sphynx referenced, and wasn't able to get incoming icq messages. Trillian, as well as adium 1.3.10 work perfectly well.

comment:42 in reply to: ↑ 35 Changed 9 years ago by vikeis

Replying to sphynx:

For anyone who wants to test this: http://xnyhps.nl/~thijs/linked/adium/Adium.ccb09f0e6c8c.app.zip is a 'nightly' build of 1.4.2 where this is hopefully completely fixed.

does not help =( adium can't get or send message with a weak internet connection...

Last edited 9 years ago by vikeis (previous) (diff)

comment:43 Changed 9 years ago by MetalSnake

@mnott I'm using that one from comment 35

comment:44 Changed 9 years ago by evands

  • Resolution set to fixed
  • Status changed from new to closed

I agree with sphynx: The issue reported in this ticket should be fixed by ccb09f0e6c8c (adium-1.4) and 5b2e819a13f8 (adium). Any remaining problems receiving messages is likely a separate issue, and a new ticket should be opened by anyone using a later revision (that is, for official builds, 1.4.2 or later) who can reproduce it.

Note: See TracTickets for help on using tickets.