Adium

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14220 closed defect (duplicate)

The removed contacts are still in the contact list when the Adium is relaunched.

Reported by: jeathli Owned by:
Milestone: Component: Service/Gadu-Gadu
Version: 1.3.10 Severity: normal
Keywords: Cc:
Patch Status:

Description

when i delete a contact using it to operate gadu-gadu plugin, the contacts are back in my contact list next time it started.

basically i cannot remove any contacts.

Change History (6)

comment:1 follow-up: Changed 4 years ago by Robby

  • Status changed from new to pending

Does it work any better in the 1.4 beta (AdiumBeta)?

comment:2 Changed 4 years ago by wixardy

Ticket #14238 has been marked as a duplicate of this ticket.

comment:3 in reply to: ↑ 1 Changed 4 years ago by pmslo

Replying to Robby:

Does it work any better in the 1.4 beta (AdiumBeta)?

No.

Also, this: http://trac.adium.im/ticket/9126

Also, the problem, I think, is related to new XML format of the buddy lists in new versions of Gadu-Gadu, and I highly doubt libpurple/libgadu people care anymore. A simple solution is to delete contacts manually from ~/Library/Application Support/Adium 2.0/Users/Default/libpurple/blist.xml and from the roster using the official GG client. Deleting the contacts form ByObjectPrefs.plist might be effective as well, but I'm really not sure. I delete both when I want to get rid of a contact.

Actually, I'm no longer even adding contacts to Gadu-Gadu in fear of not being able to delete them afterwards, so basically memorizing the GG numbers or some good ol' paper and pencil method might be better for you than the trivial contact list.

comment:4 Changed 4 years ago by Robby

  • Resolution set to duplicate
  • Status changed from pending to closed

Closed as duplicate of #9126.
Thanks, pmslo.

comment:5 Changed 4 years ago by pmslo

Does that mean it's never going to be fixed? Not that I care, I don't even care!

comment:6 Changed 4 years ago by Robby

Heh

I don't know. This is an issue in libpurple. It's almost entirely Pidgin developers who work on it and in the case of Gadu-Gadu it's usually a matter of patches being submitted from contributors and recently, an updated version of libgadu (#p10542).

See http://developer.pidgin.im/query?component=Gadu-Gadu&order=milestone&col=id&col=summary&col=owner&col=type&col=status&col=milestone&resolution=fixed.

Note: See TracTickets for help on using tickets.