Adium

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#13920 closed defect (fixed)

Max SendQ exceeded on irc.mozilla.org 6697, ssl

Reported by: timeless Owned by: zacw
Milestone: Adium 1.5 Component: Service/IRC
Version: 1.5hg Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

I'm getting disconnected from irc.mozilla.org 6697/ssl every 5 or 10 minutes.

Steps to reproduce

  1. configure wifi networks (home, office)
  2. configure adium with irc connection for irc.mozilla.org 6697/ssl
  3. connect to moznet and join a couple of channels
  4. wait for 12 minutes

Expected results

connection should last for 12 minutes (really until my mac runs out of power or falls asleep, and it isn't configured to sleep...)

Actual results

every 5 or 10 minutes, everyone else sees:
* Signoff: timeless_mbp (Max SendQ exceeded)

I see:

sand.mozilla.org	‣	(notice) *** You are connected to sand.mozilla.org with TLSv1-AES128-SHA-128bits
<!>	‣	You have disconnected
sand.mozilla.org	‣	(notice) *** You are connected to sand.mozilla.org with TLSv1-AES128-SHA-128bits
<!>	‣	You have disconnected
sand.mozilla.org	‣	(notice) *** You are connected to sand.mozilla.org with TLSv1-AES128-SHA-128bits
<!>	‣	You have disconnected
sand.mozilla.org	‣	(notice) *** You are connected to sand.mozilla.org with TLSv1-AES128-SHA-128bits
<!>	‣	You have connected

Regression

This seems to have started around April 13, 2010.

I can provide Adium logs from ~/Library/Application Support/Adium 2.0/Users/Default/Logs/IRC.timeless_mbp/sand.mozilla.org

Change History (22)

comment:1 Changed 9 years ago by Robby

Does this remain an issue in recent builds of Trunk (1.5hg)?

comment:2 Changed 9 years ago by Robby

  • Status changed from new to pending

comment:3 Changed 9 years ago by Catfish_Man

  • Resolution set to fixed
  • Status changed from pending to closed

timeless says in irc that the problem appears to be gone.

comment:4 Changed 9 years ago by tarend

I am still seeing this issue with Adium 1.4.1

comment:5 Changed 9 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

comment:6 Changed 8 years ago by Robby

  • Status changed from new to pending

Does this remain an issue?

comment:7 Changed 8 years ago by mathuaerknedam

  • Resolution set to outofdate
  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:8 Changed 8 years ago by Yoric

I meet the exact same issue. I suggest reopening the bug.

comment:9 Changed 8 years ago by David Munch

  • Resolution outofdate deleted
  • Status changed from closed to new

comment:10 Changed 8 years ago by Yoric

I should add that I meet the exact same issue both with Adium and with InstantBird. I believe that they are both based on libpurple, which suggests that the problems might lie there. This may be confirmed by the following bug report & patch on libpurple:

https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/856631

comment:11 Changed 8 years ago by mathuaerknedam

Yoric,

What version of Adium are you using?

comment:12 Changed 8 years ago by Yoric

Version 1.4.3 dated 9/4/11

comment:13 Changed 8 years ago by mathuaerknedam

Using 1.5b2, I've been in #firefox, #thunderbird, and #android on irc.mozilla.org for over 60 minutes without any problems. Please try 1.5b2.

comment:14 Changed 8 years ago by mathuaerknedam

  • Status changed from new to pending

comment:15 Changed 8 years ago by Yoric

How do I get my hand on 1.5b2? Is this a tag?

comment:17 Changed 8 years ago by mathuaerknedam

  • Resolution set to outofdate
  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:18 Changed 8 years ago by Robby

elb of Pidgin told me this is a known issue in libpurple (https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/856631).

comment:20 Changed 8 years ago by mathuaerknedam

I had read the ubuntu bug before testing, but it seems either the reproduction steps are lacking some significant detail or something changed.

comment:21 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution changed from outofdate to fixed

(In 895fe77449a4) libpurple 2.10.0 [im.pidgin.adium @ 49165fe031556f6fe6c91eadc8305a0e9001eb90]

Plucked these two changes:

  • Fix double mail notifications on MSN.
  • Make disconnects because of flooding on IRC less likely.

Fixes #13920, fixes #11199

comment:22 Changed 8 years ago by Robby

  • Milestone set to Adium 1.5
Note: See TracTickets for help on using tickets.