Adium

Opened 4 years ago

Closed 4 years ago

#13877 closed defect

User Unavailable and Receive XMPP Code 503 error when attempting to chat

Reported by: Thom.Tessandori Owned by:
Milestone: Component: Service/Google Talk
Version: 1.3.10 Severity: normal
Keywords: GTalk, XMPP, Code 503 Cc:
Patch Status:

Description (last modified by Robby)

Summary

A little over a week ago I started seeing someone I chat with frequently (for work) as showing offline when they (and several other folks) said they were online. Additionally, when I attempt to send a chat to them (manually, as described below) I get an XMPP Code 503 error.

Steps to reproduce

  1. User (BoRyan.Eberhard@…) disappeared from my contact list a little over a week ago. We chat several times a day so I thought it was out of place.
  2. He is online but not showing on my end. I facilitate a chat on my end, using the "File" -> "New Chat"; Enter his email address; type in IM and receive error code (Code 503)
  3. Chat does not go through

Expected results

I expected a response or for him to see the chat on his end.

Actual results

I do not show as Online on his end;
He does not receive my chats;
I do not receive his chats;

Regression

Mac OS X - Version 10.4.11
Using Adium 1.3.10-debug
Nothing recently has changed on my system.

Notes

Here are the debug logs from today:

15:41:05: Getting accountActionMenuItems for <AIPurpleGTalkAccount:18b39090 3>:thom.tessandori@hottopicmedia.com
15:41:05: (Libpurple: jabber) jabber_actions: have pep: NO
15:41:05: (Libpurple: jabber) Unable to find caps: buddy might be offline
15:41:05: (Libpurple: jabber) Sending (ssl): <message type='chat' id='purple69843c99' to='boryan.eberhard@hottopicmedia.com'><body>Hey BoRyan</body><html xmlns='http://jabber.org/protocol/xhtml-im'><body xmlns='http://www.w3.org/1999/xhtml'>Hey BoRyan</body></html></message>
15:41:05: (Libpurple: jabber) Recv (ssl)(392): <message type="error" id="purple69843c99" to="thom.tessandori@hottopicmedia.com/Adium0DC41213" from="boryan.eberhard@hottopicmedia.com"><body>Hey BoRyan</body><html xmlns="http://jabber.org/protocol/xhtml-im"><body xmlns="http://www.w3.org/1999/xhtml">Hey BoRyan</body></html><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></message>
15:41:05: (Libpurple: jabber) found 0 smileys
15:41:05: adiumPurpleNotifyFormatted: XMPP Message Error
XMPP Message Error
Message delivery to boryan.eberhard@hottopicmedia.com failed: (Code 503)
<html xmlns='http://jabber.org/protocol/xhtml-im'><body xmlns='http://www.w3.org/1999/xhtml'>Hey BoRyan</body></html> 

Change History (3)

comment:1 Changed 4 years ago by Thom.Tessandori

After more testing I've found that this appears to be ACCOUNT driven. In other words, I used an Alias attached to my email account and that brought up the same results. However, when I created another account in Adium using the same domain I was able to add folks that I couldn't see on the other account (the account that wouldn't show them).

comment:2 Changed 4 years ago by Robby

  • Description modified (diff)
  • Status changed from new to pending

Have you tried re-adding the contact?

comment:3 Changed 4 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.