Adium

Opened 10 years ago

Closed 9 years ago

#13649 closed defect (fixed)

IRC /say command does not work

Reported by: tmoore Owned by: zacw
Milestone: Adium 1.4.1 Component: Service/IRC
Version: 1.4b17 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

The IRC /say command does not seem to work in Adium 1.4b17. This is useful for sending messages to an IRC channel that start with a / character (which would otherwise be interpreted as commands).

Steps to reproduce

  1. Set up an IRC account (this is reproducible on irc.freenode.net, for example)
  2. Join any channel
  3. Enter "/say anything"

Expected results

It should send the message "anything" to the channel.

Actual results

Adium displays an error box:

Adium Notice: Unknown message

Unknown message 'say'

The IRC server received a message it did not understand.

Regression

I've only tried this with Adium 1.4b17 on Mac OS 10.5.8

Notes

The error makes it sound like a server issue, however I've had other people in the same channel using different clients, including Colloquy and Pidgin, report that it works for them.

Change History (5)

comment:1 Changed 9 years ago by ShawnRisk

I have tested this out on adium 1.4b18 and Mac OS 10.6.4 and the error still occurs to for me. This works for me on Colloquy perfectly.

comment:2 Changed 9 years ago by David Munch

  • Milestone set to Adium bugs

comment:3 Changed 9 years ago by paradoxmo

This works in Pidgin but not for us? I wonder how they implement it.

comment:4 Changed 9 years ago by zacw

  • Milestone changed from Adium bugs to Adium 1.4.1

/say is not actually a command for IRC. It's common on most clients to support it. This is _not_ a bug.

comment:5 Changed 9 years ago by evands

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [8e7c971af12a] and [ae7444303756]

Note: See TracTickets for help on using tickets.