Adium

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#13541 closed defect (fixed)

1.4b17: Date on the about dialog is clipped

Reported by: dani_ramos Owned by: berdan
Milestone: Adium 1.4.1 Component: Localization
Version: 1.4b17 Severity: minor
Keywords: about clipping Cc:
Patch Status: Rejected

Description (last modified by Robby)

Summary

Provide a descriptive summary of the issue.

Steps to reproduce

  1. 1.4b17
  2. Check the About dialog (Go to Adium > About Adium)

Results

The date displayed in the About box is clipped.

Notes

Check attached screenshot
Path:
Adium.app/Contents/Resources/AboutBox.nib

Attachments (2)

US.png (49.5 KB) - added by dani_ramos 10 years ago.
short-date-in-about-box.patch (719 bytes) - added by hortont424 9 years ago.

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by dani_ramos

comment:1 Changed 10 years ago by jas8522

  • Component changed from Adium UI to Localization
  • Milestone set to Adium 1.4 (Release)
  • Owner set to berdan
  • Severity changed from normal to minor

It's fine in English - localization spacing issue.

comment:2 Changed 10 years ago by Robby

  • Description modified (diff)

comment:3 Changed 10 years ago by dani_ramos

This issue is not a localization spacing issue as the nib is not on the localized folder (as you can see by it's path) and the date displayed is the same as the OS complete date.
In English is fine because the complete date (Wednesday, December 2, 2009) is much shorter than for pt_PT (quarta-feira, 2 de Dezembro de 2009).
The problem is just that the field either is too wide or it doesn't have a fixed size so to wrap the date correctly.

comment:4 Changed 10 years ago by evands

  • Milestone changed from Adium 1.4 (Release) to Adium bugs

comment:5 Changed 9 years ago by hortont424

What's the correct way to solve this? We could ellipsize the text, or expand the window, or just use a shorter date format and hope it doesn't overflow then?

comment:6 Changed 9 years ago by zacw

Using a shorter date would be a valid solution.

comment:7 Changed 9 years ago by Robby

I agree with sphynx who said it would be fine to allow the text to span multiple lines. The icon might need to be made smaller to accomodate, though.

By the way, the icon isn't centred currently, is it?

comment:8 Changed 9 years ago by hortont424

If we want the shorter date solution, here's a patch. The icon does look slightly off-center, too, yeah.

Changed 9 years ago by hortont424

comment:9 Changed 9 years ago by Robby

  • Patch Status set to Needs Dev Review

comment:10 Changed 9 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In e6ac16b25ae3) Use a short date in the about box. Fixes #13541

comment:11 Changed 9 years ago by wixardy

  • Milestone changed from Adium bugs to Adium 1.4.1
  • Patch Status changed from Needs Dev Review to Rejected

I found out, in looking at your patch, that we offer the short date already.

Note: See TracTickets for help on using tickets.