Adium

Opened 10 years ago

Closed 10 years ago

#13365 closed defect

Error Received unexpected response from http://api.oscar.aol.com/aim/startOSCARSession

Reported by: sentry Owned by:
Milestone: Component: Service/AIM
Version: 1.5hg Severity: normal
Keywords: oscar,aim,beta,api Cc:
Patch Status:

Description

Summary

Ever since I updated to 1.4b14 I get this AOL error message popup:

"Error
Received unexpected response from http://api.oscar.aol.com/aim/startOSCARSession"

Steps to reproduce

Load Adium as usual, connect to usual AIM automatically

Expected results

Normal Use, No Errors

Actual results

Popop Error for AIM

From My Logs

18:00:28: (Libpurple: account) Disconnecting account 12222988 (0x18953430)
18:00:28: (Libpurple: connection) Disconnecting connection 0x196c18a0
18:00:28: (Libpurple: oscar) Signed off.
18:00:28: Disconnected: gc=196c18a0
18:00:28: <ESPurpleICQAccount:257b3f0 3>:12222988: Telling the core we disconnected
18:00:28: <ESPurpleICQAccount:257b3f0 3>:12222988: Disconnected: Will not reconnect
'''18:00:28: Posting Growl notification: Event ID: Interface_ErrorMessageReceived, listObject: (null), chat: (null), description: 12222988 (ICQ) : Error
Received unexpected response from http://api.oscar.aol.com/aim/startOSCARSession'''
18:00:28: (Libpurple: connection) Destroying connection 0x196c18a0
18:00:28: (Libpurple: oscar) icq response: 53 bytes, 663226, 0x07da, 0x0076
18:00:29: (Libpurple: oscar) Requesting ICQ alias for 462842687
18:00:30: (Libpurple: oscar) icq response: 60 bytes, 663226, 0x07da, 0x0077}}}
	

Change History (9)

comment:1 Changed 10 years ago by Dimmuxx

  • Status changed from new to pending

Provide a more complete debug log.

comment:2 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:3 Changed 10 years ago by sethp

I'm receiving this same error in d85214653b95. It looks like it's some sort of captcha thing that Adium/libpurple isn't responding correctly to:

16:03:05: -[AdiumPurpleDnsRequest startLookup]: Performing DNS resolve: api.screenname.aol.com:443
16:03:05: DNS resolve complete for api.screenname.aol.com:443
16:03:05: (Libpurple: dnsquery) IP resolved for api.screenname.aol.com
16:03:05: (Libpurple: proxy) Attempting connection to 207.200.74.251
16:03:05: (Libpurple: proxy) Connecting to api.screenname.aol.com:443 with no proxy
16:03:05: (Libpurple: proxy) Connection in progress
16:03:05: (Libpurple: proxy) Connecting to api.screenname.aol.com:443.
16:03:05: (Libpurple: proxy) Connected to api.screenname.aol.com:443.
16:03:05: (Libpurple: cdsa) Connecting
16:03:05: Called write with no write_tag <SourceInfo 0x1154f8970: Socket 0x119b84150: fd 10; timer_tag 0; read_tag 17; write_tag 0>
16:03:05: (Libpurple: cdsa) Connecting
16:03:05: (Libpurple: cdsa) Connecting
16:03:05: (Libpurple: cdsa) SSL_connect: verifying certificate
16:03:05: (Libpurple: cdsa) SSL_connect complete
16:03:05: (Libpurple: util) request constructed
16:03:05: Called write with no write_tag <SourceInfo 0x116d39980: Socket 0x116dae200: fd 10; timer_tag 0; read_tag 19; write_tag 0>
16:03:06: (Libpurple: util) Response headers: 'HTTP/1.1 200 OK
Date: Sat, 05 Dec 2009 00:03:05 GMT
Set-Cookie: JSESSIONID=7F1B71C7D319CFAD3F7EDFC9EEB87937; Path=/auth; Secure
Pragma: No-cache
Cache-Control: no-cache, must-revalidate
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Content-Type: text/xml;charset=UTF-8
Content-Language: en-US
P3P: CP="PHY ONL PRE STA CURi OUR IND"
Connection: close

'
16:03:06: (Libpurple: oscar) clientLogin response statusCode was 330 (3015): <response xmlns="https://api.login.aol.com">
  <statusCode>330</statusCode>
  <statusText>Captcha Required/Invalid</statusText>
  <statusDetailCode>3015</statusDetailCode>
  <data>
    <challenge>
      <info>Please enter word in the image</info>
      <context>SxmjOgAAZfIAAAAF</context>
      <url>https://api.screenname.aol.com/auth/getCaptcha</url>
    </challenge>
  </data>
</response>

16:03:06: (Libpurple: connection) Connection error on 0x1154f0da0 (reason: 16 description: Received unexpected response from https://api.screenname.aol.com/auth/clientLogin)
16:03:06: Connection Disconnected: gc=154f0da0 (Received unexpected response from https://api.screenname.aol.com/auth/clientLogin)

comment:4 Changed 10 years ago by Robby

  • Status changed from closed to new
  • Version changed from 1.4b14 to 1.5hg

Sounds like #p10884, what do you think?

comment:5 Changed 10 years ago by sethp

Looks exactly like that. I tried the workaround suggested there (logging in to the website and connecting while logged in), and I'm now able to connect again.

comment:6 Changed 10 years ago by apu

Same error message trying to connect to AIM accounts when "Encrypt connection using SSL" is checked but appears to work normally when SSL is not in use. iChat appears to work regardless of SSL settings.

The relevant error message appears to be:

12:28:29: (Libpurple: oscar) startOSCARSession response statusCode was 400: <?xml version="1.0" encoding="UTF-8"?>
<response xmlns="http://developer.aim.com/xsd/aim.xsd"><statusCode>400</statusCode><statusText>useTLS=1 is not allowed for non secure requests.</statusText><data><ts>1263403709</ts><upgradeData></upgradeData><betaData></betaData></data></response>

comment:7 Changed 10 years ago by Robby

  • Status changed from new to pending

Guys and gals, is this still an issue?

comment:8 Changed 10 years ago by sethp

Doesn't seem to be—if that changes, you all will be the first to know.

comment:9 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.