Adium

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#13221 closed defect (fixed)

Bookmarked IRC status icon doesn't change

Reported by: Alien Collective Owned by: zacw
Milestone: Adium 1.4.2 Component: Service/IRC
Version: 1.4b10 Severity: normal
Keywords: irc, status icons Cc:
Patch Status:

Description

When I change status icon sets, all of my icons change except for bookmarked IRC channels. These continue to show the old set's available/online icon until Adium is restarted. However, the status icons on IRC chat tabs and IRC service icons in the contact list change properly.

Attachments (1)

irc-status.png (50.6 KB) - added by Alien Collective 10 years ago.

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by Alien Collective

comment:1 Changed 10 years ago by Alien Collective

Just an extra note: I've noticed that it does change properly when the "alert" icon is displayed, and the change sticks after the icon returns to normal. I haven't had a chance to test if the icon changes to the correct set when the alert is displayed if the set change takes place while the icons are normal.

Now that Twitter is working, the timeline's status icon also seems to be affected in the same way as IRC bookmarks. Twitter contacts look fine, though.

comment:2 Changed 10 years ago by Alien Collective

One last update: When the alert status is removed, the icon changes back to its previous (incorrect) state.

comment:3 Changed 10 years ago by zacw

  • Milestone set to Adium 1.4
  • Severity changed from normal to major

comment:4 Changed 10 years ago by Zachary West <zacw@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 791780625051) Include bookmarks in the contact controller's contactDict, so that a -contactEnumerator also contains them. By way of updating properly, fixes #13221.

We weren't providing LO updates to observers when updating all contacts, since the enumerator was being used. This also removes a bookmark-specific iterator when using the enumerator is now sufficient.

comment:5 Changed 10 years ago by Zachary West <zacw@…>

(In 9b757472094b) Include bookmarks in the contact controller's contactDict, so that a -contactEnumerator also contains them. By way of updating properly, fixes #13221.

We weren't providing LO updates to observers when updating all contacts, since the enumerator was being used. This also removes a bookmark-specific iterator when using the enumerator is now sufficient.

comment:6 Changed 10 years ago by Robby

  • Milestone Adium 1.4 deleted

comment:7 Changed 10 years ago by zacw

  • Milestone set to Adium 1.4

Bookmarks were present in 1.3.

comment:8 Changed 10 years ago by Robby

True

comment:9 Changed 10 years ago by wixardy

Ticket #12917 has been marked as a duplicate of this ticket.

comment:10 Changed 10 years ago by Zachary West <zacw@…>

(In b820c57cac38) Backed out changeset 791780625051

This is causing regressions in a few other locations. Backing out for the next beta to investigate after. Refs #13221.

comment:11 Changed 10 years ago by Zachary West <zacw@…>

(In 8983d9241c62) Backed out changeset 791780625051

This is causing regressions in a few other locations. Backing out for the next beta to investigate after. Refs #13221.

comment:12 Changed 9 years ago by Robby

  • Milestone changed from Adium 1.4 to Adium 1.4.x
  • Resolution fixed deleted
  • Status changed from closed to new

The fix was reverted. Paul Wilde is seeing this in 1.4.1.

comment:13 Changed 9 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 5148e836ba20) Update status icons for bookmarks too. Fixes #13221

comment:14 Changed 9 years ago by Robby

  • Milestone changed from Adium 1.4.x to Adium 1.5

comment:15 Changed 9 years ago by Robby

  • Severity changed from major to normal

comment:16 Changed 9 years ago by Robby

  • Milestone changed from Adium 1.5 to Adium 1.4.2
Note: See TracTickets for help on using tickets.