Adium

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#13088 closed defect (fixed)

New message notification in Dock uses text that's too big

Reported by: demonbane Owned by:
Milestone: Adium 1.5 Component: Adium Core
Version: 1.4b17 Severity: minor
Keywords: Cc:
Patch Status: Rejected

Description

Since the most recent update, the Dock label text when you have a message waiting is much too big. The letters barely fit inside the colored areas and longer names get cut off altogether. (See attached screenshot.) This used to work perfectly in previous versions.

This is using 1.4b9 on Snow Leopard (10.6.1).

Attachments (4)

Adium-Dock.jpg (17.6 KB) - added by demonbane 10 years ago.
Screenshot
Dock.jpg (16.2 KB) - added by demonbane 10 years ago.
Better Screenshot showing name clipping
Screen shot 2009-12-25 at 11.35.07 AM.png (10.4 KB) - added by jas8522 10 years ago.
ticket13088 - Adium 1.4hg.patch (1.8 KB) - added by lucamot 10 years ago.
A patch to solve this issue

Download all attachments as: .zip

Change History (24)

Changed 10 years ago by demonbane

Screenshot

Changed 10 years ago by demonbane

Better Screenshot showing name clipping

comment:1 Changed 10 years ago by demonbane

I did some more testing with this issue today. I now *occasionally* get properly-sized text, but I haven't been able to isolate any sort of a pattern to this behavior. I've tried tweaking every variation of the dock settings under Advanced and the individual event notifications with no luck. My guess is that the name on the badge is inheriting the same font size that is used to display the unread message count badge, but disabling the count badge doesn't seem to fix it.

If I am able to isolate any behavior I'll post an update here, but this is purely coming from trial-and-error testing and not from looking at any code, so I'm hoping someone with a better grasp of how things are coded might have some ideas. The huge name badges are getting quite irritating.

comment:2 Changed 10 years ago by jas8522

  • Status changed from new to pending

Please update to 1.4b15 to see if your problem has been resolved.

comment:3 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:4 Changed 10 years ago by demonbane

I just tested and it looks ok. Thanks!

comment:5 Changed 10 years ago by Robby

Thanks!

comment:6 Changed 10 years ago by demonbane

Dammit. The issue just came back. This is the same version of Adium that was ok for the last few days. The huge name labels are back again, just like before. And it doesn't look like I have permissions to re-open the ticket.

comment:7 Changed 10 years ago by jas8522

  • Milestone set to Known problems which need steps to reproduce
  • Severity changed from normal to minor
  • Status changed from closed to new
  • Version changed from 1.4b9 to 1.4b17

This has occurred for a long time, but we've never been able to reliably reproduce it - it just seems to occur randomly. If anyone else is experiencing this, please attach a screenshot of the dock icon and list how many characters the contact's name it. It's possible we'll be able to find a correlation between name length and possibly other factors that will help solve this bug.

In this case my contact's name is only 4 characters.

It appears that demonbain's contact's name was 5 characters the first time.

I also noticed that just prior to the message that triggered this, his status had changed.

Changed 10 years ago by jas8522

Changed 10 years ago by lucamot

A patch to solve this issue

comment:8 Changed 10 years ago by lucamot

I encountered the same problem mentioned here, dock badge label oversized when showing new messages waiting. I also found a simple way to reproduce it: just hide the dock and receive a new message. When the dock is hidden the rounded blue/white rect is oversized. This is due to a strange value set as default dock image scale in the dock controller.

I attached a patch that solve this issue, however i should also mention that the patch changes the way the rounded rect sizes are calculated: I think this way it is more consistent, since now the icon scale factor is fixed (I traced the original code and I can't find a reason why this should be proportional to dock height, I think it could be just related to the icon like in other similar icons, like Transmission).

If you don't like this patch (as it modifies a feature that can mean something to you :) ) I think it could be a good starting point to investigate this problem, let me know!

comment:9 Changed 10 years ago by Robby

  • Patch Status set to Needs Dev Review

comment:10 Changed 10 years ago by jas8522

  • Milestone changed from Known problems which need steps to reproduce to Adium 1.4.x

comment:11 Changed 10 years ago by Robby

  • Milestone changed from Adium 1.4.x to Adium 1.5

comment:12 Changed 9 years ago by Robby

Ticket #12694 has been marked as a duplicate of this ticket.

comment:13 Changed 9 years ago by npinchot

I hope this may help in reproducing the issue.

My Mac is only a few weeks old. I never had this issue until I did the following: accidentally changed the dock to be positioned on the left side of the screen. I changed it back, but this issue started happening after I did this. (Note: I did reboot and the issue still persists. I am going to try a re-install of the software now.)

comment:14 Changed 9 years ago by npinchot

Additional details on reproducing:

Whenever I move the adium chat window onto my monitor that is being powered by the DisplayLink driver, this issue happens. If I move the contact back to the MBP native display or external powered by the mini display port, all is well.

comment:15 Changed 9 years ago by kbotc

Proper solution:

Rewrite DockController to use NSDockTile and let Apple's API handle all the scaling for us.

comment:16 Changed 9 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In add0c83648a5) Massive changes to dock icon drawing:

  • Use NSDockTile for badging fixes #13439
  • Remove flashing of the contact name* fixes #14452
  • Use a constant size instead of the current screen's size fixes #13088

Fixes #616

*It's superfluous and may have been broken in 1.3 based on the reports from after 1.4 was released.

comment:17 Changed 9 years ago by Robby

  • Patch Status changed from Needs Dev Review to Rejected

Still, thanks for the patch, Luca. :)

comment:18 Changed 9 years ago by demonbane

Any notes on what needs to be done to make that patch acceptable? Reviewing a 2300 line patch in 7 minutes seems like a cursory glance at best.

Being that this bug is nearly 2 years old at this point it would be very nice to see some resolution. (not to mention #616, which has been around for 6 years)

comment:19 Changed 9 years ago by Robby

demonbane,

what happened here is that we rejected the patch attached to this ticket by "lucamot" because an Adium developer, Frank Dowsett, has committed a bigger change that should also fix this particular issue among others. This change will show up in the 1.5hg nightlies. :)

Last edited 9 years ago by Robby (previous) (diff)

comment:20 Changed 9 years ago by demonbane

Aha! I guess I need to read the updates more carefully. Excellent news! :)

Note: See TracTickets for help on using tickets.