Adium

Opened 15 years ago

Closed 15 years ago

Last modified 10 years ago

#1306 closed enhancement (fixed)

Google Talk as Separate Service

Reported by: giusva@bithouseweb.com Owned by: boredzo
Milestone: Adium X 0.85 Component: Service/Google Talk
Version: Severity: minor
Keywords: gtalk Cc: support@…
Patch Status: Accepted

Description

Can you give us the possibility to create a Google Talk account, without passing for Jabber account (in preferences) ?!

http://www.google.com/support/talk/bin/answer.py?answer=24075

Attachments (6)

sample_menu.jpg (21.9 KB) - added by Eoban 15 years ago.
Menu concept
gtalkpatch.diff (34.4 KB) - added by Gayle Laakmann 15 years ago.
Patch to add Google Talk as a seperate service
gtalkPatchFiles.zip (81.7 KB) - added by Gayle Laakmann [gayle at google.com] 15 years ago.
Localizable string files and gtalk icons
Imagen 1.png (69.3 KB) - added by Diatribe 15 years ago.
No icon for Google Talk
talkserviceiconweirdness.png (131.1 KB) - added by Chris Forsythe 15 years ago.
Don't know if this is a problem or not.
googlemail.diff (647 bytes) - added by Gayle Laakmann [gayle at google.com] 15 years ago.
Small change so that @gmail.com isn't appended if @googlemail.com is there.

Download all attachments as: .zip

Change History (71)

comment:1 Changed 15 years ago by Volt

Google Talk IS Jabber. There's no reason it should be listed as a different protocol.

comment:2 Changed 15 years ago by Zachary West

Component: Other ProtocolJabber
Severity: normalminor

I agree. But, I'm not going to close it. Maybe "Google Talk" should be listed (with Jabber icon) with the default GTalk servers filled in? Might be good when voice stuff arrives, and less confusing to newer users. I'll let a dev decide on this one.

comment:3 Changed 15 years ago by Zachary West

Summary: google talkGoogle Talk as Separate Service

comment:4 Changed 15 years ago by giusva@…

ICQ and AIM are also the same protocol, but they're listed anyway as separate entities. Having Google Talk listed separated from Jabber will help new users add the account. I think that if someone will add a Google Talk account, it will be added a Jabber account with the GTalk data filled in.

comment:5 Changed 15 years ago by Peter Hosey

ICQ and AIM have significant differences - they aren't completely identical. Google Talk == Jabber.

comment:6 Changed 15 years ago by anonymous

jeff, don't argue.

comment:7 Changed 15 years ago by Chris Forsythe

Milestone: Adium X 0.85
Version: 0.84

Google talk doesn't have offline messaging, and isn't linked. Plus it'll confuse users less if we just make it separate.

comment:8 Changed 15 years ago by Peter Hosey

OK, now that's a good reason to make it a separate service.

comment:9 Changed 15 years ago by Bryan

ok so ICQ and AIM aren't the same but AIM and .Mac are totally the same they're listed separately. Yes, technically Google Talk is Jabber however do you think a computer novice would know that? I doubt it.

I think it would be great to have Google Talk be it's own account type so that it not only filled in the default Google servers for new users but it also would distinguish itself from other Jabber accounts more easily.

comment:10 Changed 15 years ago by anonymous

comment:11 Changed 15 years ago by Chris Forsythe

If we can make it 1 step instead of 5, it would be nice.

comment:12 Changed 15 years ago by juanjoe@…

And what about icons? I would like a separate icon set for the gtalk account.

comment:13 Changed 15 years ago by Eoban

The issue here is that it's too hard to manage multiple accounts of the same protocol type in Adium right now, and it gets especially screwed up with Google Talk because you can't send or receive messages from other Jabber servers. Adium doesn't always let the user easily pick with which account to send a message, so if a user has an existing Jabber account, the Google Talk account will interfere and the user will get 504 errors if they end up trying to send a message to a @jabber.org user from their GT account, or vice versa. If Google ever allows inter-operability then I don't think it will matter much, but until then I think we can all agree that either way it ought to be easier to pick with which accounts on the same protocol/service to send messages.

comment:14 Changed 15 years ago by anonymous

I think this would be helpful because i had trouble with this, luckly i understand these thing more then some. It should be easy to do. I would like to have this too

comment:15 Changed 15 years ago by adamiser

eobanb brings up an important point.

comment:16 Changed 15 years ago by Evan Schoenberg

Voting support for Google Talk as a separate service, for the reasons described by eobanb. If it were just a configuration issue, I'd say it's okay; but even though it uses the Jabber protocol, it isn't Jabber since there's no interserver connectivity. Users don't care about protocols; they care about function.

Changed 15 years ago by Eoban

Attachment: sample_menu.jpg added

Menu concept

comment:17 Changed 15 years ago by anonymous

Okay, I have an idea about this. In the pop-down menu for creating a new account in the Adium preferences, why not just make Jabber some sort of submenu, or perhaps a category, and include Google Talk has an option? Likewise, you could have an Oscar submenu or category with AIM, ICQ and .Mac as options. I've attached a concept image to illustrate this.

comment:18 Changed 15 years ago by Evan Schoenberg

As I mentioned, users don't care about protocols... 99% of our users have no idea that AIM and ICQ and .Mac are all in a category of OSCAR, and while many of the people early-adopting Google Talk are aware that it is based on the Jabber protocol, it's not particularly relevant information to them.

comment:19 Changed 15 years ago by Synapse

There has been talk of GTalk allowing other servers to link. I don't think we really need GTalk as a separate account type until we reach the stage of voice chat.

comment:20 Changed 15 years ago by anonymous

Google Talk should be listed as a seperate service, rather than forcing novice users to somehow understand that Google Talk is a jabber service and then to go and look up the settings. We want to make it as easy as possible for users to use Adium - especially when it comes to Jabber :-)

Changed 15 years ago by Gayle Laakmann

Attachment: gtalkpatch.diff added

Patch to add Google Talk as a seperate service

comment:21 Changed 15 years ago by Gayle Laakmann [gayle at google.com]

I have submitted a patch to add Google Talk as a seperate service, complete with the relevant icons.

comment:22 Changed 15 years ago by Zachary West

Cc: support@… added

comment:23 Changed 15 years ago by anonymous

Google provides a nice explanation of how to set it up. New users will be able to figure it out.

comment:24 Changed 15 years ago by Peter Hosey

Gayle Laakman: the Localizable.strings files were not included in the patch because they are binary. you will need to zip them up and attach them separately.

comment:25 Changed 15 years ago by Peter Hosey

Owner: changed from nobody to Peter Hosey
Status: newassigned

I volunteer to apply the complete patch.

comment:26 Changed 15 years ago by Evan Schoenberg

Since the Localizable.strings files are generated automatically, I believe the only binary files we need are the images.

Changed 15 years ago by Gayle Laakmann [gayle at google.com]

Attachment: gtalkPatchFiles.zip added

Localizable string files and gtalk icons

comment:27 Changed 15 years ago by Evan Schoenberg

Gayle, I know you're on the gtalk team, but just wanted to be 100% sure: We have legal permission to use the official icons within Adium?

comment:28 Changed 15 years ago by Gayle Laakmann [gayle at google.com]

Absolutely. You have permission to use the google icons within Adium. You may email me at <gayle at google.com> if you wish to confirm that this is coming from a google address.

comment:29 Changed 15 years ago by Peter Hosey

(In [13508]) Committed the patch from Gayle Laakmann on #1306 (refs #1306), to add Google Talk as a separate service in Adium's 'New Account' pull-down menu button. I made these changes:

  • Changed project reference to GaimDefaultsGTalk.plist to refer to it in Plugins/Gaim\ Service.
  • Changed ESJabberAccount changes to not use stringWithFormat: (use stringByAppendingString: instead).
  • Changed use of NSLog to use of AILog (less annoying for the users, and a no-op in non-debug builds).
  • Use DEFAULT_JABBER_HOST in -[ESGaimJabberAccount serverSuffix].
  • Alphabetised GTalkService among the other services in CBGaimServicePlugin.
  • Improved alphabetisation of Icons.plist over the original patch.
  • Renamed new source-code files from ES... to AI....
  • Changed GTalk defaults plist from:
    • Connect Host: login.oscar.aol.com
    • Connect Port: 5190
    • ICQ:Encoding: ISO-8859-1

to:

  • Jabber:Connect Server: talk.google.com
  • Connect Port: 5222
  • Jabber:Resource: Adium

References #1306.

comment:30 Changed 15 years ago by Peter Hosey

(In [13510]) Committed the patch from Gayle Laakmann on #1306 (refs #1306), to add Google Talk as a separate service in Adium's 'New Account' pull-down menu button. I made these changes:

  • Changed project reference to GaimDefaultsGTalk.plist to refer to it in Plugins/Gaim\ Service.
  • Changed ESJabberAccount changes to not use stringWithFormat: (use stringByAppendingString: instead).
  • Changed use of NSLog to use of AILog (less annoying for the users, and a no-op in non-debug builds).
  • Use DEFAULT_JABBER_HOST in -[ESGaimJabberAccount serverSuffix].
  • Alphabetised GTalkService among the other services in CBGaimServicePlugin.
  • Improved alphabetisation of Icons.plist over the original patch.
  • Renamed new source-code files from ES... to AI....
  • Changed GTalk defaults plist from:
    • Connect Host: login.oscar.aol.com
    • Connect Port: 5190
    • ICQ:Encoding: ISO-8859-1

to:

  • Jabber:Connect Server: talk.google.com
  • Connect Port: 5222
  • Jabber:Resource: Adium

Fixes #1306.

comment:31 Changed 15 years ago by David Smith

I can reproduce the blank contact cells issue with this; all GTalk contact are blank.

comment:32 Changed 15 years ago by anonymous

Also you'll want to have Use TLS checked as default in the server config. I also don't see a service icon if I'm supposed to be.

comment:33 Changed 15 years ago by Gayle Laakmann [gayle at google.com]

boredzo - Weren't those already in GaimDefaultsGTalk.plist? As the above comment says, you also need to set the "Jabber:Use TLS" key to true (this was set in GaimDefaultsGTalk.plist)

comment:34 Changed 15 years ago by Evan Schoenberg

(In [13543]) Disabling the TLS checkbox for Google Talk accounts, as it's forced to on. Merged [13542]. Refs #1306'

comment:35 Changed 15 years ago by Gayle Laakmann [gayle at google.com]

Thanks. Could someone please ping me when Adium 0.85 launches so that I can get the appropriate help pages on Google Talk's website updated?

email = gayle at google.com

comment:36 Changed 15 years ago by anonymous

In addition to the service icons missing, GTalk accounts don't seem to be honoring the address book options from preferences as far as using first name, last name, nickname, etc.

comment:37 Changed 15 years ago by Gayle Laakmann [gayle at google.com]

RE: Above comment

I don't believe this bug is specific to GTalk - or is even a bug. What you're probably observing is that if you set an alias to be "John Doe", there is no parsing of first vs last name. Instead, simply "John Doe" is displayed, regardless of your settings. If you create "John Doe" in the addressbook and set the jabber address accordingly, it should be displayed properly. This has been the case for me anyway. But, if you still think this is a bug, it should be filed seperately.

comment:38 Changed 15 years ago by Eoban

Are there any other lingering issues here? I don't think there are.

comment:39 Changed 15 years ago by Chris Forsythe

When there are no more issues with this, we will close the ticket, not before eobanb

comment:40 Changed 15 years ago by Zachary West

Is there any way to make the "Use TLS" checked while it is disabled? Looks as though we're saying "no" and not giving an option (might be confusing?)

comment:41 Changed 15 years ago by Evan Schoenberg

(In [13566]) Setting Jabber:Use TLS to <true/>. Refs #1306

comment:42 Changed 15 years ago by Evan Schoenberg

(In [13567]) Merged [13566]: Setting Jabber:Use TLS to <true/>. Refs #1306

comment:43 Changed 15 years ago by David Smith

The blank contact cells issue seems to have gone away (for me, at least). Possibly due to a clean rebuild.

comment:44 Changed 15 years ago by Peter Hosey

Gayle Laakmann sent me an email about the 'Use TLS' thing, but it was on by default for me anyway, which is why I didn't put it in. weird.

as for the blank contact list cells: #1617.

Changed 15 years ago by Diatribe

Attachment: Imagen 1.png added

No icon for Google Talk

comment:45 Changed 15 years ago by Diatribe

Google Talk has no icon yet, as seen in the picture.

Secondly it doesn't connect at all. It doesn't matter how I enter the info (with @gmail.com or without) it always prompts me to enter my password. I can get into mail account without any problems though. I even tried using the german version of @googlemail.com but that gives me a stream error.

comment:46 Changed 15 years ago by Evan Schoenberg

Diatribe: You're not using the standard status icon pack. Packs need to be updated to have an icon for the new service.

comment:47 Changed 15 years ago by ozean [der.ozean at gmail.com]

evands asked me to post this issue here (taken from the forum on cocoaforge).

My old gmail account works fine with this patch. However, I also have a more recent one which I opened here in Germany. Because of a trademark lawsuit Google had to change the name of its mail service from gmail to googlemail here in Germany - my newer account therefore is a googlemail account (it goes like myname@…).

To connect using the Jabber protocol in Adium .84 I have to enter myname@… in the Jabber ID field. myname@… does not work.

Enter Adium's new Google Talk service: myname@… still does not work. The connection won't be established, it keeps asking me for my password. However, if I try the workaround (myname@…) that allows me to connect using Jabber, I get the following error:

myname@googlemail.com (GTalk): Gaim error
Stream Error

FWIW: I do receive e-mail that sent to myname@… and e-mail that is sent to myname@… (seems they are treated as aliases in that regard).

Changed 15 years ago by Chris Forsythe

Don't know if this is a problem or not.

comment:48 Changed 15 years ago by Chris Forsythe

So I'm using the first beta, and it seems that for metas may not be displaying the correct service icon, but I may be wrong in the diagnosis. geeklove in talkserviceiconweirdness.png has the correct icon, but a lot of the others do not, EarthMKII is a good example.

comment:49 Changed 15 years ago by anonymous

I don't see the service icon at all in the beta

comment:50 Changed 15 years ago by Diatribe

Evands: Thanks, that explains it.

BTW, it seems like an issue with german accounts, since I have the same problems as Ozean connecting to Google Talk.

comment:51 Changed 15 years ago by Evan Schoenberg

(In [13598]) We now fallback on the default service icon to look for a service icon before falling further back on the service icon provided directly by -[AIService defaultServiceIcon]. Fixes #1660. Refs #1306.

comment:52 Changed 15 years ago by Evan Schoenberg

(In [13599]) Merged [13598]: We now fallback on the default service icon to look for a service icon before falling further back on the service icon provided directly by -[AIService defaultServiceIcon]. Fixes #1660. Refs #1306.

comment:53 Changed 15 years ago by Peter Hosey

Resolution: fixed
Status: assignedclosed

bad Trac. no cookie.

comment:54 Changed 15 years ago by Diatribe

Is the connecting issue resolved too? Because I see nothing mentioning this.

comment:55 Changed 15 years ago by Peter Hosey

Resolution: fixed
Status: closedreopened

nope. didn't see it; sorry.

comment:56 Changed 15 years ago by anonymous

For some reason some of my GTalk contacts are showing up as GTalk accounts and some are showing up as Jabber accounts in Adium. I can't seem to figure out a rhyme or reason as to why it's happening.

comment:57 Changed 15 years ago by Evan Schoenberg

Component: JabberGoogle Talk

comment:58 Changed 15 years ago by anonymous

Ok I figured out a reason why they show up as either GTalk or Jabber (at least for me). Anyone who I only have a Jabber (gmail.com) account setup in Address Book will show up in Adium as GTalk. However for anyone I have more than one IM account specified in Address Book they'll show up as Jabber instead.

comment:59 Changed 15 years ago by Gayle Laakmann [gayle at google.com]

Could we move the Google Talk connection problems to a seperate ticket, as it is a distinct problem? I believe the icon problems have been fixed and this ticket can be closed.

By the way - I'm an engineer on the Google Talk team and we are looking into the connection problems for @googlemail accounts. Anything I found out I'll post here.

Changed 15 years ago by Gayle Laakmann [gayle at google.com]

Attachment: googlemail.diff added

Small change so that @gmail.com isn't appended if @googlemail.com is there.

comment:60 Changed 15 years ago by Evan Schoenberg

(In [13632]) Patch from Gayle Laakmann to not append @gmail.com if @googlemail.com is present. Probably fixes connection issues for googlemail.com users. Refs #1306

comment:61 Changed 15 years ago by Evan Schoenberg

(In [13633]) Merged [13632]: Patch from Gayle Laakmann to not append @gmail.com if @googlemail.com is present. Probably fixes connection issues for googlemail.com users. Refs #1306

comment:62 Changed 15 years ago by Evan Schoenberg

(In [13634]) Gmail (and Googlemail) contacts coming in from the Address Book are now properly categorized as GTalk, not as Jabber. Refs #1306

comment:63 Changed 15 years ago by Evan Schoenberg

(In [13635]) Merged [13634]: Gmail (and Googlemail) contacts coming in from the Address Book are now properly categorized as GTalk, not as Jabber. Refs #1306

comment:64 Changed 15 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

I believe all issues in this ticket have now been addressed; I agree with Gayle -- please open a new ticket for any further issues [or for further discussion of issues mentioned here] with GTalk as of 0.85b2 (forthcoming). Thanks (and thanks for the googlemail.diff patch above, Gayle, good catch).

comment:65 Changed 10 years ago by Robert

Patch Status: Accepted
Note: See TracTickets for help on using tickets.