Adium

Opened 10 years ago

Closed 9 years ago

#12916 closed defect (fixed)

VoiceOver problem with contact list, VoiceOver problem with message edit box

Reported by: Orinks Owned by: wixardy
Milestone: Adium 1.5 Component: Adium UI
Version: 1.3.6 Severity: normal
Keywords: VoiceOver Accessibility contacts message edit field Cc:
Patch Status:

Description (last modified by wixardy)

On Mac OS X 10.6.6 Snow Leopard, the VoiceOver screen reader has problems with the contact list and the message box for typing. Here is what I've found.

When arrowing up and down in the contact list, VoiceOver says "empty" before each contact. It will also, after using the up and down arrows after a time, stop speaking when they are pressed, making the user press the VoiceOver keys (Control Option), or make the user interact with the table to get the contact information, however the VoiceOver keys still must be used.

A more critical issue, however, is the message edit field. From testing, I have not been able to review what I have typed in. Also, pressing return sends the message, or is supposed to, but sometimes this isn't the case. I think it may have something to do with VoiceOver.

I hope this helps. I've always liked Adium, but this has been going on since Snow Leopard.

Thanks.

Change History (3)

comment:1 Changed 9 years ago by Robby

  • Keywords Accessibility added

comment:2 Changed 9 years ago by wixardy

  • Description modified (diff)
  • Milestone set to Adium 1.5
  • Owner set to wixardy
  • Status changed from new to assigned
  1. VoiceOver says "empty" before each contact
    • Confirmed
  2. It will also [...] stop speaking
    • I couldn't reproduce
  3. message edit field [...] [un]able to review what I have typed in
    • Works fine for me
  4. pressing return sends the message [not all the time]
    • Works fine for me

Therefore I'm limiting this to just item 1.

comment:3 Changed 9 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

(In 814c67ba82e1) A start on fixing VO; first up: contact list. The role being set (row) is not what it should be (static text).

Fixes #12916 and #9004 Refs #15115

Note: See TracTickets for help on using tickets.