Adium

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#12856 closed defect (fixed)

& character in URLs breaks log viewer

Reported by: NeQuissimus Owned by:
Milestone: Component: Logging
Version: Severity: regression
Keywords: and character log Cc:
Patch Status:

Description

Sending links that include the & character (in their GET parameters) cause the log viewer not to show anything. You can still find the entire log in the xml file, so that it can only be a problem with the log viewer itself.

I am attaching a log file that has this exact problem as well as a picture of what happens in the log viewer.

Attachments (2)

272952260 (2009-08-22T16.16.24+0200).xml (2.1 KB) - added by Tim Steinbach 11 years ago.
log file with & character in its URL
Screen shot 2009-08-23 at 11.38.24 AM.png (403.4 KB) - added by Tim Steinbach 11 years ago.
There is nothing in the log viewer.

Download all attachments as: .zip

Change History (20)

Changed 11 years ago by Tim Steinbach

log file with & character in its URL

Changed 11 years ago by Tim Steinbach

There is nothing in the log viewer.

comment:1 Changed 11 years ago by Tim Steinbach

I forgot to say: If you delete the & characters from the xml file, the entire log shows up in the log viewer, except that the links are not working properly anymore, of course. So I am pretty sure it is a problem with the & character...

comment:2 Changed 11 years ago by Frank

3855f70905bd makes logs no longer save & as &

comment:3 Changed 11 years ago by Tim Steinbach

I just updated to 1.4hgr2625 which is supposed to include this fix. Now the URL in the href property of the <a> tag is saved with & instead of &amp and the text within <a> and </a> still uses &amp. The problem seems to be more general, though. The Adium log viewer has a problem with the & character itself. & breaks a log as well as &amp. Even &quot does.

I do not believe this is a problem with logging itself. The problem seems to be located in the log viewer. (my guess without knowledge of the Adium code)

comment:4 Changed 11 years ago by Stephen Holt <sholt@…>

Resolution: fixed
Status: newclosed

(In 07e07f9788a6) Undo the part of [3855f70905bd]: It caused strings to be incorrectly escaped and causing our XML parsing to break. Rather, escape hash-symbols when parsing in XML data as not to confuse AIHTMLDecoder. Refs #8141. Fixes #12856.

comment:5 Changed 11 years ago by Martin

I'm experiencing the same bug, 2 logs aren't showing in the Log Viewer, but the logs are there... both have posted URLs with ampersands. If opening the XML file in Safari, it says: error on line 2 at column 1117: EntityRef: expecting ';' where the column of course changes for the 2 documents, and Safari only renders up until the error, just before the posted URL, which naturally does contain an ampersand. For instance, one of the log files break here: <a href="http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&fcategoryid=2610&modelid=13368#DownloadDetailAct" style="font-family: Helvetica; font-size: 12pt;">http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&amp;fcategoryid=2610&amp;modelid=13368#DownloadDetailAct</a>

Applying the above fix to simply replace the & in the entity to &amp; works a treat.

Using Adium 1.4b9

comment:6 Changed 11 years ago by Tim Steinbach

Don't worry, the next beta should fix the issue as the current nightly does already, I tested it myself. Works like a charm :)

comment:7 Changed 11 years ago by Stephen Holt

Milestone: Adium 1.4
Version: 1.4hg1.4b9

comment:8 Changed 11 years ago by Robert

Milestone: Adium 1.4

Wasn't this a b9 regression?

comment:9 Changed 11 years ago by Frank

Ticket #12957 has been marked as a duplicate of this ticket.

comment:10 Changed 11 years ago by Robert

Ticket #12972 has been marked as a duplicate of this ticket.

comment:11 Changed 11 years ago by Robert

Severity: normalregression

comment:12 Changed 11 years ago by Robert

Ticket #13037 has been marked as a duplicate of this ticket.

comment:13 Changed 11 years ago by Frank

Ticket #13075 has been marked as a duplicate of this ticket.

comment:14 Changed 10 years ago by Frank

Ticket #13098 has been marked as a duplicate of this ticket.

comment:15 Changed 10 years ago by assetburned

Any idea when the next beta will be out? Slowly this but is getting very annoying. this one and the bug reported in http://trac.adium.im/ticket/13097 together they can drive you crazy!

comment:16 Changed 10 years ago by Stephen Holt

Ticket #12903 has been marked as a duplicate of this ticket.

comment:17 Changed 10 years ago by Stephen Holt

Ticket #13162 has been marked as a duplicate of this ticket.

comment:18 Changed 10 years ago by Robert

Ticket #13168 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.