Adium

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#12774 closed defect (fixed)

Contact tooltips show through other windows

Reported by: opnop123 Owned by:
Milestone: Adium 1.5 Component: Adium UI
Version: 1.3.5 Severity: normal
Keywords: Cc:
Patch Status: Accepted

Description

This is a special case of ticket #1156:

I still see this on 1.3.5.

  • adium is hidden (CMD-h), and another app open (often Safari in my case)


  • contact tooltips pop up on the topmost app when i hover where adium was positioned before I hid it

I can reproduce it almost every time on two computers with OS X 10.5.8. Although this is a cosmetic bug, maybe it should not be classified as minor since it's frequent and disruptive.

Thanks

Attachments (2)

ticket12774.diff (1.5 KB) - added by meestaplu 9 years ago.
ticket12774_2.diff (1.2 KB) - added by meestaplu 9 years ago.
Second take…

Download all attachments as: .zip

Change History (19)

comment:1 Changed 10 years ago by opnop123

Reproduced with 1.3.6 on OSX 10.6.1.

comment:2 Changed 10 years ago by opnop123

Here's another observation on this bug. I have a habit of hiding programs with Cmd-H so I didn't realise until now that Adium had a sweet auto-hide feature (simply click focus an another program and the contacts window disappears).

So here's a distinction: When I hide Adium by simply clicking focus on another program, the bug NEVER shows. When I hide Adium with Cmd-H, the bug SOMETIMES shows.

Changed 9 years ago by meestaplu

comment:3 Changed 9 years ago by meestaplu

I attached a fix for this ticket. This prevents contact list tooltips from being shown if the app is hidden or if the contact list window is hidden.

comment:4 Changed 9 years ago by Robby

  • Milestone set to Adium 1.4.1
  • Patch Status set to Needs Dev Review

comment:5 Changed 9 years ago by wixardy

  • Patch Status changed from Needs Dev Review to Needs Changes by Author
  1. [contactListView isHiddenOrHasHiddenAncestor] is only true when the whole app is hidden.
  2. tooltips aren't being shown when Adium is in the background.

Changed 9 years ago by meestaplu

Second take...

comment:6 Changed 9 years ago by meestaplu

Thanks for looking at my previous patch. I simplified the logic in this one.

On my 10.4 and 10.6 systems:

  • I always see the bug when hiding Adium with Cmd+H if the contact list is set to hide when Adium is in the background.
  • I always see the bug if I Cmd+Tab away from Adium if the contact list is set to hide when Adium is in the background.

Otherwise, I never see it.

So, I modified the patch to check if the contact list view window hides on deactivate.

With the change in place, I can:

  • see tooltips with Adium in the foreground (if pref is set)
  • see tooltips with Adium in the background (if pref is set and window is showing on screen)
  • not see tooltips if Adium is in the background and the window is hidden

comment:7 Changed 9 years ago by Matthew Plough <matt.plough@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 76220f2da71d) Made contact list tooltips appear only at appropriate times. Fixes #12774

r=wix

comment:8 Changed 9 years ago by wixardy

  • Patch Status changed from Needs Changes by Author to Accepted

comment:9 Changed 9 years ago by Robby

  • Milestone changed from Adium 1.4.1 to Adium 1.5

comment:10 Changed 9 years ago by eXcuvator

it can also be reproduced with other windows of adium

comment:11 Changed 9 years ago by Robby

Ticket #14138 has been marked as a duplicate of this ticket.

comment:12 Changed 9 years ago by wixardy

Ticket #13113 has been marked as a duplicate of this ticket.

comment:13 Changed 9 years ago by Robby

Ticket #11661 has been marked as a duplicate of this ticket.

comment:14 in reply to: ↑ description Changed 8 years ago by wollkind

This issue is not fixed and this ticket should be reopened. I can reproduce this reliably on Adium v 1.4.2b and Mac OS X 10.6.7. Steps are as follows:

  1. Set contact list to automatically hide in background.
  2. Place mouse into contact list area
  3. Cmd-tab to another application (you need not wait for tooltip to appear)
  4. At this point the buggy behavior is 'locked in' and you can get tooltips from the area where the buddy list had previously been, regardless of what other apps you activate. The only way to clear the behavior is to bring adium back to the front and make sure that the mouse is not in the buddy list area when you cmd-tab away.

I find this behavior more than a little annoying, so I wouldn't reduce the severity of this bug, but that's just me.

Replying to opnop123:

This is a special case of ticket #1156:

I still see this on 1.3.5.

  • adium is hidden (CMD-h), and another app open (often Safari in my case)


  • contact tooltips pop up on the topmost app when i hover where adium was positioned before I hid it

I can reproduce it almost every time on two computers with OS X 10.5.8. Although this is a cosmetic bug, maybe it should not be classified as minor since it's frequent and disruptive.

Thanks

comment:15 follow-up: Changed 8 years ago by Robby

This issue is milestoned for Adium 1.5 so you can't really expect this to be fixed in 1.4.x.

comment:16 in reply to: ↑ 15 Changed 8 years ago by wollkind

Replying to Robby:

This issue is milestoned for Adium 1.5 so you can't really expect this to be fixed in 1.4.x.

Well, original issue #1156 was milestoned for adium 1.1 or 1.2 and marked fixed when it is clearly not, so I wasn't sure what the story really is. I'll make a note to check on it when 1.5 is out.

Last edited 8 years ago by wixardy (previous) (diff)

comment:17 Changed 8 years ago by Robby

You could try a nightly as well: http://nightly.adium.im/.

Note: See TracTickets for help on using tickets.