Adium

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#12339 closed patch (fixed)

Handle irc:// URIs by creating guest accounts

Reported by: SidneySM Owned by: zacw
Milestone: Adium 1.4.1 Component: Service/IRC
Version: 1.4b6 Severity: normal
Keywords: uri, irc, guest Cc:
Patch Status: Accepted

Description

Right now, when an irc:// URI is handled and Adium does not have an account for that IRC server, an alert, "Unable to join the channel channel, no account exists for server server", is displayed.

I propose that in this case Adium opens a Connect Guest Account window pre-populated with that server and set to join the channel provided in the URL (if present).

Attachments (1)

TemporaryIRCAccounts.hgbundle (15.8 KB) - added by sphynx 10 years ago.
As I said on #13913: A patch I made for this. This was made using hg bundle, as there are binary files involved, but this is the first time I did that, so I hope everything went okay. =)

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by SidneySM

Please make this an enhancement, I missed that dropdown when submitting.

comment:2 Changed 10 years ago by Robby

  • Type changed from defect to enhancement

comment:3 Changed 10 years ago by fuzzy76

Absolutely, this makes the irc:// protocol support pretty useless IMHO

comment:4 Changed 10 years ago by Robby

  • Milestone set to Adium 1.4

I agree.

comment:5 Changed 10 years ago by zacw

  • Milestone changed from Adium 1.4 to Adium 1.5

Pushing to 1.5. I agree, but I don't think we have the time to write it for 1.4.

comment:6 Changed 10 years ago by Dimmuxx

Ticket #13913 has been marked as a duplicate of this ticket.

Changed 10 years ago by sphynx

As I said on #13913: A patch I made for this. This was made using hg bundle, as there are binary files involved, but this is the first time I did that, so I hope everything went okay. =)

comment:7 Changed 10 years ago by Dimmuxx

  • Milestone changed from Adium 1.5 to Adium 1.4
  • Patch Status set to Needs Dev Review
  • Type changed from enhancement to patch

comment:8 Changed 10 years ago by evands

  • Milestone changed from Adium 1.4 to Adium 1.4.x

This is a fantastic idea, and I'm very excited to a see that you've contributed a patch to implement it.

Adium 1.4 is frozen except for major bug fixes, given that it is late in its beta cycle. Let's please review and commit this ASAP after 1.4 is released, for inclusion in Adium 1.4.1.

comment:9 Changed 10 years ago by Robby

  • Milestone changed from Adium 1.4.x to Adium 1.4.1

comment:10 Changed 10 years ago by sphynx

When attempting to get to know MQ a bit better in mercurial, I realized this bundle will probably only apply cleanly when my patch on #13899 is applied too. Also, they're kind of related, so I would strongly suggest applying that one first.

comment:11 Changed 9 years ago by evands

Actually, your bundle included the patch from #13899, too. (Which I figured out after I had committed it separately - so I made a bit of a mess with the merge).

comment:12 Changed 9 years ago by evands

  • Patch Status changed from Needs Dev Review to Accepted
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [8b2a6ff84514] and [0b8dc56dec63] - thanks :)

comment:13 Changed 9 years ago by Evan Schoenberg

(In dc87ab524a41) Fixed a warning introduced in 8b2a6ff84514. Refs #12339

Note: See TracTickets for help on using tickets.