Adium

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#12237 closed defect (fixed)

Minor redraw problem in 'Info' window when scrolling using trackpad

Reported by: mdudziak Owned by:
Milestone: Adium 1.5 Component: Adium UI
Version: 1.4b4 Severity: minor
Keywords: Cc:
Patch Status:

Description

The problem is that the Info window does not redraw correctly and ends up getting highlight ring artifacts when scrolled using two-finger scrolling on a MacBook Pro. Does not happen (for me) when using the scroll bar or moving the scroll thumb.
To reproduce:

  • Open the Info window for a contact (right click contact and select Get Info)
  • Click on the address book icon on the top
  • Click on the notification icon (the red police light icon) on the top
  • Scroll down and then scroll up using two finger scrolling (important as I cannot reproduce using scroll arrows or using the scroll thumb. MIGHT work if using a scroll wheel but I do not have one to test)
  • Note the artifacts left by the highlight ring around the icon.

See attached image for an example of the problem.

Attachments (3)

Picture 2.png (89.3 KB) - added by mdudziak 10 years ago.
Imae showing redraw problem for ticket #12237
Screen Shot 2012-01-09 at 03.41.08.png (173.7 KB) - added by paulwilde 8 years ago.
Bug in 1.4.4
Screen Shot 2012-01-09 at 03.16.22.png (82.7 KB) - added by paulwilde 8 years ago.
Bug in 1.5b9

Download all attachments as: .zip

Change History (23)

Changed 10 years ago by mdudziak

Imae showing redraw problem for ticket #12237

comment:1 Changed 10 years ago by mdudziak

I should note that this is 100% reproducible for me.

comment:2 Changed 10 years ago by zacw

  • Milestone set to Adium 1.4
  • Severity changed from normal to minor

comment:3 Changed 10 years ago by jas8522

I cannot reproduce this, however I have been able to reproduce a seemingly related issue (for many months) wherein the 1px border/divider between the 'tabs' for the inspector and the list of events disappears when scrolling down. The only place it remains is between the scrollbar and the tabs.

comment:4 Changed 10 years ago by mdudziak

Odd. I have no trouble reproducing this, though as I indicated in the original report I only see it when I use 2-finger scrolling on my MacBook Pro. Don't see it when using the scroll thumb or scroll arrows. Also, it is important to select an icon other than the notification icon (the red light) then select the notification icon again. This causes the icon to get the focus ring around it (the icon does NOT have a focus ring when the window is first opened).

It is not a big deal, obviously. Just a very minor annoyance.

Matt

comment:5 follow-up: Changed 10 years ago by jas8522

mdudziak: what version of OS X are you using?

comment:6 follow-up: Changed 10 years ago by zacw

This happens when you have keyboard control set to "all controls" (focus ring around segments at the top) and slowly scroll with the trackpad, which means something is clipping weirdly.

comment:7 in reply to: ↑ 5 Changed 10 years ago by mdudziak

Replying to jas8522:

mdudziak: what version of OS X are you using?

I'm running 10.5.7.

comment:8 in reply to: ↑ 6 Changed 10 years ago by mdudziak

Replying to zacw:

This happens when you have keyboard control set to "all controls" (focus ring around segments at the top) and slowly scroll with the trackpad, which means something is clipping weirdly.

YES! Good catch.

Toggling keyboard access off makes the redraw problem go away for me. I also find that if I scroll very slowly I see the problem, but even if I scroll fast I see the problem (just looks different). I don't use full keyboard access anyway so I'll turn that option off.

Thanks, Matt

comment:9 Changed 10 years ago by jas8522

  • Status changed from new to pending

I have set my keyboard controls to "all controls" and attempted to reproduce, but could not. The problem I had mentioned that is very similar is also not reproducible any longer with 1.5hgr2776 05e1 (last four of hash) on 10.6.1.

Can anyone else still reproduce this?

comment:10 Changed 10 years ago by mdudziak

  • Status changed from pending to new

I am no longer seeing this as well, though I have since upgraded to Snow Leopard.

comment:11 Changed 10 years ago by jas8522

  • Milestone Adium 1.4 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

comment:12 Changed 8 years ago by paulwilde

  • Resolution cantreproduce deleted
  • Status changed from closed to new

I'm able to reproduce this every time with the exact same steps as noted in the OP. I'm also seeing it inside the Chat Transcript Viewer when searching through logs and having the bar active.

Seeing this in 1.4 and 1.5b9 whilst using a Magic Mouse to scroll.

Toggling the keyboard controls as suggested above fixes nothing and the problem is still present.

This only happens with the Lion type scrollbars. With the old type the bug does not show.

Last edited 8 years ago by paulwilde (previous) (diff)

Changed 8 years ago by paulwilde

Bug in 1.4.4

Changed 8 years ago by paulwilde

Bug in 1.5b9

comment:13 Changed 8 years ago by paulwilde

  • Milestone set to Adium 1.5.1

Frank said he'll take a look into it.

Last edited 8 years ago by paulwilde (previous) (diff)

comment:14 Changed 8 years ago by Adrian Godoroja <robotive@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 1b09628c7733) Minor redraw problem in 'Get Info -> Events' window when scrolling. Fixes #12237.

comment:15 Changed 8 years ago by Adrian Godoroja <robotive@…>

(In 62403b7e52d5) Fixed ghosting artifacts when scrolling transcript contents (when searching). Refs #12237.

comment:16 Changed 8 years ago by robotive

  • Milestone changed from Adium 1.5.1 to Adium 1.5

comment:17 Changed 8 years ago by Robby

According to CFM these glitches could "be caused by the view not being sized correctly (non-integral bounds, or not-/over-filling its containing scrollview, iirc)". Might be worth investigating so as to achieve a more appropriate fix.

comment:18 Changed 8 years ago by Adrian Godoroja <robotive@…>

(In 7daaf623be3e) A better way of solving draw artifacts in 'Get Info -> Events' window when scrolling. Refs #12237.

comment:19 Changed 8 years ago by Adrian Godoroja <robotive@…>

(In 613655f74c99) A better way of solving draw artifacts in Chat Transcripts window when scrolling. Also minor position/size fixes to 'Get Info -> Events' . Refs #12237.

comment:20 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

(In 8edee52101a8) Rounded all other cases of non-integer view sizes I could find, though I don't think any contain scrollviews.

Refs #12237

Note: See TracTickets for help on using tickets.