Adium

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#12129 closed enhancement (fixed)

Opening links in the background

Reported by: fordred Owned by:
Milestone: Adium 1.5 Component: Adium UI
Version: Severity: normal
Keywords: url, background Cc:
Patch Status: Accepted

Description

Similar to Mail, clicking on a link whilst holding the Cmd key should open the link (a URL normally) in the background instead of bringing Safari to the front. Also the option of right-clicking and choosing "Open link behind Adium", similar to Mail, would be appreciated.

Attachments (2)

patch.diff (1.6 KB) - added by Aaron Dodson 10 years ago.
Patch to open links in the background
bglinkpatch.diff (1.2 KB) - added by Aaron Dodson 10 years ago.
Patch to open links in the background using [NSEvent cmdKey]

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Daniel Bergman

Component: AutoHyperlinksAdium UI
Owner: Stephen Holt deleted

comment:2 Changed 11 years ago by Jordan

Milestone: Adium 1.5

Changed 10 years ago by Aaron Dodson

Attachment: patch.diff added

Patch to open links in the background

comment:3 Changed 10 years ago by Zachary West

Patch Status: OK; Needs Check-In

This looks good. You should use our +[NSEvent cmdKey] instead of grabbing the modifier keys yourself, but the patch seems good otherwise.

Changed 10 years ago by Aaron Dodson

Attachment: bglinkpatch.diff added

Patch to open links in the background using [NSEvent cmdKey]

comment:4 Changed 10 years ago by Robert Vehse

Resolution: fixed
Status: newclosed

(In 0cdde1d4377a) Changelog Aaron Dodson's patch. Fixes #12129.

comment:5 Changed 10 years ago by Robert

Patch Status: OK; Needs Check-InAccepted

Thanks, Aaron! :)

comment:6 Changed 10 years ago by Thijs Alkemade

Ticket #14592 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.