Adium

Opened 15 years ago

Closed 13 years ago

Last modified 9 years ago

#12 closed defect (fixed)

Tab bar needs a chevron when the tabs overflow the bar

Reported by: tick Owned by: ksuther
Milestone: Adium X 1.1 Component: SoC-PSMTabs
Version: Severity: normal
Keywords: fixedinpsm Cc:
Patch Status:

Description

Tab bar needs a chevron when the tabs overflow the bar

Change History (15)

comment:1 Changed 15 years ago by Evan Schoenberg

Component: component1AIUtilities.framework

comment:2 Changed 15 years ago by Eoban

This is *sort of* fixed in 0.83, because now the tabs get as small as they need to so that they all fit in the space available. However, it'd be nice to have various options (resizing, scrolling, overflowing onto a second row, auto window resizing) for dealing with lots of tabs.

comment:3 Changed 15 years ago by Augie Fackler

Milestone: Adium X 1.0Adium X 0.90

Discussed with Evan, decided that a minimum width of 64 pixels seems sensible.

comment:5 Changed 14 years ago by Peter Hosey

comment:6 Changed 14 years ago by Peter Hosey

we can use the built-in image at /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/Resources/ToolbarChevron.png.

comment:7 Changed 14 years ago by David Smith

Owner: AdamIser deleted

comment:8 Changed 14 years ago by David Smith

field_haspatch: 0
priority: lowestnormal

comment:9 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.0Sometime after 1.0

comment:10 Changed 14 years ago by David Smith

PSMTabBarControl is in the ChatKit repository, and supports this. However, it still needs some work to match AICustomTabsView in other areas.

comment:11 Changed 14 years ago by Chris Forsythe

Milestone: Sometime after 1.0Adium X 1.4

Unless SoC covers this, we should visit it with 1.4

comment:12 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.4Adium X 1.1
Owner: set to Kent Sutherland

Kent Sutherland will be implementing PSMTabBarControl as part of the Summer of Code.

comment:13 Changed 13 years ago by Kent Sutherland

Component: AIUtilities.frameworkSoC-PSMTabs
Keywords: fixedinpsm added
Owner: changed from Kent Sutherland to Kent Sutherland
Status: newassigned

Fixed in PSMTabBarControl.

comment:14 Changed 13 years ago by Chris Forsythe

Resolution: fixed
Status: assignedclosed

Since it's fixed in psmtabbarcontrol, closing.

comment:15 Changed 9 years ago by mathuaerknedam

Ticket #13971 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.