Adium

Opened 12 years ago

Closed 10 years ago

#11676 closed defect (wontfix)

Adium only showing Facebook User IDs

Reported by: andrewjkm Owned by: evands
Milestone: Component: Service/Facebook
Version: Severity: normal
Keywords: Facebook User IDs Cc:
Patch Status:

Description

On startup, Adium is only showing Facebook User IDs for my contacts.

If I delete the FB account and then set it up again, contact Aliases are again shown.

Adium 1.3.3rc1, Mac OS 10.4.11

Attachments (2)

Picture 3.png (36.5 KB) - added by mwdigian 12 years ago.
adiumbug.jpg (38.8 KB) - added by Sandy Nicholson 11 years ago.
See my comment on the problem persisting in 1.3.4b1.

Download all attachments as: .zip

Change History (30)

comment:1 Changed 12 years ago by Robert

Component: Adium CoreFacebook Chat
Owner: nobody deleted

comment:2 Changed 12 years ago by Andrew

Alias only remain until Adium quits. On relaunch, they are back to the Used IDs only.

This appears to affect offline contacts. The User ID is replaced by the alias as soon as the contact comes online.

comment:3 Changed 12 years ago by Ned

It appears that we've gone from using Facebook Display Names to using Facebook ID numbers and hiding the display names away.

This should be changed back - average users do not want to bother with ID numbers. They're never visible on Facebook, they should not be here either.

comment:4 Changed 12 years ago by Evan Schoenberg

That's the first time someone's mentioned that they are seeing this only with offline contacts. Is that what you've seen, as well, 4am?

comment:5 Changed 12 years ago by heykay15

Facebook contacts now appear as only #s or UIDs. All contacts, not just offline facebook contacts appear as UIDs.

Changed 12 years ago by mwdigian

Attachment: Picture 3.png added

comment:6 Changed 12 years ago by mwdigian

I am getting the same problem and am using 1.3.3

I've attached an image of the problem.

comment:7 Changed 12 years ago by mwdigian

When opening up a chat with one of the accounts, it shows their full name (no account number). In the buddy list, however, it only shows the account number.

comment:8 Changed 12 years ago by Evan Schoenberg

Milestone: Adium 1.3.4
Owner: set to Evan Schoenberg
Status: newassigned

comment:9 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [25995]) Treat the Facebook alias as a formatted UID, as we never want to see that random string of numbers. Fixes #11676

comment:10 Changed 12 years ago by Evan Schoenberg

(In [25996]) Merged [25995]: Treat the Facebook alias as a formatted UID, as we never want to see that random string of numbers. Fixes #11676

comment:11 Changed 11 years ago by Sandy Nicholson

I don’t think this is fixed.

In older versions, everything was fine, but in version 1.3.3 there was definitely a problem, in that the only way I could find to associate Facebook IDs with names (and to group people with multiple accounts properly) was to do a quick ⌘I and run through all the stray Facebook IDs at startup. (When the info was displayed, the ID became a proper name, joining the ranks of online Facebook users.)

I read somewhere that 1.3.4b1 fixed this problem (or perhaps it was another, similar problem?), and so I downloaded that, but it behaves exactly the same way for me. I will attach a screenshot from the beta (with identities disguised by blurring).

Changed 11 years ago by Sandy Nicholson

Attachment: adiumbug.jpg added

See my comment on the problem persisting in 1.3.4b1.

comment:12 Changed 11 years ago by Zachary West

The users in question will have to sign on then off first for their name to be saved. If that doesn't fix it, then yeah, it's still broken.

comment:13 Changed 11 years ago by Sandy Nicholson

OK – thanks! I hadn’t realised that. I will reserve judgement until I see whether names gradually begin to be paired up with IDs. I did just quit and restart Adium (1.3.4b1) and noticed that one of my Facebook friends last signed off 20 minutes ago (i.e. well after I upgraded to the current beta) and yet their entry still appears as a numeric ID. Another entry is paired up, though, despite the user being offline at the moment. Perhaps the first user was already signed on to Facebook from earlier on when I started using the new version. (Does the fresh sign-on have to happen while Adium is running?)

comment:14 Changed 11 years ago by Sandy Nicholson

Just to update you, I’m still seeing this issue after about four days of using 1.3.4b1. For some of my Facebook friends, their names do seem to remain associated with the relevant Facebook IDs (which is good!), but:

  • there are several that have last-seen status ‘online’ or ‘signing off’ within the last couple of days and yet still show up with only numeric IDs (unless I force Adium to update by checking info)
  • I have at least one Facebook friend who currently doesn’t show up at all within my contact list
  • even among those Facebook friends whose IDs are correctly associated with names, most of those still show the numeric IDs in places where the IDs/screen names appear for other IM services.

comment:15 Changed 11 years ago by Sandy Nicholson

In the final 1.3.4, this problem persists. I have tried removing my Facebook account from Adium (in the Preferences pane) and reinstating it. There are some Facebook accounts that are immediately associated with users’ names, while others (around a quarter of my Facebook friends) are not. Furthermore, I just did a count of the contacts that Adium sees, and it seems that nearly a quarter of my Facebook friends don’t even show up on Adium at all (as numbers or names).

Are others seeing this, or do I need to reset anything else to get 1.3.4 working the way I'd expect it to? (I'm reluctant to trash any preferences etc., as I don't want to lose any chat transcripts or information relating to other IM accounts.)

comment:16 Changed 11 years ago by Peter Hosey

Milestone: Adium 1.3.4Adium 1.4
Resolution: fixed
Status: closednew

Several users are still seeing this.

comment:17 Changed 11 years ago by Peter Hosey

Ticket #12310 has been marked as a duplicate of this ticket.

comment:18 Changed 11 years ago by Peter Hosey

Ticket #12384 has been marked as a duplicate of this ticket.

comment:19 Changed 11 years ago by Peter Hosey

A user named “pawz” has sent a debug log to the feedback address.

comment:20 Changed 11 years ago by Ariel Chinn

BTW, it hasn't been mentioned here, but this behaviour also exists in the Chat Transcript Viewer's source list. That is, all FB contacts are represented by their ID # and not by their name, but in the actual logs their real name is used.

comment:21 Changed 11 years ago by Robert

Milestone: Adium 1.4Adium 1.3.6

comment:22 Changed 11 years ago by Robert

Ticket #11800 has been marked as a duplicate of this ticket.

comment:23 Changed 11 years ago by Robert

Milestone: Adium 1.3.6Adium 1.3.7

1.3.6 has been released.

comment:24 Changed 11 years ago by Robert

Milestone: Adium 1.3.7Adium 1.3.8

comment:25 Changed 11 years ago by Robert

Milestone: Adium 1.3.8Adium 1.3.9

comment:26 Changed 11 years ago by Robert

Milestone: Adium 1.3.9Adium 1.3.11

comment:27 Changed 10 years ago by Evan Schoenberg

Milestone: Adium 1.3.11Adium 1.4

comment:28 Changed 10 years ago by Evan Schoenberg

Milestone: Adium 1.4
Resolution: wontfix
Status: newclosed

We'll be moving to XMPP based Facebook in the future.

Note: See TracTickets for help on using tickets.