Adium

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#11602 closed defect (fixed)

Showing/hiding an emoticon causes chat text not to rearange in chat window

Reported by: xja Owned by:
Milestone: Adium 1.3.3 Component: Message View
Version: Severity: normal
Keywords: Cc:
Patch Status: Accepted

Description

After hiding a large emoticon the chat frame (in smooth operator message style) do resize but a blank space is added at the bottom of the window, so the message previuos to that with the emoticon stays stuck with its position and the following "floats" over the bottom. Here's the aspect of the "floating" message. Bye

Attachments (2)

Immagine 2.png (13.4 KB) - added by xja 11 years ago.
templateHtml.diff (4.7 KB) - added by mathuaerknedam 11 years ago.
patch for 1.3 and 1.4

Download all attachments as: .zip

Change History (16)

Changed 11 years ago by xja

Attachment: Immagine 2.png added

comment:1 Changed 11 years ago by xja

There's also to say that this behaviour doesn't happen when the scrollbar is present. Bye

comment:2 Changed 11 years ago by mathuaerknedam

Milestone: Needs feedback from users
pending: 01

So this happens with the builtin Smooth Operator message style? What emoticon set? A particular emoticon or any of them? I need to know exactly how to replicate your problem.

comment:4 Changed 11 years ago by xja

pending: 10

This happened with Monkey Icons Refined, the emoticon was triggered by a "mmm" within the text.
Bye

comment:5 Changed 11 years ago by mathuaerknedam

I started a new chat with Smooth Operator and Monkey Icons Refined. I typed "mm" pressed enter and saw the monkey icon. I clicked on the icon and it changed to "mm". I clicked on it again and it changed back into the monkey icon. Never was there a gap. I cannot reproduce the problem, is it consistent for you?

comment:6 Changed 11 years ago by mathuaerknedam

pending: 01

comment:7 Changed 11 years ago by xja

pending: 10

It's still there in b3, it happens also with smaller emoticons.
I have a MacBook (1,1) with Mac OSX 10.5.6.
bye

comment:8 Changed 11 years ago by mathuaerknedam

It happens every time?

comment:9 Changed 11 years ago by xja

It seems so...

comment:10 Changed 11 years ago by mathuaerknedam

Aha! I can now reproduce this, but only when there is no scrollbar. Can you confirm that the problem goes away when there is a vertical scrollbar?

comment:11 Changed 11 years ago by mathuaerknedam

I found the problem and I'm in the process of making a patch.

Changed 11 years ago by mathuaerknedam

Attachment: templateHtml.diff added

patch for 1.3 and 1.4

comment:12 Changed 11 years ago by Robert

Milestone: Needs feedback from usersAdium 1.3.3
Patch Status: NoneNeeds Dev Review

comment:13 Changed 11 years ago by mathuaerknedam

The patch does three things, though only one of them is necessary to fix this bug.

  • I replaced the bits of indentation by spaces with indentation by tabs.
  • I removed all instances of <tab><newline> with <newline> (in accordance with CodingStyle).
  • I added to the function imageCheck:
var shouldScroll = nearBottom(); 

and

alignChat(shouldScroll); 

comment:14 Changed 11 years ago by David Smith

Resolution: fixed
Status: newclosed

(In [25829]) Patch from mathuaerknedam that fixes #11602

comment:15 Changed 11 years ago by Robert

Patch Status: Needs Dev ReviewAccepted

Merged to branch in [25830].

Note: See TracTickets for help on using tickets.