Adium

Opened 14 years ago

Closed 12 years ago

Last modified 10 years ago

#1156 closed defect (fixed)

When the contact list is hidden the tooltip of a contact still shows

Reported by: shamusom@mac.com Owned by: boredzo
Milestone: Adium 1.2.5 Component: Adium UI
Version: Severity: minor
Keywords: hidden space spaces leopard video animation Cc:
Patch Status:

Description (last modified by Peter Hosey)

OSX: 10.4.2

  1. Bring up the contact list
  2. Hover over a contact to verify the expanded tooltip appears for the contact
  3. Now hide Adium (⌘+H)
  4. Now hover over where the contact list was

Result:

You will get the expanded tooltip of a contact even though the contact list is hidden. This becomes a little annoying when you are in another application, and happen to be in the spot where the contact list was and all of a sudden you get this tooltip of a contact appearing.

alternate explanation by boredzo:
if you have 'Hide [contact list] while Adium is in the background' checked, and you show the tooltip for a contact, and hide Adium while the tooltip is still visible, you can continue to view tooltips for the contacts even while the contact list is not visible.

furthermore, bringing up a tooltip for a contact while the contact list is not visible will reveal the Preferences window if it was open when Adium was hidden.

Additional Cases by jas8522:

  1. Having the contact list behind other windows, tooltips can show through. I cannot reproduce this regularly, but I've seen it happen a fair amount.
  2. Having the contact list in another space, the tooltips can show 'through' spaces which also has the negative effect of hurting the user perspective of how spaces works (as being beside or below/above the current space). Now they won't believe in Santa Claus anymore.
  3. For those not encountering (1) above, we still get tooltips appearing when the contact list is behind the current window (including FS QT video windows) and a contact is animating: as the contact slides under the cursor, it will show a tooltip momentarily.

Attachments (1)

adiumproblem.jpg (148.9 KB) - added by bino 14 years ago.
screenshot of the issue

Download all attachments as: .zip

Change History (59)

comment:1 Changed 14 years ago by Zachary West

Milestone: Adium X 0.82

I can duplicate this issue, but I add the following: in order for this to occur, you must first bring the contact list to the front using cmd+/, not just by opening adium. Please do not set the milestone.

comment:2 Changed 14 years ago by Peter Hosey

Description: modified (diff)

changed Apple logo to PLACE OF INTEREST SIGN, and fixed formatting (list especially).

comment:3 Changed 14 years ago by adamiser

Resolution: worksforme
Status: newclosed

I am unable to reproduce this.

comment:4 Changed 14 years ago by shamusom@…

Resolution: worksforme
Status: closedreopened

I can duplicate this everytime. I can post a screenshot if necessary

comment:5 Changed 14 years ago by Zachary West

I've been able to reproduce this as well.

comment:6 Changed 14 years ago by iMacThere4iAm@…

I can reproduce this and I have made a screenshot:

comment:7 Changed 14 years ago by gkkk04

11/1/05: This issue is still happening - whether I use Cmd-H to hide Adium, or click its icon in the Dock and choose Hide, after a few seconds, the app "unhides" itself (shows as active on Dock) and the rollover/popup effect described above (and shown in the screenshot) occurs.

So is this a bug or is it not? and if it's not, how can I stop it??!!

comment:8 Changed 14 years ago by gkkk04

11/17 - for others also experiencing this major annoyance, I've just stumbled upon a useful work-around. I normally have kept the contact list on my desktop and attempted to "Hide Adium" with Cmd-H or by clicking its icon in the Dock and choosing Hide - as related above, it just keeps "unhiding" itself. Bad software, bad!! :-)

Today I minimized the Contact List (click on yellow button, or Cmd-M), which I'd never done before, and FINALLY, Adium stays hidden - you can either just keep it minimized without Hiding, or Hide it as well, and it stays put. Good software, good!

comment:9 Changed 14 years ago by Evan Schoenberg

I can't reproduce by following the instructions above. Is your contact list set to a non-default ordering? (Above / below other windows)

comment:10 Changed 14 years ago by shamusom@…

Using the current version: 0.86 with 10.4.3, I can no longer reproduce it.

comment:11 Changed 14 years ago by Zachary West

Indeed, I just tried to replicate it and could not. I could before, using the instructions.

Changed 14 years ago by bino

Attachment: adiumproblem.jpg added

screenshot of the issue

comment:12 Changed 14 years ago by anonymous

I'm having the same problem... can consistently replicate it.

comment:13 Changed 14 years ago by Zachary West

Can you give the steps to replicating it?

comment:14 Changed 14 years ago by nathan___

I believe this is the same issue as a related bug I have noticed.

Steps to reproduce both bugs:

  1. Under Appearance, set your buddy list to Borderless window, group bubbles, or contact bubbles
  2. Under Advanced>Contact List, make sure "Show contact information tooltips," "While Adium is in the background," and "Hide when Adium is in the background" are checked. (Buddy list ordering does not matter)
  3. Close preferences. Open a message window.
  4. Select the message window so it has focus.
  5. Select the contact list so it has focus.
  6. Wait until a tooltip appears.
  7. Hide Adium (this bug) OR focus to another window using Command+Tab (the bug I found)
  8. Hover over where the contact list was.

"Hide when Adium is in the background" needs to be enabled for both bugs to appear, not just the Command+Tab bug.

comment:15 Changed 14 years ago by nathan___

By the way, that's with OS X 10.4.3 and AdiumX 0.87b4

comment:16 Changed 14 years ago by nathan___

It seems like you don't always need to focus a message window before focusing the contact list, but sometimes it makes a difference. I can reproduce it without that step.

comment:17 Changed 14 years ago by Peter Hosey

Description: modified (diff)
field_haspatch: 0

comment:18 Changed 14 years ago by Peter Hosey

Description: modified (diff)

comment:19 Changed 14 years ago by nathan___

Hmmm, it seems to be related to whether or not your mouse is over the contact list when you switch/hide. You have to be hovering over the contact list when you switch/hide.

comment:20 Changed 14 years ago by Peter Hosey

yup.

comment:21 Changed 14 years ago by mietek@…

Still happening in 1.0b4.

comment:22 Changed 13 years ago by Dan

And 1.0b9

comment:23 Changed 13 years ago by Christopher Butera

Still happening in 1.0.1. Not critical but very annoying! Using the steps above I can reproduce it everytime.

comment:24 Changed 13 years ago by Eric Richie

Milestone: Adium X 1.2
Version: 0.821.0.1

comment:25 Changed 13 years ago by Jordan

Patch Status: None
Severity: normalminor

If it helps at all, I was able to reproduce this under any window type - regular, borderless, group bubbles etc. I also did not have to open a message window as nathan_ had said.

Show contact information tooltips (Checked)

  • While Adium is in the background (Unchecking this solves the problem)

Perhaps a solution to this might be to have the checkbox corresponding to "Show contact information tooltips - while Adium is in the background" conditional based on the setting of "Automatically hide the contact list". When hiding the contact list automatically is set to "While Adium is in the background", the tooltips while in background checkbox should be disabled and unchecked.

As far as I can tell this removes no functionality, since you don't want tooltips when adium is in the background since the other settings states that it is hidden anyway... so actually, it appears that the settings are functioning as they are supposed to - just not as we would expect them to...

Jordan

comment:26 Changed 13 years ago by TheDodger

Also happens when using VirtueDesktops. Bind Adium to one desktop, switch to another, hover to where the contact list was and voilá: there are the tooltips. Show tooltips and while in background both active.

comment:27 Changed 13 years ago by Chris Forsythe

Milestone: Adium X 1.2Good idea for "later"

Moving to the good idea milestone, move back individually if you intend to work on these.

comment:28 Changed 12 years ago by Jordan

pending: 0
Version: 1.0.11.1.1

comment:29 Changed 12 years ago by Jordan

Version: 1.1.11.1.2

comment:30 Changed 12 years ago by Jordan

Milestone: Good idea for "later"Adium X 1.2

Occurs in Spaces in the exact way as it does in VirtueDesktops #8125

At the moment, they only appear in windows on top of Adium when contacts make transitions. The tooltip appears, then disappears as it slides under the area where the mouse is (but still with something on tope of it - like a QT video window that is fullscreen). It's rather annoying to see a tooltip pop up in the middle of a video.

comment:31 Changed 12 years ago by Evan Schoenberg

If we put every single bug encountered on 1.2, we're never going to release...

comment:32 Changed 12 years ago by Jordan

Milestone: Adium X 1.2Adium X 1.3

Fair enough, however to be fair to this bug/ticket/users waiting, this probably should have been set to 1.2 for a while now, since it has been a known issue for years. Either way, you're right, there's enough in 1.2 for now.

comment:33 Changed 12 years ago by Jordan

Keywords: hidden space spaces leopard video animation added

Adding some keywords - hopefully people will find this now...

Status Update

This seems to occur primarily during contact list transitions (sliding animation) when Adium is in the background and another window (VLC or QT video window or Safari for example) is in the foreground and covering the contact list. It may also now appear while in another space, however this could be fixed for 1.1.4.

I have not been able to get it to occur while Adium is only hidden for a while

comment:34 Changed 12 years ago by Jordan

Milestone: Adium X 1.3Adium X 1.2.1

#8356 Shows this is not fixed for 1.1.4 for Spaces.

I think the priority of this ticket should now be higher since Spaces use is going to be much more prevalent than virtual desktops was. Plus there's still the problem of them showing through other application windows while the Adium CL is behind and (possibly) while the list is hidden.

Moving closer to 1.2 so it may be fixed before 1.3

comment:35 Changed 12 years ago by Jordan

priority: normalhigh

comment:36 Changed 12 years ago by Jordan

Description: modified (diff)

comment:37 Changed 12 years ago by Peter Hosey

Description: modified (diff)

Santa Clause is a movie.

comment:38 Changed 12 years ago by Jordan

I was tempted to use Chanukah Harry, but very few people know of him and how he saved the day when Santa was ill.

comment:39 Changed 12 years ago by Peter Hosey

Owner: changed from nobody to Peter Hosey
Status: reopenednew

comment:40 Changed 12 years ago by Peter Hosey

Status: newassigned

comment:41 Changed 12 years ago by Peter Hosey

(In [21728]) Making a branch for my tooltip fixes until I get them working. Refs #1156.

comment:42 Changed 12 years ago by Peter Hosey

(In [21764]) Burninated the Carbon Event implementation of AISmoothTooltipTracker, because it didn't work. We now use NSTrackingArea instead. Refs #1156.

Next will be a Tiger-compatible substitute, which I've (creatively) named AITrackingArea. We'll use this until either we drop Tiger and go Leopard-only or we find a bug in NSTrackingArea that we can't work around.

comment:43 Changed 12 years ago by Evan Schoenberg

Peter, what's your status on this?

comment:44 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:45 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.3

comment:46 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.4Adium X 1.2.x

Since we're not sure when this will be done...

comment:47 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [23073]) Added -[NSWindow isOnCurrentWorkspace] which uses a little CoreGraphics magic to determine if a window is on the current workspace (spaces desktop), then used it to prevent contact list tooltips from showing up when we're not on the proper workspace. Fixes #1156.

comment:48 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.xAdium X 1.2.5

comment:49 Changed 12 years ago by Evan Schoenberg

(In [23074]) Merged [23073]: Added -[NSWindow isOnCurrentWorkspace] which uses a little CoreGraphics magic to determine if a window is on the current workspace (spaces desktop), then used it to prevent contact list tooltips from showing up when we're not on the proper workspace. Fixes #1156.

comment:50 Changed 12 years ago by Frank

no tooltips show on the contact list if adium is set to show on all spaces

comment:51 Changed 12 years ago by Evan Schoenberg

Great catch, wixardy. Made #9592 for that.

comment:52 Changed 12 years ago by TheDodger

Now, since #1156 is closed, what about the tooltips when the contact list is covered by any other window? Haven't had any chance to check for that since my contant list is on it's own space with the other comm apps...

comment:53 Changed 12 years ago by Pheredhel

Seems to be fixed for me (at least cant reproduce something like this, cant find any ticket either), also fixed for spaces ( #8800 #9170 )

comment:54 Changed 12 years ago by Jordan

I also haven't seen any inappropriate showing of tooltips since this fix, but I will be sure to open individual tickets from now on if I do encounter it. This goes the same for others here - after you have upgraded to 1.2.5 (obviously only after it is released), if you notice tooltip problems, please open a new ticket outlining that specific problem with the usual exact steps to reproduce, etc.

comment:55 Changed 10 years ago by Op Nop

I still see this case on 1.3.5. Does not happen always but reproducible daily:

  • adium is minimised, another app open (often Safari in my case)
  • contact tooltips show through when i hover where adium would be positioned unless minimised

Although this is a cosmetic bug, maybe it should not be classified as minor since it's frequent and disruptive.

comment:56 in reply to:  55 Changed 10 years ago by Op Nop

Replying to opnop123:

I still see this case on 1.3.5. Does not happen always but reproducible daily:

  • adium is minimised, another app open (often Safari in my case)
  • contact tooltips show through when i hover where adium would be positioned unless minimised

Although this is a cosmetic bug, maybe it should not be classified as minor since it's frequent and disruptive.

Correction: I meant "hidden", not "minimised".

comment:57 Changed 10 years ago by Rob Wilkerson

For whatever it's worth, this still occurs for me. I'm using 1.4b8 and have my contact list set to hide when it's not active. I can reproduce as follows:

  1. Bring Adium (and the contact list) to the front.
  2. Hover briefly over a contact.
    • You do not have to hover long enough for the tooltip to actually appear.
  3. cmd+tab to a different application while the cursor is still hovering over the contact list.
  4. Hover where the contact list was before the app switch
    • Once switched you can move the mouse away from where the contact list was and the tooltip will still appear when you return.
  5. A contact tooltip should appear.

comment:58 Changed 10 years ago by Op Nop

I submitted a new ticket for this since this ticket was closed. #12774

Note: See TracTickets for help on using tickets.