Adium

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#11496 closed defect (fixed)

Instant inline contact search not working

Reported by: Katt Owned by: evands
Milestone: Adium 1.3.3 Component: Adium UI
Version: Severity: normal
Keywords: instant search Cc:
Patch Status:

Description

I'm using 1.3.3b1, in 1.3.2 my contactwindow searched inline instantly as i typed (without having to press cmd-F)... In 1.3.3b1 I can no longer do this. This only worked when I used the standard layout in 1.3.2, so don't try to reproduce in bubblemode.

Change History (13)

comment:1 Changed 11 years ago by Robert

Resolution: wontfix
Status: newclosed

That's intended behaviour: "Contact list searching is now only triggered by Cmd-F, and no longer cancels when switching applications (#10956)" (http://beta.adiumx.com/).

comment:2 Changed 11 years ago by David Smith

I do think it would be interesting to look at the pros and cons of having it both ways, and whether there's a third hidden solution that would make both groups of people happy.

comment:3 Changed 11 years ago by Karl Kjellgren

Agreed, not having to press cmf-f streamlines my usage of the contactlist, please add an option to enable this again. Cmd-f just feels like an unnecessary step when all I want to is finding a specific contact (which is the purpose of the contactlist, don't you think?)

I don't see any con in giving the user this choice.

comment:4 Changed 11 years ago by Johnathan

You really need to get rid of the cmd+F thing or give us an option to turn it off. Also the canceling when switching needs to happen. Takes way to long to do a simple contact search then having to clear it before I can go talk to someone else.

comment:5 Changed 11 years ago by Robert

Milestone: Adium 1.3.3
priority: normalhigh
Resolution: wontfix
Status: closedreopened

I think we need decide on a good solution before releasing 1.3.3 as leaving the change as it is would be considered a regression by many.

comment:6 Changed 11 years ago by Karl Kjellgren

I think a good solution to both problems is:

  • If the user starts a search using CMD-F, the search field is not cleared when switching window.
  • If the user starts a search by typing, the search field is cleared when switching window.

I think that feels like a behaviour most people agree upon since the search-by-typing is kind of a "quick" search which clear the field when switching window.

comment:7 Changed 11 years ago by Robert

That indeed sounds good to me. :)

comment:8 Changed 11 years ago by Evan Schoenberg

Owner: set to Evan Schoenberg
Status: reopenednew

comment:9 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [25747]) Partially revert [25397], and tweak standard contact list typing as suggested by Katt in #10956. Typing does initiate a search, as Adium 1.3.2 did, and clicking away does clear that search. Hitting cmd-F to initiate a search starts a less transient search, and the search field will remain when clicking away. I think this will please most involved, I hope. :)

Refs #10956. Fixes #11496.

comment:10 Changed 11 years ago by Robert

Resolution: fixed
Status: closedreopened

comment:11 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [25753]) Merged [25747]: Partially revert [25397], and tweak standard contact list typing as suggested by Katt in #10956. Typing does initiate a search, as Adium 1.3.2 did, and clicking away does clear that search. Hitting cmd-F to initiate a search starts a less transient search, and the search field will remain when clicking away. I think this will please most involved, I hope. :) Refs #10956. Fixes #11496.

comment:12 Changed 11 years ago by Zachary West

Component: Contact List SearchContact List

Removing Contact List Search component.

comment:13 Changed 11 years ago by Zachary West

Component: Contact ListAdium UI

Removing 'Contact List' component.

Note: See TracTickets for help on using tickets.