Adium

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11473 closed defect (duplicate)

Adium facebook chat seems to interfere with facebook homepage

Reported by: godfreykfc Owned by:
Milestone: Component: Service/Facebook
Version: 1.3.2 Severity: normal
Keywords: Cc:
Patch Status:

Description

Starting these few days, I started to experience this issue: when I have my adium facebook chat signed on, the official facebook homepage is virtually unusable -- I would either get redirected to the login page or got a message saying that my session has timed out after clicking a few links. I can sign in again and continue for a short while, but this would happen again in like 1 minute. Disconnecting the Adium facebook chat before logging into facebook fixes the problem. (It should also be noted that facebook's "remember me" option no longer works if I signed in using Adium's facebook chat.) I am pretty sure it's not a browser thing although I have only tried to reproduce this on Safari and Firefox. It seems that the facebook people have changed something on their side, making it impossible to sing in at the same from two different "locations". I am not sure if Adium's team could fix this on their own without help from facebook...

Change History (9)

comment:1 Changed 6 years ago by godfreykfc

Nevermind, there seems to be another cause for this problem because I just got signed out with Adium fb chat disconnected.

comment:2 Changed 6 years ago by godfreykfc

Sorry for the confusion, please ignore my last comment, that seems to be a one time thing.
I just retested everything and it is definitely related to Adium, here is my observation:

Disconnect Adium fb chat -> sign into web interface, browse for 10 minutes, everything works fine -> sign in adium -> web interface got disconnected almost immediately

comment:3 Changed 6 years ago by godfreykfc

It seems that facebook (web) and Adium is "fighting" for the right to use the account.

From adium log: (I removed some stuff cause I am not sure if they are "confidential" or not)

13:49:02: -[AIFacebookBuddyListManager connectionDidFinishLoading:]: {
    bootload =     (
                {
            name = "js/***.pkg.js";
            permanent = 0;
            src = "http://static.ak.fbcdn.net/***.pkg.js";
            type = js;
        }
    );
    error = 1357001;
    errorDescription = "You must be logged in to do that.";
    errorIsWarning = 0;
    errorSummary = "Not Logged In";
    payload = <null>;
}
13:49:02: -[AIListObject setVisible:]: <AIListContact:*** Facebook.***>: 0. Telling (null)
13:49:02: -[AIListObject setVisible:]: <AIListContact:*** Facebook.***>: 0. Telling (null)
13:49:02: -[AIListObject setVisible:]: <AIListContact:*** Facebook.***>: 0. Telling (null)
13:49:02: -[AIListObject setVisible:]: <AIListGroup:*** Group.Facebook>: 0. Telling <AIListGroup:*** Group.ROOTJKSHFOEIZNGIOEOP>
13:49:02: -[AIListObject setVisible:]: <AIListContact:*** Facebook.***>: 0. Telling (null)
13:49:02: <AIFacebookAccount:*** 2>:***@gmail.com: Disconnected ("Waiting to reconnect"): Automatically reconnecting immediately
13:49:02: -[AIFacebookAccount webView:resource:didFinishLoadingFromDataSource:]: <WebView: 0x504200> resource Logging in finished loading <WebDataSource: 0x2091fae0>

And then I got "kicked out" form the web interface.

comment:4 Changed 6 years ago by Decipherer

I had a similar problem and it appeared after the 10.5.6 update. Try this:

1) Close Adium and all browsers.
2) Open Safari and go to Preferences -> Security.
3) Click on "Show Cookies".
4) Type "facebook" in the search field.
5) Select all entries that start with ".facebook.com" and click on "Remove".
6) Click on "Done" and quit Safari.
7) Reopen Safari and Adium.

Hope it helps. It worked for me...

comment:5 Changed 6 years ago by proton

  • Resolution set to duplicate
  • Status changed from new to closed

The way the facebook plugin works is by logging into the web interface itself and pretending to be a web browser. This means you may have difficulties via the web interface at the same time, depending on browsers, timings, etc.

This is a duplicate of #10757 #10643 #11431 and probably others.

comment:6 Changed 6 years ago by spyralex

I am having this same problem. I will log into facebook, and almost immediately I am logged out of facebook chat on Adium (v. 1.3.2). Then, Adium will log me back in, and the next thing I do on facebook, I either get redirected to the login page (if I navigate to a different page), or get a message saying I must log in to do what I'm trying to do (if it's commenting on a status or photo or something else that doesn't involve actually navigating to a new page). The 'remember me' function does not work for me either.
In response to godfreykfc, after I unchecked my facebook account on Adium and then reloaded and re-logged in to facebook, facebook logged me out and asked for my password one more time, and hasn't asked me since. I think that this is a sort of residue from when I was still trying to connect to both at once.
In addition, at first I wasn't having this problem, then I found a work around for a few days by logging in to facebook first, and now nothing works. This has all been in the past week.
Not that it seems to matter at all, but I'm using OS 10.5.6.

comment:7 Changed 6 years ago by nitron

Hello, this one is major and needs to be fixed. The dup that's still open makes the bug seem trivial or a nice to have. But, with 10.5.6, this bug makes the facebook IM functionality in Adium straight out break facebook access in Safari.

And there is no indication to the user as to what might be going and why they are being logged out of facebook literally every 30 seconds. It's really bad.

There are several threads in Apple support forums on this already, with people blaiming 10.5.6 and Safari and being unable to figure out what's going on.

Could this bug be reopened??

comment:8 Changed 6 years ago by timotab

I had this problem too. http://discussions.apple.com/thread.jspa?messageID=8651868 suggests that it's a problem with safari getting confused about cookies after the OS X 10.5.6 upgrade, and that the fix is to reinstall safari 3.2.1. This seems to have worked for me.

comment:9 Changed 6 years ago by nosillacast

I agree that this isn't a minor inconvenience - I've isolated it to Safari only on my 10.5.6 machine. I can happily be in FB chat in Adium (which ROCKS!) and go to FB on Firefox to look at photos. The minute I try to go to FB in Safari, it and AX keep logging in and out. I wanted to create a Fluid App for FB today, but of course Fluid uses webkit, which means it's plagued with the same problems. Please don't discount how useful it is to be able to use AX for Facebook chat.


Allison
NosillaCast at http://podfeet.com
A technology geek podcast with an EVER so slight Macintosh bias!

Note: See TracTickets for help on using tickets.