Adium

Opened 14 years ago

Closed 14 years ago

#1136 closed defect (fixed)

Blocking over AIM does not work

Reported by: anonymous Owned by: nobody
Milestone: Adium X 1.0 Component: Service/AIM
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Blocking seems to have no effect, have tried blocking users and they are still able to send and receive messages from me. This is on Adium 0.82.

Change History (9)

comment:1 Changed 14 years ago by Trevin Ward

Resolution: worksforme
Status: newclosed

Try .83b at AdiumBeta But I'm pretty sure it was working fine in .82 also

comment:2 Changed 14 years ago by David Smith

Milestone: Adium X 0.82

comment:3 Changed 14 years ago by anonymous

Still having the same problems. Right clicking and "Block"ing them still has no effect. Running .83b9 on Tiger 10.4.2 on a 1.67GHz Powerbook.

comment:4 Changed 14 years ago by Chris Forsythe

Milestone: Adium X 0.90
Resolution: worksforme
Status: closedreopened

comment:5 Changed 14 years ago by anonymous

Have the same exact setup as first anonymous--blocking has no effect.

comment:6 Changed 14 years ago by adiumx@…

My friend noticed that Adium seems to be telling the AIM server to block a small positive integer instead of the account name. For instance, instead of blocking user "Foo", it blocked user "23". I assume this small integer is some internal index number used by Adium—I know nothing of Adium's internals.

comment:7 Changed 14 years ago by adamiser

Sounds like a meta-contact issue.

comment:8 Changed 14 years ago by ArAgost

I've got the same problem on 0.86. Blocked the single accounts in one metacontact, but messages keep coming in AIM. The "warning" thing should be implemented, too.

comment:9 Changed 14 years ago by Colin Barrett

field_haspatch: 0
Resolution: fixed
Status: reopenedclosed

I believe this was fixed by the small blocking change that Kiel introduced. Marking this as closed, unless it shows up.

Note: See TracTickets for help on using tickets.