Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#11246 closed defect (fixed)

Adium 1.3.2 on OSX 10.5.5 - cannot create a new (Jabber) Account

Reported by: comkomm Owned by:
Milestone: Adium 1.3.4 Component: Service/XMPP (Jabber)
Version: Severity: regression
Keywords: Jabberaccount Cc:
Patch Status:

Description (last modified by Robert)

Hi there,

If I try to create a Jabber Account with Adium 1.3.2 on Mac OS X 10.5.5 nothing happens. The EventLog says:

11.10.08 17:49:03 Adium[225] *** Assertion failure in -[NSTextFieldCell _objectValue:forString:errorDescription:], /SourceCache/AppKit/AppKit-949.35/AppKit.subproj/NSCell.m:1338 
11.10.08 17:49:03 Adium[225] Invalid parameter not satisfying: aString != nil 
11.10.08 17:49:18 Adium[225] *** Assertion failure in -[NSTextFieldCell _objectValue:forString:errorDescription:], /SourceCache/AppKit/AppKit-949.35/AppKit.subproj/NSCell.m:1338 
11.10.08 17:49:18 Adium[225] Invalid parameter not satisfying: aString != nil 
11.10.08 17:53:32 Adium[252] Could not connect the action adiumDuckClicked: to target of class AIFacebookAccountViewController 
11.10.08 17:53:32 Adium[252] Could not connect the action buildFieldClicked: to target of class AIFacebookAccountViewController 
11.10.08 17:53:32 Adium[252] Could not connect the action visitHomepage: to target of class AIFacebookAccountViewController 
11.10.08 17:53:32 Adium[252] Could not connect the action showLicense: to target of class AIFacebookAccountViewController 
11.10.08 17:53:32 Adium[252] Could not connect the action hideLicense: to target of class AIFacebookAccountViewController 
11.10.08 17:53:36 Adium[252] *** Assertion failure in -[NSTextFieldCell _objectValue:forString:errorDescription:], /SourceCache/AppKit/AppKit-949.35/AppKit.subproj/NSCell.m:1338 
11.10.08 17:53:36 Adium[252] Invalid parameter not satisfying: aString != nil

Every other try to create another account seems working fine...

Just dropping in..

Nice work - CU

Attachments (2)

com.adiumX.adiumX.plist (1.3 KB) - added by comkomm 12 years ago.
current AdiumX preferences
XMPP-Konto Einstellungen.png (54.7 KB) - added by Robert 12 years ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 12 years ago by Robert

Description: modified (diff)
Milestone: Needs feedback from users
pending: 01

At which server did you try? Does it work with other servers?

Changed 12 years ago by comkomm

Attachment: com.adiumX.adiumX.plist added

current AdiumX preferences

comment:2 Changed 12 years ago by comkomm

pending: 10

I cannot select a server.

If I try to ADD an account (using the '+' button within preferences or the menu -> add account, jabber) the window where I can enter all details for that server won't appear.

I'm using the German localized version of Adium.

If everything will work I'll surely use my own server (crossfire implementation).

Thanks for your fast response.

comment:3 Changed 12 years ago by Robert

pending: 01

That's very odd, my localisation is German as well. I've made screenshot of the window which shows up for me.
Does this window not appear at all for you or are you just missing the "Einstellungen" (Settings) part?

Changed 12 years ago by Robert

comment:4 Changed 12 years ago by comkomm

pending: 10

Hello again,

as you are using the localisation in German as well I suppose we can continue this topic in German :) Also Hallo nochmal.

Ich komme nicht auf die Möglichkeit ein JABBER Konto hinzuzufügen. Wenn ich auf das '+' unter Einstellungen --> Konten klicke oder unter 'Ablage --> Konto Hinzufügen --> Jabber' versuche ein solches Konto hinzuzufügen erscheint kein Einstellungsdialog. Selbst wenn ich wollte, ich könnte kein Konto erzeugen/hinzufügen wie auch immer.

Ich sehe also diesen Einstellungsdialog nicht.

Die Rechte sollten ausreichend sein, weil ich als Administrator unterwegs bin.

Grüße - ComKomm

comment:5 Changed 12 years ago by Robert

pending: 01

I'd rather continue in English as other people might only also have this problem and find this ticket. :)
It's odd that I can't reproduce the issue. Have you tried the TroubleshootingTips?

comment:6 Changed 12 years ago by comkomm

pending: 10

Hi there,

So I've deleted all ADIUM preferences, went through the welcome wizard. During the wizard I was able to enter a Jabber account (which worked well) but unfortunatelly I cannot change preferences on this account. The configuration window won't show up as well as it didn't during trying to add a new jabber account. It seems this is a problem only with the jabber account preferences window.

If I add a jabber account with the wizard everything is fine but I cannot change anything. If I try to add it later with the normal add dialogue it fails.

Trying another user account doesn't really fix that issue because I'd prefer use Adium with my current account. So any other further tips?

Thanks for your feedback,

ComKomm

comment:7 Changed 12 years ago by Steven Johnson

I have *exactly* the same symptoms on my machine (same Adium and OSX versions). I haven't tried capturing an event log to see if it matches as well, but I've tried all the same steps and been similarly frustrated.

comment:8 Changed 12 years ago by comkomm

Hi Steven...

Well - If you already own 'one' jabber account you can try the same thing that I've done. I've deleted preferences, started Adium and with the initial startup Wizard I added my jabber account. You have only this ONE chance and after adding this you cannot modify nor change anything on this jabber account. I've added another (ICQ) account that works good alltogether with the jabber account. I really don't understand what the problem might be.

Hope that helps you...

Greetings - ComKomm

comment:9 in reply to:  8 Changed 12 years ago by Steven Johnson

Unfortunately, it doesn't help much, as there are a few settings I need to change (from the defaults) to get it to work on my corporate server.

Is there a settings file I could try hacking on directly?

comment:10 Changed 12 years ago by Robert

Milestone: Needs feedback from usersAdium 1.3.3
Owner: Andreas Monitzer deleted

comment:11 Changed 12 years ago by Robert

priority: normalhigh
Severity: normalregression

comment:12 Changed 12 years ago by Evan Schoenberg

I can't reproduce this while running German. Your debug logging talks about "AIFacebookAccountViewController". Are you sure you're trying to add a Jabber account? Could you please show another set of logging, from Adium 1.3.3 beta?

comment:13 Changed 12 years ago by David Munch

Im not sure if this is expected behavior, but using the danish localization, I get the following sequence: http://dl-client.getdropbox.com/u/32952/Adium.jpg

When the last error window shows up, I get this debuglog: http://paste.lisp.org/display/73822

comment:14 in reply to:  12 Changed 12 years ago by Steven Johnson

Replying to evands:

I can't reproduce this while running German. Your debug logging talks about "AIFacebookAccountViewController". Are you sure you're trying to add a Jabber account? Could you please show another set of logging, from Adium 1.3.3 beta?

I will install 1.3.3 beta sometime this week and get a logging result for you.

comment:15 in reply to:  13 Changed 12 years ago by Andreas Monitzer

Replying to David Munch:

Im not sure if this is expected behavior, but using the danish localization, I get the following sequence: http://dl-client.getdropbox.com/u/32952/Adium.jpg

The "conflict" message probably means that an account with this name is already registered. The other error and the empty list below the server field is due to jabber.org having changed a specific API. This has already been fixed in trunk, but was not propagated to the 1.3 branch.

comment:16 Changed 12 years ago by Steven Johnson

OK, I just tried this in 1.3.3RC1, and no change in behavior (still broken).

When I select "File>Add Account>Jabber", instead of the "add account" dialog, I get the "Join Chat" dialog, with no Jabber option available (my AIM and YIM accounts are available in the popup).

The Debug Windows only gives one line of output:

11:14:13: <DCJoinChatWindowController: 0x183eca80>: _selectPreferredAccountInAccountMenu: <AIAccountMenu: 0x184479d0>: menuItem for <ESPurpleAIMAccount:502ad0 4>:boredomfestival is <MenuItem: 0x18497e10 boredomfestival>

("boredomfestival" is my AIM account name and is the active item in the popup when the dialog appears)

Is there a Debug-specific build I should try? (eg one with assertions enabled)... I have the full XCode suite installed on my system, so I can do a bit of debugging (unfortunately I don't have the time to grab and debug the entire Adium project at the moment)

comment:17 Changed 12 years ago by Robert

Milestone: Adium 1.3.3Adium 1.3.4

comment:18 Changed 12 years ago by Mark Watson

I also had this problem and tracked it down to a call to SCDynamicStoreCopyLocalHostName(NULL) at ESPurpleJabberAccountViewController.m line 58 (in the 1.3.3 source). This is called if the "Resource" field in the preferences is not present (as it is when an account is created at statup). This can return NULL (on error, though I am not sure what kind) and the text field does not like being set to null.

Modifying the code for the Resource element solves the problem, though I am not sure this counts as a clean solution:

//Resource
	if([account preferenceForKey:KEY_JABBER_RESOURCE group:GROUP_ACCOUNT_STATUS])
		[textField_resource setStringValue:[account preferenceForKey:KEY_JABBER_RESOURCE group:GROUP_ACCOUNT_STATUS]];
	else
	{
		NSString* hostname = (NSString*)SCDynamicStoreCopyLocalHostName(NULL);
		if ( hostname )
		{
			[ hostname autorelease ];
		}
		else
		{
			hostname = @"";
		}
		
		[textField_resource setStringValue: hostname ];
	}

comment:19 Changed 12 years ago by Evan Schoenberg

Hm. Good bug hunting. Do you have a computer name set in System Preferences -> Sharing?

comment:20 Changed 12 years ago by Mark Watson

You're right. I did not have anything configured there. If I configure something then 1.3.3 works fine.

comment:21 Changed 12 years ago by Evan Schoenberg

Clearly Adium shouldn't fail without clear cause in that case - it's good to know what causes it, as well, though.

comment:22 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [25976]) Fixed an exception thrown when loading the Jabber account preferences with no host name set or when for some other reason SCDynamicStoreCopyLocalHostName() returns NULL. Thanks to mwatson for the find and suggested fix (I just cleaned up his patch). Fixes #11246

comment:23 Changed 12 years ago by Evan Schoenberg

(In [25977]) Merged [25976]: Fixed an exception thrown when loading the Jabber account preferences with no host name set or when for some other reason SCDynamicStoreCopyLocalHostName() returns NULL. Thanks to mwatson for the find and suggested fix (I just cleaned up his patch). Fixes #11246

Note: See TracTickets for help on using tickets.