Adium

Opened 11 years ago

Closed 8 years ago

Last modified 7 years ago

#11199 closed defect (fixed)

MSN Mail Alert - Getting 2 alert dialogs for new mail

Reported by: batmanppc Owned by:
Milestone: Adium 1.5 Component: Service/MSN
Version: 1.4b18 Severity: normal
Keywords: Cc:
Patch Status:

Description

I'm getting two alerts mail alert dialogs when signing into MSN. One that says I have mail with only an OK button and another that tells me I have mail with options to launch mail, browser, and OK. This is only happening for MSN. Yahoo and GTalk continue to only show one alert with 3 buttons.

Confirmed on multiple machines with different MSN accounts.

Currently running trunk (r25029).

Attachments (1)

adium_debug.log (166.4 KB) - added by batmanppc 10 years ago.

Download all attachments as: .zip

Change History (24)

comment:1 Changed 11 years ago by Dimmuxx

  • Milestone set to Adium 1.3.2
  • Summary changed from 1.4svn: MSN Mail Alert - Getting 2 alert dialogs for new mail to MSN Mail Alert - Getting 2 alert dialogs for new mail
  • Version changed from 1.4svn to 1.3.2b2

This happens in the 1.3 branch too.

comment:2 follow-up: Changed 11 years ago by evands

  • Milestone changed from Adium 1.3.2 to Waiting on libpurple

This should be reported in pidgin trac; we only display mail alerts when libpurple tells us to, so we're being told twice, and the fix needs to happen in the msn prpl.

comment:3 Changed 11 years ago by jmpp

  • Version changed from 1.3.2b2 to 1.3.2

Sorry for dup'ping tickets, I searched but didn't find this one when I filed #11249. Libpurple hasn't fixed the problem in the current released version of Adium (1.3.2), so I'm adapting the version number in the ticket accordingly.

-jmpp

comment:4 in reply to: ↑ 2 Changed 11 years ago by batmanppc

Replying to evands:

This should be reported in pidgin trac; we only display mail alerts when libpurple tells us to, so we're being told twice, and the fix needs to happen in the msn prpl.

Does this account for the fact that Adium is putting up two different types of alerts (regular alert telling us there's mail with just an ok button and the other more familiar mail alert with 3 buttons asking to open mail.app, mail in browser and ok)?

comment:5 Changed 11 years ago by evands

Yes. libpurple is passing us two alert notifications; one with a URL for checking the mail and one with no information.

comment:6 Changed 11 years ago by zacw

  • Status changed from new to closed

Closing all "waiting on libpurple" tickets. There's no reason to keep them around as open, and largely go ignored anyway. File a ticket at http://developer.pidgin.im for any functionality you want to see.

comment:7 Changed 11 years ago by anonymous

  • Milestone Waiting on libpurple deleted

Milestone Waiting on libpurple deleted

comment:8 Changed 10 years ago by Dimmuxx

Ticket #12274 has been marked as a duplicate of this ticket.

comment:9 Changed 10 years ago by Robby

  • Status changed from closed to new

I have opened a ticket in Pidgin's Trac, #p9876 but they need a debug log.

comment:10 Changed 10 years ago by Robby

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

comment:11 Changed 10 years ago by batmanppc

  • Status changed from pending to new

I'll get this soon as I get some time.

Changed 10 years ago by batmanppc

comment:12 Changed 9 years ago by Robby

  • Owner nobody deleted

comment:13 Changed 9 years ago by Robby

I suppose this issue hasn't miraculously disappeared in the meantime?

comment:14 Changed 9 years ago by jmpp

Unfortunately, no, still there lingering in the latest Adium beta.

-jmpp

comment:15 Changed 9 years ago by Robby

  • Version changed from 1.3.2 to 1.4b18

Okay, I'll go after the Pidgin ticket then. Thanks, jmpp. :)

comment:16 Changed 9 years ago by Robby

  • Milestone set to Adium bugs

comment:17 Changed 9 years ago by Robby

Evan, #p9876 now has a patch.

comment:18 Changed 9 years ago by Robby

  • Milestone changed from Adium bugs to Adium 1.5

comment:19 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 895fe77449a4) libpurple 2.10.0 [im.pidgin.adium @ 49165fe031556f6fe6c91eadc8305a0e9001eb90]

Plucked these two changes:

  • Fix double mail notifications on MSN.
  • Make disconnects because of flooding on IRC less likely.

Fixes #13920, fixes #11199

comment:20 Changed 8 years ago by ShawnRisk

I have an old email that is unread but not getting sending a notification to MSN on Adium is there a reason that is happening? I sent a new message to myself, and that is sending a notification now but only saying 1 new message.

What are others getting around this?

comment:21 Changed 8 years ago by MacMom

I am not getting email notifications. I reverted back to 1.4.4 for the time being.

comment:22 Changed 8 years ago by pij

I have the same problem of ShawnRisk (comment 20)
And it seems to be fixed with the downgrade to 1.4.4.

comment:23 Changed 7 years ago by Robby

The regression of no notification being shown has been reported here: #15965.

Note: See TracTickets for help on using tickets.