Adium

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#11127 closed enhancement (fixed)

Permanently remember offline messaging settings (per-contact or per-account)

Reported by: naveenneogi Owned by: nobody
Milestone: Adium 1.3.3 Component: Adium Core
Version: Severity: normal
Keywords: wereon1.3.2 Cc: naveenneogi@…
Patch Status:

Description

Hello,

I use Adium for Yahoo, Gtalk and MSN. This alert started showing up (in all the protocols) since i upgraded my adium client to 1.3.2b1 to get around the yahoo servers ping issue. Before that i used to have a really old version (i do not recollect the version) which dint have this problem.

This is the exact message it throws up :

"Send Now will deliver your message to the server immediately. naveenneo will receive the message the next time he or she signs on, even if you are no longer online.

Send When Both Online will send the message the next time both you and naveenneo are known to be online and you are connected using Adium on this computer."

Is there already a way to disable this alert? If not, can we have an option in the preferences section to enable/disable this. Or is this something that cannot be fixed because of the protocols.

This seriously is an usability issue since i just dont care if the user is online or offline because he would respond to me if he is online.

Change History (18)

comment:1 Changed 11 years ago by Jordan

Milestone: Adium 1.3.2

This dialog is expected to appear for any protocol that does not support server-side offline messaging. Now that MSN does support it in 1.3.2 we should change the behaviour of the dialog so that it does not appear when sending a message via MSN (unless those conditions are not correct). Yahoo and Gtalk do not support server-side offline messaging (as far as I'm aware) so they are expected to have that dialog appear.

comment:2 in reply to:  1 Changed 11 years ago by TheDodger

Replying to jas8522:

This dialog is expected to appear for any protocol that does not support server-side offline messaging.

Shouldn't this appear when a protocol indeed DOES support server-side offline messaging? I thought that it works this way, if the protocol doesn't support this feature there is no other option as sending when both are online.

comment:3 Changed 11 years ago by naveenneogi

And the ones that i am using adium for -yahoo,goog,msn support server-side offline messaging. If this was working as intended in an older version, why not in the newer versions.

comment:4 Changed 11 years ago by Evan Schoenberg

It appears if it DOES support offline messaging, as some users don't want to send an offline message but rather wait until the user signs on.

comment:5 Changed 11 years ago by Josh Cheshire

It would be fantastic if this could be disabled as a preference. I IM with a number of people who are online, but mark themselves as hidden or offline. I get this dialog every time I try to send my first IM with them, even though they have actively sent me messages. It's driving me batty.

Thanks!

comment:6 Changed 11 years ago by TheDodger

Yeah, I'll vote for a pref too.

Should be like this:

  • Checkbox in the dialog to save chosen value (Do not ask again or such)
  • Dropdown in the prefs to toggle between:
    • Ask
    • Send now
    • Send later

Any other opinions?

comment:7 Changed 11 years ago by Robert

Keywords: wereon1.3.2 added
Milestone: Adium 1.3.2Adium 1.3.3

comment:8 Changed 11 years ago by Robert

Summary: adium throws up an alert whenever i msg a user who is offline/invisiblePermanently remember offline messaging settings (per-contact or per-account)

comment:9 Changed 11 years ago by eschoenfeld

+1, this dialog drives me crazy. Should be a perf, per account. If you want to add scope creep then add exceptions per user.

comment:10 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [25780]) Assume that an account which supports offline messaging should send messages immediately rather than prompting; I think we get more complaints about the offline messaging dialogue than nearly anything else. Closes #11127.

comment:11 Changed 11 years ago by Evan Schoenberg

(In [25781]) Merged [25780]: Assume that an account which supports offline messaging should send messages immediately rather than prompting; I think we get more complaints about the offline messaging dialogue than nearly anything else. Closes #11127.

comment:12 Changed 11 years ago by Jan Brašna

Please consider having a pref for this, as with this bug #11147 present, we're no longer able to send messages to offline contacts. This dialog was a way how to postpone the sending until both sides are online, but right now there's no option to avoid the particular bug in libpurple.

comment:13 Changed 11 years ago by mrezny

This REALLY needs to be a preference. Offline messages NEVER works, EVER! The addition of this dialog was a huge help in that there was finally a way to leave a message when the other person wasn't immediately available. Now that it thinks it can send an offline message, it never prompts and instead just throws it into the wind. The server responds with "Unable to send message: Service unavailable" some time later since offline messages in fact don't freakin' work.

I will be hacking around this as I already have other patches to resolve retarded "won't fix" issues and thus do my own builds anyway. However, it would be nice if it were fixed properly so that other people could benefit and I wouldn't have to maintain as many personal patches. At the rate things are going in 1.3.x, I'll end up with my own branch just loosely tracking the mainline by the time we hit 1.4 just to have a usable client free of critical bugs masked as misfeatures.

comment:14 Changed 11 years ago by Evan Schoenberg

The problem here is that ICQ (which I presume you're using based on the error you've cited, though you don't say specifically) doesn't have a proper offline messages implementation. The fix, then, is to disable offline messages in ICQ.

There shouldn't be "retarded won't fix" issues. "Won't implement" is one thing - for example, a feature which we don't think should be part of Adium. "Won't fix" for a true bug is just a function of a miscommunication. I'd appreciate if you would be constructive in pointing out such issues -- and providing your fixes, if you've coded them -- rather than just alluding to them.

comment:15 Changed 11 years ago by mrezny

I'm using AIM, it is just as broken as ICQ. Always has been and probably always will be. When I say "won't fix" I'm exactly quoting what the tickets have been marked as. The other major gripe ticket is one I attempted to fix, even after it was marked as "won't fix" but was defeated from making a proper patch until 1.4 ue to laziness and policy. I did in fact post a patch to the comment thread to fix the issue until that time. So, to be very explicit, my patch for this particular issue is to back out changeset 25781/25780 in my tree.

comment:16 Changed 11 years ago by m1ss1ontomars2k4

Please change this to a toggle-able setting. I get messages like this when attempting to use offline messaging with certain buddies:

4:36:24 PM: Unable to send message: Refused by client

To my knowledge this tends to happen regardless of whether the other person actually accepts offline messages, and in some cases I'd prefer to use "send later" rather than "send now". I'd also like the option to say "don't send" when people sign off right before I hit enter. At any rate, I'm going back to 1.3.3b1 until this is changed.

comment:17 Changed 11 years ago by Robert

This is with ICQ, m1ss1ontomars2k4?

comment:18 Changed 11 years ago by m1ss1ontomars2k4

No, AIM.

To clarify, I like "send later" because it also notifies me when the buddy is online (by opening a window for them). I like "don't send" because it makes no sense to send someone an offline IM that says "bye".

Note: See TracTickets for help on using tickets.