Adium

Opened 11 years ago

Closed 11 years ago

#11126 closed defect (fixed)

Unable to add user - Unknown error (205) when connecting to MSN

Reported by: asqui Owned by: nobody
Milestone: Adium 1.3.3 Component: Service/MSN
Version: Severity: normal
Keywords: wereon1.3.2 Cc:
Patch Status:

Description

Just updated to 1.3.2b1 and whenever MSN tries to connect I get a notification Window popup and say:

Unable to add user

Unknown error (205)

MSN stays in "Connecting" state.

Reproducible by simple disconnecting or disabling MSN and attempting to go online again.

Will attach what seems to be the problematic part of the debug log...

Attachments (3)

adiumdebug.txt (5.2 KB) - added by Lachlan 11 years ago.
Debug log snippet
adiumdebuglog.txt.zip (20.8 KB) - added by kari 11 years ago.
adium-1.3.2-debug-msn-error.log.txt (444.6 KB) - added by Christoffer Sawicki 11 years ago.

Download all attachments as: .zip

Change History (33)

Changed 11 years ago by Lachlan

Attachment: adiumdebug.txt added

Debug log snippet

comment:1 Changed 11 years ago by Lachlan

Forgot to note this occurred on Mac OSX 10.5.5, though I suspect OS isn't really related here :)

comment:2 Changed 11 years ago by kari

same here. happens every time MSN tries to connect. Just upgraded to 1.3.2b1 and my PowerBook G4 is running 10.5.5, in English. Attached my debug log, which is from trying to connect to MSN until the 205 error window pop ups.

Changed 11 years ago by kari

Attachment: adiumdebuglog.txt.zip added

comment:4 Changed 11 years ago by Jordan

Milestone: Adium 1.3.2

According to #p6640 libpurple 0.5.1 will have a workaround by hard coding the messenger@… buddy. We should see if that commit is included in the version of libpurple we're using in 1.3.2b1

Although a better fix is included in a patch there (according to khc) either the fix or the workaround would look the same to the end user, so I see no reason to hold this up on that diff attached to the ticket.

comment:5 Changed 11 years ago by kari

For me, the messenger@… buddy (as in ignore that contact) is from a long time ago, when Microsoft did something with that account (sending messages or something, can't really remember). Back then, it was possible to block it, but now I can't do anything about that contact. Today I don't think MS uses it for anything, but I've been impossible to remove that buddy. I wouldn't mind if it just disappeared from my local buddy list.

comment:6 Changed 11 years ago by Dimmuxx

The temporary fix which is in Pidgin 2.5.1 have been removed from im.pidgin.pidgin now so the libpurple built for 1.3.2b1 doesn't include it and that's why this happen.

comment:7 Changed 11 years ago by Dimmuxx

What do you mean by stays in "connecting" state btw? Are you able to login to msn just that it shows you the error message every time you do?

If so then you can probably make the error message go away by removing messenger@… from your block list under the Adium menu -> Privacy Settings...

comment:8 in reply to:  7 Changed 11 years ago by kari

Replying to Dimmuxx:

What do you mean by stays in "connecting" state btw? Are you able to login to msn just that it shows you the error message every time you do?

No, the login doesn't seem to continue from that point onwards. The account shows as "(Connecting)" in Status menu and in Preferences (with status "Retrieving buddy list (100%)")

comment:9 Changed 11 years ago by Dimmuxx

Can some Adium developer do a new build with the patch from #p6640 and post it here so that people who experience this bug can try it. QuLogic wanted to know if it worked before commiting it to im.pidgin.pidgin.

comment:10 Changed 11 years ago by BigBossman

Bug still present in 1.3.2b2, and there is/never was a messenger@… contact in block list

comment:11 Changed 11 years ago by Lachlan

Tested also on 1.3.2b2 and the issue still exists. (I should note that I'm not surprised, as the changelog from 1.3.2b1 to b2 mentions nothing about a fix.)

I've reverted to 1.3.1 stable as I miss MSN :(

Will keep an eye on this ticket and go back to beta when it's fixed.

comment:12 Changed 11 years ago by Richard H.

I got this message too. removing messenger@… from my block list helped however.

comment:13 Changed 11 years ago by Lachlan

@Chain - How do you do that? I can only seem to find a way to block and unblock contacts that are selectable on the contact list, no way to edit a block list or anything?

comment:14 Changed 11 years ago by Dimmuxx

You can see the block list at Adium Menu -> Privacy Settings...

comment:15 Changed 11 years ago by Richard H.

I have to unfortunately correct myself. Reconnecting didn't make any problems. But after restarting Adium it does it again. I even emptied my block list to try, but still, this problem seems to persist. Even a single litte message on *which* contact makes troubles would be helpful. For now, the debug log seems useless for this task...

comment:16 Changed 11 years ago by Dimmuxx

You can also get something like this problem if you have a user on both your block and allow list.

comment:17 Changed 11 years ago by Lachlan

Chain/Dimmuxx - The problem is that you can only edit privacy settings (seemingly) for an account that is online. Since I can't get MSN online in 1.3.2b1 or b2 I reverted to 1.3.1.. I edit the privacy settings for my MSN connection and found that messenger@… contact is on "allow" for it..

I try to remove it and it disconnects MSN, then it reconnects. The Privacy Settings window then flicks back to Account: All and Privacy: (Multiple privacy levels are active) .. (Does this I guess due to MSN going offline and therefore no longer being "selectable" in Privacy settings)

Then when MSN reconnects successfully and I select it from the dropdown again, the contact messenger@… still appears in the "Allow" list.

I guess the problem is that it has been added as a contact or to some list somewhere, but there is a hack/workaround in the MSN library that tells it to ignore it.

comment:18 Changed 11 years ago by Richard H.

Oh... It might sound strange but... I can connect, and I can stay online. Yes in 1.3.2b1 I was d/c 'd, but in b2 it seems to work fine. My list is now empty, and the error still occurs, however in b1 it kept reconnecting and failing, now it stays online, so the error really doesn't bother me too much.

comment:19 Changed 11 years ago by Dimmuxx

asqui: There is a bug in 1.3 and 1.3.1 regarding msn block/allow lists I think so you should try to remove it in 1.2.7.

comment:20 Changed 11 years ago by kari

This problem still exists 1.3.2 meaning that I can't upgrade to it without losing MSN connectivity.

comment:21 Changed 11 years ago by Robert

Keywords: wereon1.3.2 added; msn connect error 205 removed
Milestone: Adium 1.3.2Adium 1.3.3

comment:22 Changed 11 years ago by skrysko

I am having the same problem since updating to 1.3.2 Keep getting the error message: unable to add user (205) everytime I connect to MSN

Changed 11 years ago by Christoffer Sawicki

comment:23 Changed 11 years ago by Christoffer Sawicki

Same problem here. I've attached adium-1.3.2-debug-msn-error.log.txt which is a full debug log for my MSN connection with some personal information stripped.

comment:24 Changed 11 years ago by Dimmuxx

If you do a backup of your ~/Library/Application Support/Adium 2.0 and then delete ~/Library/Application Support/Adium 2.0/Users/Default/libpurple/blist.xml(This will force Adium to redownload the server stored contact lists) you will be able to login at least it seems.

comment:25 Changed 11 years ago by Dimmuxx

The fix that was in libpurple 0.5.1 is commited again because it seems that this is how the official client works more or less so this should work once libpurple is rebuilt.

comment:26 Changed 11 years ago by Christopher J. Bottaro

I'm experiencing this problem also. When Adium logs into my MSN account, I get "Unable to add user - Unknown error (205)", but otherwise, everything works as normal.

comment:27 Changed 11 years ago by Dimmuxx

You should be able to login in 1.3.3b1 at least but you might still get a window about the error.

http://adiumx.cachefly.net/Adium_1.3.3b1.dmg

comment:28 Changed 11 years ago by Robert

pending: 01

Thanks, Dimmuxx. If anyone thinks different, please add a comment. :)

comment:29 Changed 11 years ago by Lachlan

pending: 10

hallelujah! It's a Christmas miracle :)

It all works just dandy for me - thank you to everyone involved!

comment:30 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

asqui, thanks for getting back to us :)

Note: See TracTickets for help on using tickets.