Adium

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#11097 closed defect (fixed)

Yahoo! Error message assumed to be an "authentication failed" event erroneously

Reported by: zacw Owned by: nobody
Milestone: Adium 1.3.2 Component: Adium Core
Version: Severity: major
Keywords: yahoo keychain password save Cc:
Patch Status:

Description (last modified by Zachary West)

A debug log from the forums:

16:17:48: (Libpurple: yahoo) 19 bytes to read, rxlen is 128
16:17:48: (Libpurple: yahoo) Yahoo Service: 0x54 Status: -1
16:17:48: (Libpurple: yahoo) Key: 1     Value: ericajoy
16:17:48: Connection Disconnected: gc=182e5df0 (Unknown error number 0. Logging into the Yahoo! website may fix this.)
16:17:48: -[AIAccount(Abstract) serverReportedInvalidPassword]: <ESPurpleYahooAccount:15d27530 1>:ericajoy
16:17:48: <ESPurpleYahooAccount:15d27530 1>:ericajoy accountConnectionReportDisconnect: Unknown error number 0. Logging into the Yahoo! website may fix this.
16:17:48: (Libpurple: yahoo) 69 bytes to read, rxlen is 89
16:17:48: (Libpurple: yahoo) Yahoo Service: 0x7d1 Status: -1
16:17:48: (Libpurple: yahoo) Key: 66     Value: 1014
16:17:48: (Libpurple: yahoo) Key: 16     Value: 42352,ericajoy,ericajoy,*.*.*.*,84,-1
16:17:48: (Libpurple: yahoo) Unhandled service 0x7d1
16:17:48: <ESPurpleYahooAccount:15d27530 1>:ericajoy: Telling the core we disconnected

We're taking the "Unknown error number 0. Logging into the Yahoo! website may fix this." to be an authentication error: in fact, libpurple is saying so in its disconnect reason (PURPLE_CONNECTION_ERROR_AUTHENTICATION_FAILED).

Attachments (1)

2008-09-25.log (24.2 KB) - added by Arthur Coleman 11 years ago.
Debug Log (Yahoo problem with v1.3.2b1)

Download all attachments as: .zip

Change History (26)

comment:1 Changed 11 years ago by Zachary West

Description: modified (diff)
Milestone: Adium 1.3.2
priority: normalhighest
Reporter: changed from Dan Miller to Zachary West
Severity: normalmajor
Summary: Adium 1.3.1 forgets keychain saved Yahoo Messenger password running Mac OS 10.5.5Yahoo! Error message assumed to be an "authentication failed" event erroneously

I'm taking over this ticket and deleting everything that was in it before. Sorry.

comment:2 Changed 11 years ago by Zachary West

Keywords: yahoo keychain password save added

Adding some keywords so hopefully people don't dupe this one. Feel free to forward-dupe to this one the horribly-wrong reports of us forgetting Yahoo passwords.

comment:3 Changed 11 years ago by Dan

So the correct behavior is that Adium should quietly reconnect to Yahoo?

I notice that the "regular" Yahoo client does not fall off Yahoo like this. Nor does it happen in Trillian on a peecee. As to the cause on Yahoo's side, I think they're having some network problems. Traces to scs.msg.yahoo.com are showing very high latencies and path changes. fwiw.

comment:4 Changed 11 years ago by Zachary West

comment:5 Changed 11 years ago by Peter Hosey

Component: Adium Corelibpurple

Given the Pidgin tickets, it sounds like this is a libpurple problem, not an Adium problem.

comment:6 Changed 11 years ago by lees312

I am having the same problem since I downloaded the newest version of Adium 1.3.1 I keep getting logged off and asked for my password on yahoo. I am not having this problem when I use the regular Yahoo so I believe it is an adium problem. I am running a 10.4.11

comment:7 Changed 11 years ago by ralfy

Same problem here, I was using 1.3.1 with 10.5.5. It disconnected me every few hours, and had to manually reconnect. Now I'm back to 1.2.7 until the problem is solved.

comment:8 Changed 11 years ago by Daniel Spisak

Adium is being disconnected from Yahoo and refusing to reconnect because of libpurple. Libpurple pings the Y!IM servers too often and to Yahoo this looks like a DoS attack. The official Y!IM client I believe only pings the servers 4 times an hour. Any more then that and the Y!IM servers will ban your IP for some period of time.

comment:9 Changed 11 years ago by Dan

The pidgin devs have fixed this in libpurple. http://developer.pidgin.im/ticket/7161

Dimmuxx send me a build of Adium 1.3.2 with a new libpurple a few hours ago. So far it's working great! No YIM drops at all, whereas 1.3.1 was dropping often.

comment:10 Changed 11 years ago by Marc Bejarano

cc me

comment:11 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [25203]) im.pidgin.pidgin 2.5.2mtn @ 741d3db56d7408 which fixes Yahoo disconnection problems (Fixes #11097)

comment:12 Changed 11 years ago by Marc Bejarano

and 1.3.2b1 with this fix is now at http://beta.adiumx.com/ :)

comment:13 Changed 11 years ago by ralfy

I'm still having this problem with 1.3.2b1. Keeps disconnecting me and asking me for my password...

comment:14 Changed 11 years ago by EricaJoy

Still having this problem in 1.3.2b1 as well. I'll try to grab data from the log next time it happens again.

comment:15 Changed 11 years ago by K

I am still having the problem also even with 1.3.2b1 installed. Yahoo is continuing to disconnect randomly and does not retain password when prompted to log in.....

Changed 11 years ago by Arthur Coleman

Attachment: 2008-09-25.log added

Debug Log (Yahoo problem with v1.3.2b1)

comment:16 Changed 11 years ago by strredwolf

Kopete from KDE on Linux also suffers from this problem.

comment:17 Changed 11 years ago by K

I reverted to 1.2.7 and am still having the disconnect issue. I have logged on to Yahoo using their app and so far the disconnects have not happened. Only when using Yahoo via Adium. I have read online that users of Pidgin and Trillium are having the same issues with Yahoo. Not sure if any of this is helpful........

comment:18 Changed 11 years ago by Iain MacDonnell

FWIW, I was experiencing the problem on a daily basis with 1.3.1. I installed 1.3.2b1 4 days ago, and have not experienced the problem at all since then.

comment:19 Changed 11 years ago by Brian

FWIW, I upgraded to 1.3.2 after the release today, and I just got another Yahoo disconnection. It looks like this problem isn't quite solved yet.

comment:20 Changed 11 years ago by Matthew Cave

I can also verify that disconnect issue is still present after upgrading to 1.3.2.

comment:21 Changed 11 years ago by Zachary West

The server has you temporarily blacklisted. Wait a few hours and it'll clear up.

comment:22 Changed 11 years ago by Matthew Cave

I'm not sure if this is what you meant, but I re-connected just fine. But the "Yahoo disconnect, and Adium asks for password (pre-populated) so just hit OK" behavior is still present in 1.3.2

comment:23 Changed 11 years ago by K

UPDATE: I reverted to 1.2.7 on my G4 Powerbook and then updated to 1.3.2b, .......bypassing 1.3.1 completely..... and have had no further Yahoo disconnect issues. I have repeated this procedure with my dual-core iMac and have had the same result. Skipping the install of 1.3.1 seems to have eliminated the problem. Not sure why. I'll leave you all to figure out that one. :)

comment:24 Changed 11 years ago by Zachary West

Component: libpurpleAdium Core

Removing 'libpurple' component.

comment:25 in reply to:  23 Changed 10 years ago by Mike Smith

Removed spam

-Robby

Note: See TracTickets for help on using tickets.