Adium

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#11059 closed defect (fixed)

Pasting specific URL in a conversation leads to buggy behavior!

Reported by: cstromme Owned by: earthmkii
Milestone: Adium 1.3.2 Component: Message View
Version: Severity: major
Keywords: URL, conversation Cc:
Patch Status:

Description

After pasting the url at the end of this message in a conversation the following happens:

  1. I can not see the url in the conversation
  2. Anything I type in after it does not come up neither at my end or the other, but I do see the replies back from the other party
  3. I can no longer close the window with CMD+W

I'm using Modern View here, not sure if that has anything to do with it.

Here's the url: http://vg.transact.no/Item.asp?GroupID=178&Group=Dataspill&ThreadID=1409326&Thread=S%uFFFDPPEL%20BIL%20simulator%20

Change History (10)

comment:1 Changed 11 years ago by Jordan

Milestone: Adium 1.3.2
Owner: set to Stephen Holt
priority: normalhigh
Severity: normalmajor
Version: 1.3.11.3.2b1

Confirmed with Stockholm message style on 1.3.2b1

Since it's impossible to close the window/tab after doing this, without restarting Adium, I'm raising the priority.

comment:2 Changed 11 years ago by Jordan

Milestone: Adium 1.3.2Adium 1.3.3

comment:3 Changed 11 years ago by Stephen Holt

Status: newassigned

This definitely happens in the link parsing, but i don't know where or how -- the string apparently is getting mangled before it even hits any of the lex code.

comment:4 Changed 11 years ago by Stephen Holt

There is an unescaped '%' character in the URL, and it looks like the string is corrupted when it gets converted from an Attributed string to an NSString before it's even scanned. Removing that character makes the string linkify correctly.

I'll mockup a driver app to test this later, but this URL works as expected ('%' encoded into '%25') http://vg.transact.no/Item.asp?GroupID=178&Group=Dataspill&ThreadID=1409326&Thread=S%25uFFFDPPEL%20BIL%20simulator%20

comment:5 Changed 11 years ago by sholt

(In [25236]) NSURL has some difficulties with string formatting escaped in URLs, as does CFURLCreateStringByReplacingPercentEscapesUsingEncoding. While I'm investigating workarounds, this is a quick-fix to keep AutoHyperlinks from freezing up the app when one is encountered. Refs #11059.

comment:6 Changed 11 years ago by sholt

(In [25237]) Better way of doing [25236]. Refs #11059.

comment:7 Changed 11 years ago by sholt

Resolution: fixed
Status: assignedclosed

(In [25239]) Merging [25237] to 1.3 branch. Fixes #11059.

comment:8 Changed 11 years ago by Stephen Holt

Milestone: Adium 1.3.3Adium 1.3.2

comment:9 Changed 11 years ago by Stephen Holt

Opened ticket #11160 to track a proper fix for this bug.

comment:10 Changed 11 years ago by sholt

(In [25240]) One more place to fix #11059. Stupid special case code... do we even need this anymore?

Note: See TracTickets for help on using tickets.