Adium

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#10921 closed defect (fixed)

"id=insert" became required for status.html in Adium .80, breaking existing message styles

Reported by: mathuaerknedam Owned by: evands
Milestone: Adium 1.3.3 Component: Message View
Version: Severity: regression
Keywords: Cc:
Patch Status:

Description

When webkit message views were first introduced, an id=insert was not required (or functional) in status.html. If I download an old message style (say, Sharp), and look at the chat preview in the messages prefpane, the second of the two status messages will be missing. It does not contain the [now] obligatory id=insert, but adding it makes the second status message appear and the preview now looks like the xtras screenshot from 05/13/04. Sharp works as expected in Adium .77, but in .80 the consecutive status message disappears.

Just for reference, this shows that the earliest version of Mockie (from 04/23/2004) didn't have id=insert either. It was added here on 04/04/2005. (It's probable that nobody needs this, but I already looked it up, so here it is!)

I suspect that *many* old messages style are broken in this way. At the very least I'd guess that the 4 dozen or so that were released before Adium .80 came out. The Tutorial didn't include one (until a week ago!), so people were either building from instructions that didn't say to use it, or altering styles from a time when it wasn't even functional.

Change History (17)

comment:1 Changed 11 years ago by mathuaerknedam

Summary: Did "id=insert" become required for status.html?"id=insert" became required for status.html in Adium .80, breaking existing message styles

comment:2 Changed 11 years ago by Jordan

Milestone: Adium 1.4

So you opened this so that we could update the documentation and build this into that versioning system that Evan started?

I think I'll add message style versioning/compatibility updates to the 1.4 milestone...

comment:3 Changed 11 years ago by mathuaerknedam

Well, I opened it because Evan asked me to open a ticket to document places where new versions of Adium break message styles that worked previously (within it's supported MessageViewVersion). The documentation from that far back is a bit sparse; I've not found any thing to indicate why the change was made without incrementing MVV. Perhaps it predates MVV?

comment:4 Changed 11 years ago by Robert

If this is a regression why is it milestoned for 1.4, may I ask?

comment:5 Changed 11 years ago by Jordan

Well... it's a regression from many many many versions ago, I don't see it being problematic to wait for one more major version. Plus there have been more than a couple message style issues that have been reported - why not put 'em all down for 1.4 and see if we can get that versioning system done at the same time. (Just a thought)

comment:6 in reply to:  5 Changed 11 years ago by mathuaerknedam

Replying to jas8522:

...and see if we can get that versioning system done at the same time. (Just a thought)

There is already a versioning system in place, and I'm aware of David working on a big WKMV rewrite (MVV=5) for 1.5. Is there some other versioning system being considered?

comment:7 Changed 11 years ago by Jordan

Oh maybe not... I thought there was a commit last week or so about having a 'basic versioning system' added in to 1.4svn but perhaps I misinterpreted...

comment:8 Changed 11 years ago by Robert

Ah, ok.

comment:9 Changed 11 years ago by mathuaerknedam

The only new versioning that I'm aware of is for plugins.

comment:10 Changed 11 years ago by Robert

Milestone: Adium 1.4Adium 1.3.x

"Regressions shouldn't be tolerated". ;)

comment:11 Changed 11 years ago by Robert

Milestone: Adium 1.3.xAdium 1.3.3

As it's a regression...

comment:12 Changed 11 years ago by Evan Schoenberg

Message styles have always been versioned. Unfortunately, the documentation didn't state this required tag until recently, so even recent versions can't be trusted.

comment:13 Changed 11 years ago by Evan Schoenberg

Owner: set to Evan Schoenberg
Status: newassigned

comment:14 Changed 11 years ago by Evan Schoenberg

Sharp includes its own template.html. That template.html refers to the 'insert' div, but the style's status.html doesn't include one. Similarly, the old version of Mockie to which you link above did the same thing.

comment:15 Changed 11 years ago by Evan Schoenberg

(In [25544]) If a style doesn't include an 'insert' div but does let the default template.html be used by not overriding it, we now fall back on not treating the addition as a consecutive addition. This fixes a small number of cases of old styles which don't have an 'insert' div in their Status.html, but does not fix most of them since most override the template.html, as well. Refs #10921

comment:16 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [25545]) For version 0 message styles with a custom template.html, such as Sharp, use APPEND_MESSAGE_WITH_SCROLL for consecutive status messages so they will be properly displayed. Fixes #10921

comment:17 Changed 11 years ago by Evan Schoenberg

(In [25546]) Merged [25544] and [25545]: For version 0 message styles with a custom template.html, such as Sharp, use APPEND_MESSAGE_WITH_SCROLL for consecutive status messages so they will be properly displayed. Fixes #10921

Note: See TracTickets for help on using tickets.