Adium

Opened 15 years ago

Closed 15 years ago

Last modified 12 years ago

#1085 closed defect (fixed)

Some URLs gets a %0D suffix

Reported by: Lfe Owned by: nobody
Milestone: Adium X 1.0 Component: Service/MSN
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

When sending and receiving some Links trough a chat, the suffix %0D is added.

This doesn't apply every time a link is sent or recieved either. The other side is also affected.

Using svn .9 r13025, confirmed from a user with r12454 aswell.

Change History (5)

comment:1 Changed 15 years ago by anonymous

A bit further info on this, I've determined it to happen on the msn protocol, if the sending user adds a line feed immediately after the link (whether intentional or by copy & paste). This is the only scenario I've seen it happen in, though it may happen in others. Using adiumx 0.83rc1 Aug 19 2005.

comment:2 Changed 15 years ago by adamiser

I am able to reproduce this. In Mac MSN, open an IM to someone on Adium and enter "www.adiumx.com", then press option-return, then press return to send the message. The link will contain a %0D.

comment:3 Changed 15 years ago by wengero

field_haspatch: 0
Milestone: Adium X 1.0
Resolution: fixed
Status: newclosed

i followed your steps and am unable to reproduce it anymore

comment:4 Changed 14 years ago by Chris Forsythe

Component: libgaim-generalMSN

comment:5 Changed 12 years ago by Peter Hosey

(In [23554]) Added test cases for whitespace before and after URIs. Refs #1085.

Note: See TracTickets for help on using tickets.