Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#10814 closed defect (fixed)

Adium changes status text to status (Dutch, Away status only)

Reported by: eriq Owned by: felipec
Milestone: Adium 1.3.2 Component: Adium UI
Version: Severity: minor
Keywords: msn, status text, status, dutch Cc:
Patch Status:

Description

Hi,

I realize the short summary may seem confusing, let me explain. The problem is that Adium changes my status text (aka. 'personal status') to the status I set. This only seems to occur with the 'Away' - and (as far as I've noticed) only when the (system) language is set to Dutch.

For the record, 'Away' in Dutch is 'Afwezig'. When I set my status to being Away (Afwezig), My nickname will display as 'Nickname (Afwezig) - Afwezig' for MSN users, while that's not the case with other statuses, like Busy. It should be 'Nickname (Afwezig)', optionally with a status text (if set). The status text does get overridden when you set it manually.

Attachments (2)

Afbeelding 1.png (8.7 KB) - added by Erik 12 years ago.
Away status - Status text should be empty
Afbeelding 2.png (6.7 KB) - added by Erik 12 years ago.
Busy status - The way it should be

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by Erik

Attachment: Afbeelding 1.png added

Away status - Status text should be empty

Changed 12 years ago by Erik

Attachment: Afbeelding 2.png added

Busy status - The way it should be

comment:1 Changed 12 years ago by Jordan

Resolution: worksforme
Status: newclosed

This seems to be behaving as it's supposed to.

  1. You set your status message to something.
  2. Change your status to away
  3. Unless you chose to set a custom status, it will overwrite your status message to nothing
  4. If you chose the 'away' status, then it actually gets set to "Away" on the MSN protocol.

comment:2 in reply to:  1 Changed 12 years ago by Erik

Replying to jas8522:

This seems to be behaving as it's supposed to.

  1. You set your status message to something.
  2. Change your status to away
  3. Unless you chose to set a custom status, it will overwrite your status message to nothing
  4. If you chose the 'away' status, then it actually gets set to "Away" on the MSN protocol.

I'm sorry, but I have to respectfully disagree. I'll try to explain why. From now on I'll refer to the "status text" as "personal text" to hopefully make things clearer.

The steps you mentioned are correct. However, when you set your status to Away, Adium should _clear_ your personal text *unless* you provide one yourself. This is the case for all other statuses being "Busy", "On the Phone", "Out to Lunch" and "Be Right Back". It's inconsistent to not also do this for the Away status.

The way it's set up right now, you can never set your status to Away and have an empty personal text, because it's always getting set to 'Away' (or in my case, 'Afwezig') if you decide to leave it empty. There's really no reason to do so, since the personal text (or status text, if you will) are two separate things - at least on the MSN protocol.

The way it's now (Away status):

  1. You are online - personal text set or not (not relevant)
  2. You set your status to "Away" and don't set a personal text

Result: You're status will change correctly but your personal text also changes to the word "Away" ("Afwezig" in Dutch) - which it shouldn't.

The way it should be (and is for all other statuses):

  1. You are online - personal text set or not (not relevant)
  2. You set your status to "Busy" and don't set a personal text

Result: You're status will change correctly and your personal text will clear - which it should.

I hope you'll reconsider. It's just a tiny glitch but a rather annoying one - at least to me. People actually take the time to ask me why I felt the need to set my status twice (status + personal text) - which resulted in my always setting my status to "Busy" to avoid having me to explain :-)

comment:3 Changed 12 years ago by Erik

Not fixed yet (in my opinion).

comment:4 Changed 12 years ago by Felipe Contreras

Component: msn-pecanAdium UI
priority: normalhigh
Resolution: worksforme
Severity: normalminor
Status: closedreopened

I agree with eriq here.

In fact, the personal message should be completely independent of the status; it's not a status message as in other protocols.

I tried to convince Pidgin guys this was the case, but they didn't agree. Many msn-pecan users agree the status quo is not ideal: http://code.google.com/p/msn-pecan/issues/detail?id=51

comment:5 Changed 12 years ago by Jordan

Milestone: Adium 1.3.2

So status messages should never be set to the actual status... I'm not sure how that does any harm to have it do so, but sure :)

The real problem is that the status being set as the status message is actually overwriting personal messages, which is another ticket anyway.(#11034)

comment:6 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [25157]) Don't set 'away' as a the status message for a no-message away status for MSN. Fixes #10814

comment:7 Changed 12 years ago by Evan Schoenberg

(In [25158]) Merged [25157]: Don't set 'away' as a the status message for a no-message away status for MSN. Fixes #10814

Note: See TracTickets for help on using tickets.