Adium

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#10808 closed crash (fixed)

Adium 1.3 crashes in DNS resolution when trying to connect to MSN

Reported by: markpalavra Owned by: nobody
Milestone: Adium 1.3.1 Component: Adium Core
Version: Severity: major
Keywords: Cc:
Patch Status:

Description

Hi

I've been trying to get some help from the IRC channel, but everything we've tried is hitting a dead-end.

I had 1.3b11 earlier today, installed 1.3 over the top of it, and then it would crash as soon as it tried to connect to an account (which I would find out later specifically MSN).

Tried doing everything on the troubleshooting page, nothing helped.

Ending up deleting everything including the library app support folder and the application file, reboot, reinstall from clean slate, and still same problem.

The first time I run it after install it will allow me to add my MSN account and then when I hit continue and it tries to connect, I get an instant crash. I can hold down Shift after this and it will open, and I can go through all the menus etc, but as soon as I try to connect, it crashes.

If I delete the MSN account and just have my Facebook account, it works fine.

Now here comes the really weird part...

After I added the Facebook account and connected, I went to Adium > Preferences .. and from that Window, in the Accounts tab, I added my MSN account. After I added the account underneath my Passport address in the box it started going through a progress of things like "Getting handshake" and "Getting cookie" ... and miraculously it connected, and all my contacts were displayed.

Although, as soon as I quit and tried to restart Adium, it would continue to crash when attempting to connect to MSN.

This problem is reproducible every time I try to connect to MSN the regular way.

I'm running 10.5.4 on a 24" 2.4ghz iMac .. all the other apps on here are pretty run of the mill, and nothing out of the ordinary. Everything else is working tip top.

Attachments (1)

crash.rtf (31.9 KB) - added by markpalavra 11 years ago.
Crash Report

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by markpalavra

Attachment: crash.rtf added

Crash Report

comment:1 in reply to:  description Changed 11 years ago by markpalavra

By the way ... for the time being I've gone back to b11 and it works A-OK.

comment:2 Changed 11 years ago by Robert

Component: Adium Coremsn-pecan
Milestone: Waiting on msn-pecan
Owner: changed from nobody to Felipe Contreras
priority: normalhigh
Severity: normalcritical

Good report, thanks! :)
As I can't read debug logs, I can't tell whether it's a duplicate of one of the crashes on the msn-pecan milestone. Anyhow, they should been fixed in time for the release so you're fine.

comment:3 Changed 11 years ago by Felipe Contreras

That's really weird, I can't see anything related to msn-pecan in the crash:

Thread 0 Crashed:
0   com.apple.CoreFoundation      	0x968ec2d4 CFRetain + 36
1   com.apple.CoreFoundation      	0x9687af25 CFArrayCreate + 357
2   com.apple.CFNetwork           	0x93f918a8 CFHostCreateWithName + 72
3   com.adiumX.AdiumPurple        	0x15e37669 -[AdiumPurpleDnsRequest startLookup] + 112
4   com.adiumX.AdiumPurple        	0x15e3784c adiumPurpleDnsRequestResolve + 58
5   libpurple                     	0x178915d4 purple_dnsquery_ui_resolve + 69
6   libpurple                     	0x17892025 handle_next_queued_request + 92
7   libpurple                     	0x1789240e resolve_host + 27

comment:4 Changed 11 years ago by Robert

Component: msn-pecanlibpurple
Milestone: Waiting on msn-pecanAdium X 1.3.1
Owner: changed from Felipe Contreras to nobody

Ok, let's see what Evan says.

comment:5 Changed 11 years ago by eraser85

I figured out a repeteable situation which leads to crash Adium at startup when trying to connect to an MSN account. I'm connected to the internet through my university's wireless service, it's completely free and does not even requires a password in order to connect to it.

However, in order to gain access to the web you have to put your personal user/password, and that's accomplished through a web interface which gets loaded automatically whenever you try to connect to the web.

So, if I launch Adium when connected AND authenticated it does start up correctly and doesn't crash. But, if I'm not authenticated (haven't put user/password yet) then Adium crashes.

The crash can be related to the connection at startup, maybe you're waiting for and explicit response from your connection algorithm which could be different in some cases.

Using 1.3, MacOS X 10.5.4.

comment:6 Changed 11 years ago by Felipe Contreras

Could be, but I think this is in Adium core.

comment:7 Changed 11 years ago by markpalavra

I'm on a private secure wireless network at home.

comment:8 Changed 11 years ago by Evan Schoenberg

Summary: Adium 1.3 crashes when trying to connect to MSNAdium 1.3 crashes in DNS resolution when trying to connect to MSN

This might be somehow connected to it being MSN, but I think it's more likely a generic issue with the DNS lookup code, possibly related to a DNS lookup failing.

comment:9 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

Fixed in [24987] on the 1.3 branch; fix committed upstream to im.pidgin.pidgin in [50be1dba5568bb36004d300f202b0dd3af444053]. Future build on trunk will fix it there.

comment:10 Changed 11 years ago by Evan Schoenberg

Please verify that Adium_1.3.1svn20080826 fixes this problem for you.

comment:11 in reply to:  10 Changed 11 years ago by markpalavra

Replying to evands:

Please verify that Adium_1.3.1svn20080826 fixes this problem for you.

Verified, thank you.

comment:12 Changed 11 years ago by Zachary West

Component: libpurpleAdium Core

Removing 'libpurple' component.

Note: See TracTickets for help on using tickets.