Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#10752 closed defect (fixed)

Spellcheck defaults to systemwide default language in 1.3b11

Reported by: mrgann Owned by: berdan
Milestone: Adium 1.3.1 Component: Localization
Version: Severity: regression
Keywords: default english Cc:
Patch Status:

Description

I have used Hungarian spell checking in Adium for ages, yet after downloading the new beta (of which i know that it is a beta:) ) I found that after opening a chat window I have to set the spellchecker's language each and every time.

Change History (14)

comment:1 Changed 12 years ago by András Hann

Wierd. It remembers the setting for _some_ contacts, but not all of them.

comment:2 Changed 12 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

See TroubleshootingTips - try a fresh OS X user account and see if you can reproduce. Don't forget to do this with 1.3b12

comment:3 Changed 12 years ago by Jordan

Milestone: Needs feedback from usersAdium X 1.3.1
Version: 1.3b111.3

comment:4 Changed 12 years ago by Jordan

pending: 10
Severity: normalregression

comment:5 Changed 12 years ago by DWizzy

Same problem here: language changed (for every application) from Multilingual to English, the moment I installed 1.3 I unfortunately do not have the time to create a fresh account to try and reproduce.

comment:6 Changed 12 years ago by András Hann

OK in the final 1.3 it keeps track of language setting for every contact, so if I set it once, it is there forever. I think I can live with it now.

comment:7 Changed 12 years ago by DWizzy

I can not replicate the 'remembered' language. Chat windows when closed and reopened return to English.

comment:8 Changed 12 years ago by Evan Schoenberg

(In [24978]) Added debug logging which shows the user's preferred spell checking language. Refs #10752

comment:9 Changed 12 years ago by Evan Schoenberg

Please follow the steps at CurrentAdiumDebug while using Adium_1.3.1svn20080826 and show a debug log of Adium starting up while you hold the Shift key. It should show information about your preferred languages.

You will need to load Adium, open the debug window, and then quit Adium with the debug window first so that it captures all debug logging as Adium loads the next time.

comment:10 Changed 12 years ago by DWizzy

I stand corrected: language seems to be remembered when I reopen a chat window (and seems to be remembered system-wide)

evands: thanks for the interest shown, per your request my log upon restarting when my language was set to 'multilingual':

11:49:53: -[AILoggerPlugin loadDirtyLogArray]: Loaded dirty log array with 5 logs
11:49:54: -[OWSpellingPerContactPlugin installPlugin]: Preferred spell checking language is en from choice set (en, nl, de, fr, es, it, sv, nb, da, fi, pt, ja, "zh-Hans", "zh-Hant", ko)
11:49:54: -[AIPreferenceContainer prefs]: I read in AccountPrefs with 38 items

This strengthens an earlier theory I had: it chooses the top language set in the "International" Preference pane, which is English in my case. I would just like to continue with multilingual. I'll try and change that top language later on to make sure (have to log in again..)

comment:11 Changed 12 years ago by DWizzy

Had time to restart my system earlier than expected. Hypothesis confirmed, I suggest the title of this ticket be changed to: "Spellcheck resets to system language"

12:10:29: -[OWSpellingPerContactPlugin installPlugin]: Preferred spell checking language is nl from choice set (
    nl, 
    "en-GB", 
    en, 
    de, 
    fr, 
    es, 
    it, 
    sv, 
    nb, 
    da, 
    fi, 
    pt, 
    ja, 
    "zh-Hans", 
    "zh-Hant", 
    ko
)

(notice that the array now has one item per line instead of all one line?)

comment:12 Changed 12 years ago by Evan Schoenberg

Summary: Spellcheck defaults to US English in 1.3b11Spellcheck defaults to systemwide default language in 1.3b11

comment:13 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [25010]) When setting the spelling preference for the language, store it globally in addition to at a per-contact level so that it will be used as the default for future chats. Fixes #10752

comment:14 Changed 12 years ago by Evan Schoenberg

(In [25014]) Merged [25010]: When setting the spelling preference for the language, store it globally in addition to at a per-contact level so that it will be used as the default for future chats. Fixes #10752

Note: See TracTickets for help on using tickets.