Adium

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#1055 closed defect (fixed)

(null) in Get Info window

Reported by: fredhope2000@cox.net Owned by: evands
Milestone: Adium X 1.0 Component: Service/AIM
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

I got info on a friend who isn't on my buddy list (so I could give him an alias), but the info window was titled (null)'s Info and the screen name was 48 (not related at all to his actual screen name). See http://members.cox.net/fredhope2000/adiumgetinfo.png.

In Console, all of his messages until I gave him the alias were presented as if his screen name were (null).

(AIM service, Adium .83b4)

Change History (11)

comment:1 Changed 14 years ago by Zachary West

Are you able to reproduce this bug at all? If so, can you give any specifics?

comment:2 Changed 14 years ago by FredAkbar

Nope. I just got on another screen name in the official client (after removing the screen name from my buddy list), IMed myself, and got info on my other screen name in Adium but it worked fine. So it's a random occurance.

comment:3 Changed 14 years ago by Zachary West

Resolution: invalid
Status: newclosed

If anyone is able to duplicate this issue, feel free to reopen the ticket.

comment:4 Changed 14 years ago by imk

Resolution: invalid
Status: closedreopened

I don't get that window when I view anyone else's info but I get it if I try to view my own info. I can reproduce it every time. I've also been able to reproduce it in all 0.82, 0.83 and 0.84 betas and release.

If I go to the menu and choose to start a new chat. I type in my own name (my sn on aim, for example). It will open a window to myself and I can type and see it come back to me. If I choose to view the info it will open the info window and say (null)'s info and show my username as 1.

comment:5 Changed 14 years ago by Chris Forsythe

Milestone: Adium X 1.0

comment:6 Changed 14 years ago by Zachary West

I've experienced this once. I had a user on my buddy list on two accounts and tried to get info. Didn't replicate. :/

comment:7 Changed 14 years ago by Evan Schoenberg

It has something to do with:

  • A metacontact
  • which has no contained contacts currently known to be online to any connected account
  • and no alias at present

I believe.

comment:8 Changed 14 years ago by Evan Schoenberg

field_haspatch: 0
Milestone: Adium X 1.0

I can't reproduce this now, but that doesn't mean it's fixed but rather just rare... not blocking 1.0 on it.

comment:9 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.0
Owner: changed from nobody to Evan Schoenberg
Status: reopenednew

I not only found the reproduction while working on #2424, I found the fix.

comment:10 Changed 14 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [14823]) Fixed determination of which contact to show when doing a Get Info; this prevents a situation in which a metacontact would be selected for getting info when the metacontact was actually effectively hidden because it had no contained list objects which were on any online contact list. Fixes #1055

comment:11 Changed 14 years ago by Evan Schoenberg

(In [14824]) Oops, the commit message for [14823] was supposed to go here. Fixed determination of which contact to show when doing a Get Info; this prevents a situation in which a metacontact would be selected for getting info when the metacontact was actually effectively hidden because it had no contained list objects which were on any online contact list. Fixes #1055

Note: See TracTickets for help on using tickets.