Adium

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#10541 closed defect (fixed)

New messages appear with history scrolled to top (oldest)

Reported by: mcraig Owned by: evands
Milestone: Adium 1.3.3 Component: Message View
Version: Severity: regression
Keywords: wereon1.3.2 Cc:
Patch Status:

Description

When receiving or sending new messages, the history in the window defaults to oldest (scrollbar at top). This is new in the 1.3 betas.

Reproduce (Number of messages in log == 80)

1) Initiate chat with contact 2) Notice scroll bar is at top of chat window.

OR

1) Receive new message 2) notice that new message not visible since log is scrolled to oldest.

Change History (32)

comment:1 Changed 12 years ago by Evan Schoenberg

What message style?

comment:2 Changed 12 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

Yeah I can't reproduce this with 1.3b9 using Stockholm... as Evan asked, what message style are you using? Did you try any of the TroubleshootingTips?

comment:3 Changed 12 years ago by mathuaerknedam

Component: Adium UIMessage View
Owner: nobody deleted
Version: 1.3b9

Last week I helped someone debug a similarly described (possible identical) problem in an unreleased messagestyle. The problem was reported to be sporadic, so I wasn't able to get confirmation that my suggestion helped. Nonetheless, I was able to consistently see the problem in the messages prefpane preview, and I think updating the messageviewversion (in info.plist) from v1 to v3 fixed the problem (worked for me). This ticket is the first indication I've seen that the problem might be linked to a change in Adium or be more widespread than the particular style I was looking at.

comment:4 Changed 12 years ago by wagnerone

Happening to me too with 1.3b9

I'm seeing it in some messagestyles I choose from those that have been on my system for a good while.

Examples:

Metal Chat 2 (AvG remix).AdiumMessageStyle h4x0r.AdiumMessageStyle

I updated the messageviewversion (in info.plist) from v1 to v3 which fixed the problem in "Metal Chat 2 (AvG remix).AdiumMessageStyle", but haxor didn't have that value to change.

Seems various other messagestyles I choose are OK.

comment:5 Changed 12 years ago by Jordan

Resolution: worksforme
Status: newclosed

So this is basically up to the message style developers to update their styles.. If you are using a style that this bug appears in, you should post it to the comments of that style on adiumxtras.com or email the dev directly.

comment:6 Changed 12 years ago by mathuaerknedam

I'm not sure that this should be a messagestyle author problem. As I understand it, the messageviewversion key was created (at least in part) to prevent Adium updates from breaking messagestyles that already work fine. If this is true, it seems like the best route is to figure out what in Adium changed and make it so that messagestyles with messageviewversion < 3 are unaffected.

comment:7 in reply to:  4 Changed 12 years ago by mathuaerknedam

Replying to wagnerone:

I updated the messageviewversion (in info.plist) from v1 to v3 which fixed the problem in "Metal Chat 2 (AvG remix).AdiumMessageStyle", but haxor didn't have that value to change.

You should be able to add it.

I will note (for everyone) that I've seen different things in a messagestyle break when the messageviewversion is changed. So while doing so may fix this particular problem, it may create other problems in the messagestyle that will need to be fixed.

comment:8 Changed 12 years ago by Evan Schoenberg

A message style of a given version should always work in all versions of Adium which support that version. That's the point of versioning.

mathuaerknedam, if you can note specific breakages in individual tickets, that would be helpful. I believe 1.3b10 has a couple fixes for issues you reported.

comment:9 Changed 12 years ago by Jordan

Milestone: Needs feedback from usersAdium X 1.3.1
Resolution: worksforme
Status: closedreopened

comment:10 in reply to:  8 ; Changed 12 years ago by mathuaerknedam

Replying to evands:

mathuaerknedam, if you can note specific breakages in individual tickets, that would be helpful. I believe 1.3b10 has a couple fixes for issues you reported.

I think I may have been unclear. I was trying to say that I've seen messagestyles break when I've changed that value of messageViewVersion without changing anything else. Is that what you're asking me to document? I can try to do that, but I tend to think that changing the messageViewVersion without making accommodation for the changes in Adium is asking for the breakage the the version was intended to prevent. Nevertheless, I can see such a list being useful for anyone wanting to update a messagestyle.

My statement above that I've seen other things break was *not* that I've seen Adium updates break previously working styles. I have, but that's not what I was saying here. I do try to document whatever I notice, though I can think of a minor problem in mvv=1 I've not reported yet. :) I'm usually running trunk and I've been happy see all the fixes.

comment:11 in reply to:  10 Changed 12 years ago by Evan Schoenberg

Replying to mathuaerknedam:

Replying to evands:

mathuaerknedam, if you can note specific breakages in individual tickets, that would be helpful. I believe 1.3b10 has a couple fixes for issues you reported.

I think I may have been unclear. I was trying to say that I've seen messagestyles break when I've changed that value of messageViewVersion without changing anything else. Is that what you're asking me to document? I can try to do that, but I tend to think that changing the messageViewVersion without making accommodation for the changes in Adium is asking for the breakage the the version was intended to prevent. Nevertheless, I can see such a list being useful for anyone wanting to update a messagestyle.

Oh. No, don't make that listing. That's exactly what I would expect; if no changes were necessary, there also wouldn't be a need for a new version number!

comment:1 Changed 11 years ago by trac-robot

pending: 10
Status: reopenedclosed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:2 Changed 11 years ago by mathuaerknedam

Status: closedreopened

Looking back at this, I think the pending bit didn't get twiddled when this was reopened and the resolution was changed from Needs feedback from users to Adium X 1.3.1. So I'm reopening it again. :)

comment:3 in reply to:  9 Changed 11 years ago by Patrick Fergus

Replying to evands: I'm seeing the history-scrolled-to-the-top issue with the "Fiat" message style under Adium 1.3 and 10.5.4. Didn't see it before Adium 1.3, and am seeing it on two different machines (both on 10.5.4 and 1.3). I have copied the preferences between the two machines in the past, so if this is preference-based that may be the reason.

FWIW, the "demo" of the current message style in the Adium preferences also appears scrolled to the top (only caught that because I was so used to seeing "Gotta run; catch ya later" in that preference pane).

comment:4 Changed 11 years ago by Jordan

Milestone: Adium 1.3.1Adium 1.3.2
priority: normallow
Severity: normalminor

comment:5 Changed 11 years ago by Jim

Yes, this is actually far more than an annoyance.

When new messages appear the window does not scroll with the new message. Instead the window reverts to top of the list meaning you can't see the new message until you manually scroll down (in version 1.3.1).

Yes, this just started over the past month or so it seems.

Using Theme: aqualicious List layout: tiny Windows style: group bubbles

Thanks for reviewing.

Best Wishes, Jim

comment:6 in reply to:  5 Changed 11 years ago by mathuaerknedam

Replying to jfwalkeriii:

Yes, this is actually far more than an annoyance.

Just in case it was clear from previous comments, you can switch to a more up-to-date messagestyle until this problem is resolved. Any of the included styles should work.

comment:7 Changed 11 years ago by Jim

Yes, I was using SimpleSeparateLines (which is awesome IMHO). Hope we can see an update to this in the next version.

Thanks, Jim

comment:8 Changed 11 years ago by Robert

Keywords: wereon1.3.2 added; log history removed
Milestone: Adium 1.3.2Adium 1.3.3

comment:20 Changed 11 years ago by Raptor007

This also occurs with the GoneDark Polarized message style. Hoping to see a fix soon. :¬)

comment:21 Changed 11 years ago by Robert

Severity: minorregression

comment:22 Changed 11 years ago by Robert

priority: lowhighest

comment:23 Changed 11 years ago by Robert

priority: highestnormal

Oops.

comment:24 Changed 11 years ago by mathuaerknedam

I just downloaded all of the styles on adiumxtras.com in order to quantitatively measure the number of styles affected by this and other bugs (and to see how many are themselves broken in specific ways). Out of 232 .adiummessagestyle files, 85 are affected by this regression.

I also discovered that message styles that have added javascript for smoothscrolling are *not* affected by this. This leads me to believe that the bug was introduced by a change to Adium's Template.html. The style I've looked at most closely is Milk Mockie, but it appears to replace most of the Template.html functions. I'll try to determine the problematic function(s), but no guarantees as to when I'll get to it. :)

comment:25 Changed 11 years ago by mathuaerknedam

The smoothscroll javascript just avoids the problem by forcing a scroll to the bottom but the actual problem isn't in in one of the javascript functions of Template.html. If Template.html was a problem I should be able to use the Template.html from 1.2.7 (which does not display this bug) in 1.3 to make the bug disappear, but this is not the case. Similarly, I cannot make the bug appear in 1.2.7 by using the Template.html from 1.3.

comment:26 Changed 11 years ago by Evan Schoenberg

Hardcore bug reporting, mathuaerknedam - thanks!

comment:27 Changed 11 years ago by Evan Schoenberg

Owner: set to Evan Schoenberg
Status: reopenednew

comment:28 Changed 11 years ago by Evan Schoenberg

Status: newassigned

comment:29 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [25783]) Fixed scrolling to the bottom of the chat when it loads for message styles version 0 through 2 which don't include a custom template.html. Fixes #10541

comment:30 Changed 11 years ago by Evan Schoenberg

(In [25785]) Merged [25783]: Fixed scrolling to the bottom of the chat when it loads for message styles version 0 through 2 which don't include a custom template.html. Fixes #10541

comment:31 in reply to:  26 Changed 11 years ago by mathuaerknedam

Replying to evands:

Hardcore bug reporting, mathuaerknedam - thanks!

You're welcome. I was hoping to be able to submit a patch, but I just couldn't figure out what was going on. I'm amused the actual code change was so simple. :)

comment:32 Changed 11 years ago by Evan Schoenberg

One of those cases where figuring out where the problem lies is a ton harder than the fix itself, definitely. :)

Note: See TracTickets for help on using tickets.