Adium

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#10436 closed defect (fixed)

Events can be recorded with wrong contact

Reported by: sightless Owned by: eharris
Milestone: Adium 1.3.3 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

To reproduce:
- Right click a contact in your contact list; Get Info.
- Go to the events tab.
- Click the + button to add an event.
- While the 'add event' sheet is still open, select a different contact
  in your list; the "When <username> <does whatever>" part of the sheet
  remains the same, though the title bar of the info window changes to
  reflect the newly selected contact.
- Finish filling out the add event sheet and click OK. The event is added
  to the newly selected contact, not to the one you clicked + for.

I personally would like to have multiple Get Info windows rather than an
Inspector-like thing, which would solve this problem (except if an Inspector is
still offered, like how the Finder offers both, this would need to be special
cased).

But that's really a feature request, and this is a bug report. I'm not sure of
the best way to get around this in the Inspector situation like Adium currently
has. It would be equally odd to have an event added not appear in the window
(because it is showing a different contact) or to have the window showing a
different contact to that which is selected in the contact list. And making the
add event sheet a modal dialog would be horrible.

I guess one of you guys will pick the best of the bad bunch and implement it! Good luck, and thanks for a great app.

Adium version 1.2.7 on OS X 10.4.9.

Change History (9)

comment:1 Changed 12 years ago by Jordan

Milestone: Adium X 1.3.1

Multiple info windows is anti-inspector-like, so that likely won't be done. Having open sheets with [contact] details update based on the selected contact is the correct behaviour here, so if we can do that, then it's likely the best solution.

comment:2 Changed 11 years ago by Elliott Harris

Owner: set to Elliott Harris
Status: newassigned

This is a pretty insane use case for any piece of software. Changing contacts in the middle of event creation does not merit a special workflow to handle. A request for multiple inspectors is valid (since that does occur in other applications). In this situation however, as soon as you click on another contact, the correct behavior is to cancel the event creation.

It's valid to want to have multiple inspectors, but I don't really see the need, perhaps you can justify your reason for me?

comment:3 in reply to:  2 Changed 11 years ago by Jordan

Replying to eharris:

This is a pretty insane use case for any piece of software. Changing contacts in the middle of event creation does not merit a special workflow to handle. A request for multiple inspectors is valid (since that does occur in other applications). In this situation however, as soon as you click on another contact, the correct behavior is to cancel the event creation.

Yes this is what I was thinking as well.

comment:4 Changed 11 years ago by Jordan

Milestone: Adium 1.3.1Adium 1.3.2

comment:5 Changed 11 years ago by Jordan

Milestone: Adium 1.3.2Adium 1.3.3

comment:6 in reply to:  2 Changed 11 years ago by Ben Schmidt

Replying to eharris:

This is a pretty insane use case for any piece of software. Changing contacts in the middle of event creation does not merit a special workflow to handle. A request for multiple inspectors is valid (since that does occur in other applications). In this situation however, as soon as you click on another contact, the correct behavior is to cancel the event creation.

I fail to see how the use case is insane. Doing only a single task at a time with a computer takes us back 20 years just in Macintosh history. If you think this is insane, though, the correct solution is most certainly to make the add event dialog modal, not to cancel the event creation (which would lose any, perhaps carefully-crafted, text you had entered in the window, which amounts to data loss which is BAD).

It's valid to want to have multiple inspectors, but I don't really see the need, perhaps you can justify your reason for me?

I'd find it handy to be able to see and edit notes from more than one contact on the screen at a time, etc. Updating notes over an extended period as a conversation progresses can be useful, and it's easier to click a window to bring it to the front than to find the contact in the list and select it when it's needed.

Similarly, I'll often dig through my offline contacts to find someone and open an info window for them, or quickly click them just as they go offline. It would be handy if I could leave that open to come back to it after conversing with others, rather than needing to find it again every time I click a different contact.

Ben.

comment:7 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [25704])

  • When the contact being shown in the contact inspector changes, dismiss any existing add or edit contact alert sheet. Fixes #10436 *?\194?\160Cleanup and document the public creator for CSNewContactAlertWindowController

comment:8 Changed 11 years ago by Evan Schoenberg

(In [25706]) Merged [25704]:

  • When the contact being shown in the contact inspector changes, dismiss any existing add or edit contact alert sheet. Fixes #10436 *?\194?\160Cleanup and document the public creator for CSNewContactAlertWindowController

comment:9 Changed 11 years ago by Zachary West

Component: Contact InspectorAdium UI

Removing Contact Inspector component.

Note: See TracTickets for help on using tickets.