Adium

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#10420 closed defect (fixed)

Show offline contacts does not work if groups are disabled

Reported by: Alex Owned by: zacw
Milestone: Adium 1.3.1 Component: Adium UI
Version: Severity: regression
Keywords: offline contacts menu item Cc:
Patch Status:

Description

I click on the "Show offline contacts" in the view menu and... My offline contacts don't appear. Then I click "Hide offline contacts" and my offline contacts show for about 1 millisecond then disappear. Hmm...

Attachments (3)

show_offline_contacts.png (55.2 KB) - added by Alex 12 years ago.
Show offline contacts (before)
hide_offline_contacts.png (55.1 KB) - added by Alex 12 years ago.
Hide offline contacts (after)
Adium Log.txt (4.8 KB) - added by Alex 12 years ago.
Adium Log

Download all attachments as: .zip

Change History (30)

comment:1 Changed 12 years ago by Zachary West

Can you screenshot your view menu before and after clicking Show Offline Contacts?

comment:2 Changed 12 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

Changed 12 years ago by Alex

Attachment: show_offline_contacts.png added

Show offline contacts (before)

Changed 12 years ago by Alex

Attachment: hide_offline_contacts.png added

Hide offline contacts (after)

comment:3 Changed 12 years ago by Alex

pending: 10

I chose "Show offline contacts" and nothing happened. Then I restarted Adium then... Poof! They were there. But, when I said "Hide offline contacts:, they went, then I chose "Show offline contacts" again and it didn't work.

comment:4 Changed 12 years ago by Jordan

pending: 01

Does anything show up in the console log from the exact time that you click on "Show offline contacts" and/or "Hide offline contacts" ?

If not, please see CurrentAdiumDebug for how to get a debug log of the event occurring.

comment:5 Changed 12 years ago by Alex

pending: 10

Yes, I attached the log to the file attachments. When you find "FRIENDS IM" in the log, it means that my friends IM's address was there.

Changed 12 years ago by Alex

Attachment: Adium Log.txt added

Adium Log

comment:6 Changed 12 years ago by Sebastian Sebusæter

The same happen in b9 and in Adium 1.2.7

You should be able to reproduce the problem, if you can't then I will attach 2 pictures that show my contact list and the "Hide Offline Contacts" button

oh and btw, I have only tested with msn and facebook chat (at same time)

comment:7 Changed 12 years ago by Sebastian Sebusæter

another update. Users that get on and then go off again don't show up as offline in the contact list

if you log off and on again then everybody that are offline are in the contact list again

comment:8 Changed 12 years ago by Robert

Milestone: Needs feedback from usersAdium X 1.3

comment:9 Changed 11 years ago by Jordan

Milestone: Adium X 1.3Adium X 1.3.1

comment:10 Changed 11 years ago by Sebastian Sebusæter

You can watch offline people (after they logg off or if you click "Show offline messages") IF you have checked for "Show groups"

Short summary "Show offline contacts" only works if you have checked "Show groups"

Maybe that will help you to find what the problem is

comment:11 Changed 11 years ago by Alex

Thank you! That did solve my problem; and you can then click "Hide groups" and the offline contacts still show.

comment:12 Changed 11 years ago by Daniel Bergman

Milestone: Adium X 1.3.1Needs feedback from users
pending: 01

So this ticket can be closed then?

comment:13 Changed 11 years ago by Zachary West

Milestone: Needs feedback from usersAdium X 1.3
Owner: changed from nobody to Zachary West
pending: 10
Status: newassigned

No, this is an actual bug. Workarounds in situations like this (where expected behavior isn't happening) don't count as fixes.

Let's add this to my "please god let me have some free time this week" queue.

comment:14 Changed 11 years ago by Jordan

Keywords: fault removed
Severity: normalregression
Summary: Show offline contacts not working properlyShow offline contacts does not work if groups are disabled

comment:15 Changed 11 years ago by Zachary West

Is anyone able to reproduce this?

comment:16 Changed 11 years ago by Sebastian Sebusæter

Someone else than me? If you mean anyone then yeah If groups are on, turn that off. Then choice "Hide offline contacts" and then "Show offline contacts" and voila, they don't show up (I just did this, just to make sure :))

comment:17 Changed 11 years ago by Zachary West

What service are the contacts on? I can't cause it to happen doing that.

comment:18 Changed 11 years ago by Sebastian Sebusæter

Msn and facebook... but I guess facebook are not supposed to be there anyway so I have only tested with MSN :)

comment:19 Changed 11 years ago by Zachary West

This appears to be a more extensive bug than just as this ticket indicates. CFM reported idle contacts behaving the same way. Something isn't updating visibility correctly.

comment:20 Changed 11 years ago by Sebastian Sebusæter

I'm not sure what you mean, but my Idle contacts show just fine

comment:21 Changed 11 years ago by Jordan

Using 1.3b12 here is what I have found (with both MSN contacts and Gtalk contacts). Groups are disabled for all these tests.

Show All Contacts menu option chosen (such that it now shows "Hide Certain Contacts" in the view menu):

  1. All my online AND offline contacts appear in the list.
  2. Hide Certain Contacts and Show Offline Contacts specified - all my contacts except blocked ones are showing.
  3. Hiding idle contacts also works fine.

Therefore I cannot reproduce this issue.

comment:22 Changed 11 years ago by Zachary West

I'll put some debug logging into a test build tonight and throw it in this ticket. Let's see if it's something weird or not. It might just not be updating all visibility on changes, or something strange like that, under certain conditions.

comment:23 Changed 11 years ago by Sebastian Sebusæter

If I understud you right jas, then you had on groups then disabled that right? But you didn't click "hide offline contacts" and then "show offline contacts"? Offline contacts show if you either log on, or choice "show groups", but if "show groups" are not on then ppl that go offline will not show up

hm, I think I missed something, but can't remamber that right now

comment:24 Changed 11 years ago by Robert

Milestone: Adium X 1.3Adium X 1.3.1

Pushing.

comment:25 Changed 11 years ago by Robert

priority: normalhigh

comment:26 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [25102]) Fixed and cleaned up a little bit handling of visibility preference changes as they relate to offline contacts and the offline contact group. Man, this code is ridiculous. Fixes #10420

comment:27 Changed 11 years ago by Evan Schoenberg

(In [25103]) Merged [25102]: Fixed and cleaned up a little bit handling of visibility preference changes as they relate to offline contacts and the offline contact group. Man, this code is ridiculous. Fixes #10420

Note: See TracTickets for help on using tickets.