Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#10350 closed defect (fixed)

Delay sending message (as long as 10 minutes)

Reported by: Michael Kruck Owned by: evands
Milestone: Adium 1.3 Component: Service/ICQ
Version: Severity: regression
Keywords: message delay since icq6 Cc:
Patch Status:

Description (last modified by Evan Schoenberg)

Hello,

since the last update to Adium version 1.2.6 I have a big message delay to all other instant messanger clients e.g. Miranda, ICQ6, Trillian.

I'm using Mac OS X 10.5.4 on a MacBook Pro. Many thanks in advance.

Kindest regards Michael

Attachments (10)

2008-07-06.log (26.4 KB) - added by Stussi 12 years ago.
2008-07-04.log (94.3 KB) - added by Michael Kruck 12 years ago.
2008-07-19 2.log (261.0 KB) - added by Michael Kruck 12 years ago.
2008-07-20.log (77.4 KB) - added by Stussi 12 years ago.
2008-07-20.2.log (500.2 KB) - added by Michael Kruck 12 years ago.
2008-07-20 2.log (531.1 KB) - added by Michael Kruck 12 years ago.
2008-07-20 1.log (335.0 KB) - added by Stussi 12 years ago.
2008-07-20.3.log (464.3 KB) - added by Michael Kruck 12 years ago.
2008-07-21.log (212.6 KB) - added by Stussi 12 years ago.
2008-07-21 1.log (107.2 KB) - added by Stussi 12 years ago.

Change History (53)

comment:1 Changed 12 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

We need a debug log: see CurrentAdiumDebug. It would be best to get the latest 1.3 AdiumBeta and retrieve it with that.

comment:2 Changed 12 years ago by Michael Kruck

pending: 10

comment:3 in reply to:  2 Changed 12 years ago by Michael Kruck

furthermore i noticed that approximately after 20 minutes of running adium the queue goes downwards again, and everything works!!!

comment:4 Changed 12 years ago by Stussi

Hello,

i've got the same Problem but it occured first in 1.2.5.

Messages will arrive aprox. 5-10 minutes later....

1.2.3 worked just fine, 1.2.4 reconnected itself often....

Now in 1.2.6 (right now i test 1.2.7) the delay problem is there again.... this realls sucks :-/

Hope you'll find the error!

Thanks in advance!

comment:5 Changed 12 years ago by Jordan

pending: 01

Please attach the debug log - do not paste it in the window. Otherwise it is unreadable!

Changed 12 years ago by Stussi

Attachment: 2008-07-06.log added

Changed 12 years ago by Michael Kruck

Attachment: 2008-07-04.log added

comment:6 Changed 12 years ago by Robert

Milestone: Needs feedback from usersAdium X 1.3

comment:7 Changed 12 years ago by Jordan

Milestone: Adium X 1.3Needs feedback from users

Is this still a problem with 1.3b7 AdiumBeta? I would have expected to have seen more reports of this...

comment:8 Changed 12 years ago by Michael Kruck

pending: 10

yes, this is still a problem! in the forum there is another user who noticed it...

comment:9 Changed 12 years ago by Jordan

Component: Adium CoreICQ
Milestone: Needs feedback from usersAdium X 1.3
Summary: big message delay since icq v6 (adium 1.2.6)Delay sending message (as long as 10 minutes)
Version: 1.2.61.3b7

comment:10 Changed 12 years ago by Evan Schoenberg

This is caused by the ICQ Status Note support in libpurple

comment:11 Changed 12 years ago by Evan Schoenberg

(In [24405]) libpurple.framework which hopefully fixes the long ICQ delay for people with lengthy ICQ buddy lists. If it works, I'll commit it upstream. Refs #10350

comment:12 Changed 12 years ago by Evan Schoenberg

Please wait at least 10 minutes after experiencing this bug to completion (with messages no longer having a delay). Then try Adium_1.3b720080717 and let us know here if it fixes the problem.

comment:13 in reply to:  12 Changed 12 years ago by Michael Kruck

The Problem still exists in Adium_1.3b720080717 :(

comment:14 Changed 12 years ago by Evan Schoenberg

Please post the complete debug log of connecting just your ICQ account. and finding the delay to be present using Adium_1.3b720080717

Changed 12 years ago by Michael Kruck

Attachment: 2008-07-19 2.log added

comment:15 Changed 12 years ago by Evan Schoenberg

(In [24430]) Another attempted fix for handling the ICQ status notes request flood. Refs #10350

comment:16 Changed 12 years ago by Stussi

My attachment is 1.3b7 too....

The Problem still exists in 1.3b7!

comment:17 Changed 12 years ago by Evan Schoenberg

Please try Adium_1.3b720080719 and post the debug log.

comment:18 Changed 12 years ago by Jordan

Owner: changed from nobody to Evan Schoenberg
priority: normalhigh
Severity: normalregression

Changed 12 years ago by Stussi

Attachment: 2008-07-20.log added

comment:19 Changed 12 years ago by Stussi

Attached a log with the Adium Version you posted....

Changed 12 years ago by Michael Kruck

Attachment: 2008-07-20.2.log added

comment:20 Changed 12 years ago by Michael Kruck

me too, still the same problem

comment:21 Changed 12 years ago by Stussi

Just to let you know: some friends tell me that "i" am reading their Away Messages over and over again.. i think that was with 1.2.5 too. Maybe there is the error...

comment:22 Changed 12 years ago by Evan Schoenberg

Well, yes, that's the source of the problem - but the solution is to fix the rate limiting, not stop reading away messages, I think.

comment:23 Changed 12 years ago by Evan Schoenberg

(In [24438]) Iterating on trying to fix ICQ rate limiting problems. Refs #10350

comment:24 Changed 12 years ago by Michael Kruck

doesn't help :(

comment:25 in reply to:  24 Changed 12 years ago by Evan Schoenberg

Replying to Michael Kruck:

doesn't help :(

Are you building from source?

comment:26 Changed 12 years ago by Evan Schoenberg

Description: modified (diff)

Note: I removed the parts of this ticket involving offline messages and file transfers from the description. Please make new tickets for separate issues.

comment:27 Changed 12 years ago by Evan Schoenberg

Please wait 10 minutes to let your account completely clear, then try Adium_1.3b720080720, posting the entire debug log from initial connection to message sending attempt. I don't believe anyone has posted a complete log so far - hold shift while Adium loads to prevent your account from automatically connecting, then open the debug window before connecting.

Changed 12 years ago by Michael Kruck

Attachment: 2008-07-20 2.log added

comment:28 Changed 12 years ago by Michael Kruck

so here is a complete log now (holding shift on start up)

comment:29 Changed 12 years ago by Evan Schoenberg

Thanks, Michael. I can see that we're making improvement - your messages started off sending immediately and then ended up with a brief delay, rather than the 10 minutes or so you were seeing previously. Does that understanding of the logs match your experience using 1.3b720080720?

comment:30 Changed 12 years ago by Michael Kruck

yes, as soon as the queued for the low-priority snacs are 0 the message arrives immediately... before the delay is aprox. 5 minutes at peak.

comment:31 Changed 12 years ago by Evan Schoenberg

Messages are sent at high priority; it should be a second or two at most when you send a message so long as there aren't high priority snacs waiting. Are you sure that it's not until the low priority ones reach 0 that you're seeing good message send times?

comment:32 Changed 12 years ago by Evan Schoenberg

(In [24440]) Improved debug logging for SNAC queueing, and made buddy icon requests group into the low priority queue. Refs #10350

comment:33 in reply to:  27 Changed 12 years ago by Evan Schoenberg

Same story, but now with Adium_1.3b720080720-2. Entire debug log again please :)

Changed 12 years ago by Stussi

Attachment: 2008-07-20 1.log added

comment:34 Changed 12 years ago by Stussi

It seems to be better.... sometimes the error occurs after a sudden reconnect (don't know why...)

comment:35 Changed 12 years ago by Evan Schoenberg

(In [24441]) Once more toward good ICQ rate control. 'bout ready to just cardiovert the sucker the old fashioned way... Refs #10350

comment:36 Changed 12 years ago by Evan Schoenberg

Changed 12 years ago by Michael Kruck

Attachment: 2008-07-20.3.log added

comment:37 Changed 12 years ago by Michael Kruck

and here is the next logfile :)

comment:38 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [24443]) Make ICQ alias requests low priority to avoid interfering with messaging, and clean up debug logging. Fixes #10350 if I'm not mistaken :)

Changed 12 years ago by Stussi

Attachment: 2008-07-21.log added

comment:39 Changed 12 years ago by Stussi

The number of the queued SNACs still grows... now: 01:01:10: (Libpurple: oscar) Attempting to send 31 queued SNACs and 14 queued low-priority SNACs for 0x195bf680

I think the delay is still there... (i used the last version you posted)

comment:40 in reply to:  36 Changed 12 years ago by Evan Schoenberg

I believe this should fix the issue. Please try Adium_1.3b72008720-4 and let us know :)

Changed 12 years ago by Stussi

Attachment: 2008-07-21 1.log added

comment:41 Changed 12 years ago by Stussi

Yes, seems to work :) Thank you! :)

comment:42 Changed 12 years ago by Michael Kruck

yes it works! would it be implemented now in a non-beta version?

comment:43 in reply to:  42 Changed 12 years ago by Jordan

Replying to Michael Kruck:

yes it works! would it be implemented now in a non-beta version?

Of course... when 1.3 is released.

Note: See TracTickets for help on using tickets.