Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#10347 closed defect (fixed)

1.2.6 and 1.2.7b1 - Can no longer receive XMPP messages.

Reported by: heidelj Owned by: nobody
Milestone: Adium 1.2.7 Component: Adium Core
Version: Severity: normal
Keywords: Cc: 1.2.6
Patch Status:

Description

I can no longer receive XMPP messages from our internal Spark server. I can receive AIM messages and I can send messages internally on Jabber (spark server) but I cannot receive messages.

Attachments (2)

down.log (1.0 KB) - added by Pete Toscano 12 years ago.
Log of my Jabber server getting disconnected.
nochat.log (3.2 KB) - added by Pete Toscano 12 years ago.
Log of 'receiving' two non-displayed messages and sending one.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by heidelj

This is odd. I'm now receiving messages internally again using 1.2.7b1. This hadn't worked until now. I have no further explanation.

comment:2 Changed 12 years ago by Pete Toscano

I'm seeing the same problem with 1.2.6 and 1.2.7b1. Plus, I'm still seeing my Jabber connection flap about every three minutes or so. Attached is a log of the connection going down. I also have a log of a cow-orker sending me two test messages and me sending him one. I saw neither his messages nor typing notification, but he saw mine.

One final note. This is probably just a coincidence, but it seems like it might help narrow down the problem... I have two other people in my office. One's using Adium 1.2.7b1 and OS X 10.5.3 and the other's using the latest Pidgin on Linux. While they were away at lunch, my connection stayed up no problem for an hour. Almost as soon as they came back, the flapping returned. I cannot receive IMs or join conference rooms, although my cow-orkers see me in them, I don't. My Adium-1.2.7b1-using cow-orker that returned from lunch is staying up no problem.

Changed 12 years ago by Pete Toscano

Attachment: down.log added

Log of my Jabber server getting disconnected.

Changed 12 years ago by Pete Toscano

Attachment: nochat.log added

Log of 'receiving' two non-displayed messages and sending one.

comment:3 in reply to:  2 Changed 12 years ago by Brian

We're seeing the same problems in our office of connections to the Jabber server dropping, inability to join Chat rooms, and lost messages to and from people using Adium 1.2.6 and 1.2.7 beta. Another user has reported the problem using 1.2.5, and another reports no problems when using 1.1.4.

For our part we've been unable to determine what causes Adium clients' connections to drop or the lost messages to and from Adium users. Users moving to other Jabber clients (Spark, Coccinella, Psi) don't experience these connection problems.

comment:4 Changed 12 years ago by Evan Schoenberg

One issue per ticket, please. This ticket is about not receiving XMPP messages. Please create a new ticket for disconnection issues, with a full debug log of this occurring.

re: nochat.log: Are you getting the typing notifications which are shown in the log? What are your privacy settings? What is your authorization status with this contact? Does the contact receive your messages? Does this happen every time or just sometimes?

comment:5 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.7

comment:6 in reply to:  4 Changed 12 years ago by Pete Toscano

Replying to evands:

re: nochat.log: Are you getting the typing notifications which are shown in the log?

No. I get no indication that the sender is trying to send me anything. I used to back on 1.2.5. He's using Pidgin 2.3.1 on Linux (CentOS 5).

What are your privacy settings?

Please excuse my ignorance here, but I'm not sure what you're looking for. Are you looking for something in the Preferences panel? Normally, we can send back and forth with typing notifications working both ways.

What is your authorization status with this contact?

Full? We've both authorized each other.

Does the contact receive your messages?

Yes. He received mine just fine. I see his messages in the log, but they never got displayed in my chat window. He got mine (and the typing notification) no problems.

Does this happen every time or just sometimes?

All the time.

Thanks.

comment:7 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [24247]) libpurple.framework im.pidgin.pidgin 2.5.0mtn @ 2b2d7fb52, which should fix problems with XMPP XML parser error handling. Investigation and fix a combined effort of dhawes, catfish_man42, and myself.

Fixes #10347. Fixes #10353. Refs #10324.

May fix other issues, as well, or at least make them more debuggable, as there was no error handling previously.

comment:8 Changed 12 years ago by Evan Schoenberg

(In [24249]) libpurple.framework im.pidgin.pidgin.2.4.3, with all patches on adium-1.2 as of [24245], which should fix problems with XMPP XML parser error handling. Investigation and fix a combined effort of dhawes, catfish_man42, and myself.

Fixes #10347. Fixes #10353. Refs #10324.

May fix other issues, as well, or at least make them more debuggable, as there was no error handling previously.

Note: See TracTickets for help on using tickets.