Adium

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#10291 closed crash (fixed)

Facebook crash [SBJSON objectWithString:error:]

Reported by: kb1ibt Owned by: evands
Milestone: Component: Service/Facebook
Version: 1.3b5 Severity: normal
Keywords: Cc:
Patch Status:

Description (last modified by jas8522)

Facebook module crashing intermittantly.

Abridged:

Process:         Adium [715]
Path:            /Applications/Adium.app/Contents/MacOS/Adium
Identifier:      com.adiumX.adiumX
Version:         1.3b5 (1.3b5)
Code Type:       X86 (Native)
Parent Process:  launchd [145]

Date/Time:       2008-06-30 21:16:34.185 -0400
OS Version:      Mac OS X 10.5.4 (9E17)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000066000000
Crashed Thread:  0

Thread 0 Crashed:
0   libobjc.A.dylib               	0x9365e6ec objc_msgSend + 28
1   org.brautaset.JSON            	0x012132d4 -[SBJSON objectWithString:error:] + 56
2   org.brautaset.JSON            	0x01212470 -[NSString(NSString_SBJSON) JSONValueWithOptions:] + 160
3   org.brautaset.JSON            	0x01212504 -[NSString(NSString_SBJSON) JSONValue] + 42
4   com.adiumX.facebook           	0x01204eb5 -[AIFacebookBuddyListManager connectionDidFinishLoading:] + 195
5   com.apple.Foundation          	0x958f73f7 -[NSURLConnection(NSURLConnectionReallyInternal) sendDidFinishLoading] + 87
6   com.apple.Foundation          	0x958f7363 _NSURLConnectionDidFinishLoading + 147
7   com.apple.CFNetwork           	0x9634ecef sendDidFinishLoadingCallback + 148
8   com.apple.CFNetwork           	0x9634bdd6 _CFURLConnectionSendCallbacks + 2022
9   com.apple.CFNetwork           	0x9634b573 muxerSourcePerform + 283
10  com.apple.CoreFoundation      	0x937f8615 CFRunLoopRunSpecific + 3141
11  com.apple.CoreFoundation      	0x937f8cf8 CFRunLoopRunInMode + 88
12  com.apple.HIToolbox           	0x92db2da4 RunCurrentEventLoopInMode + 283
13  com.apple.HIToolbox           	0x92db2bbd ReceiveNextEventCommon + 374
14  com.apple.HIToolbox           	0x92db2a31 BlockUntilNextEventMatchingListInMode + 106
15  com.apple.AppKit              	0x9413c505 _DPSNextEvent + 657
16  com.apple.AppKit              	0x9413bdb8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
17  com.apple.AppKit              	0x94134df3 -[NSApplication run] + 795
18  com.apple.AppKit              	0x94102030 NSApplicationMain + 574
19  com.adiumX.adiumX             	0x00002b42 _start + 216
20  com.adiumX.adiumX             	0x00002a69 start + 41

Attachments (3)

crash.log (33.8 KB) - added by jas8522 6 years ago.
Original crashlog that was pasted in the comment box
frett-crash.log (37.0 KB) - added by frett 6 years ago.
2008-07-08 1.log (30.6 KB) - added by frett 6 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 years ago by jas8522

  • Description modified (diff)
  • Milestone set to Adium X 1.3.1
  • Owner set to evands
  • priority changed from normal to highest
  • Type changed from defect to crash

Temporary milestone, not setting to 1.3 as this is the first report we've had of this - making it appear to be less of a priority (ie: not required to be in 1.3)

Changed 6 years ago by jas8522

Original crashlog that was pasted in the comment box

comment:2 Changed 6 years ago by evands

Please show debug logging as per current Adium debug's instructions (but using 1.3b5) leading up to the crash. You'll need to be logging to file to be sure the logging exists.

comment:3 Changed 6 years ago by dave_atx

Happened to me several times this morning as well. I've got debug logging turned on now and will attach those logs if I can repro.

Seems like something funny was going on with facebook this morning. Now when I try to log in through the web I get a message saying, "Your account is temporarily unavailable due to site maintenance. It should be available again within a few hours. We apologize for the inconvenience." Log in through adium fails (without a crash) as well.

I'd guess that earlier this morning things were in a bad state but I was still being able to be logged in.

comment:4 Changed 6 years ago by fusionfox

Several times this happened to me yesterday and today running 1.3b6. I didn't know if it was connected to adding my Facebook account or not but I'm running now without adding my Facebook and it hasn't crashed in about half an hour; the likelihood of this ticket being correct seems to be increasing.

But it was getting pretty ridiculous, I think it crashed 3 times within 20 minutes when I was trying to use it last night.

comment:5 Changed 6 years ago by evands

There's no question of it being correct, nor of it being related to Facebook connectivity. We need debug logging, as mentioned above, to investigate it, though.

comment:6 Changed 6 years ago by frett

I've been able to reproduce this error by leaving adium running for a while, then logging into facebook in a web browser which will cause adium to reconnect to facebook and crash, attached in the last part of the debug log and the crash report. I connected to facebook around 17:58:37. I can probably produce a full debug log of the entire adium session if it's necessary.

Changed 6 years ago by frett

Changed 6 years ago by frett

comment:7 Changed 6 years ago by dogtown08

Hello again!
I have what I think is the same crashing bug in my shiny new (shipping) iPhone app and I just happened to come across this :)

The only difference is that my crash occurs in -objectWithString:allowScalar:errror:
The crashing method in this bug (assuming we are using the same SBJSON build) is just a one liner that calls -objectWithString:allowScalar:errror: and unless self (the SBJSON object) is somehow becoming invalid, I think the stack must just be missing the other method.

If so, you can fix it by changing line 310 from:
id o;
to:
id o = nil;

It is just that the o pointer is not being initialized in the other methods due to some error (in my case, an invalid JSON string was being returned), so o randomly points to an invalid memory address.

I HATE those bugs. I'll report it to the framework project too, later.

comment:8 Changed 6 years ago by frett

I put the fix dogtown suggested and it appears to have fixed the problem. I wasn't able to get it to crash the couple times I tried.

comment:9 Changed 6 years ago by evands

Thanks for the hunt and fix. I made the fix a bit more robust, correcting the returns of the various methods used by objectWithString:allowScalar:error:, and submitted the bug report and patch in json-framework issue #8.

comment:10 Changed 6 years ago by evands

  • Resolution set to fixed
  • Status changed from new to closed

(In [24289]) Fixed return-by-reference when an error occurs to return nil. Fixes #10291

comment:11 Changed 6 years ago by Robby

  • Milestone changed from Adium X 1.3.1 to SVN issues

comment:12 Changed 6 years ago by evands

If you have the actual JSON string which causes this crash, could you please note it in json-framework issue #8? (by request of the developer)

comment:13 Changed 5 years ago by anonymous

  • Milestone SVN issues deleted

Milestone SVN issues deleted

Note: See TracTickets for help on using tickets.