Adium

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#10255 closed defect (fixed)

Sorting contacts very difficult

Reported by: Robby Owned by:
Milestone: Component: Adium UI
Version: Severity: major
Keywords: Cc:
Patch Status:

Description

[24101]
It seems sorting contacts is saved nicely now but a problem I have been seeing for quite a while now (probably ever since editing of combined contacts in the contact list was implemented) is that it's quite impossible to sort a contact below a combined contact.

While holding on to a contact and hovering over the list the bar does appear. But nevertheless when I let go Adium asks whether I want to combine.

Could this be related to #10254?

Attachments (1)

Configure Status Sort.png (54.7 KB) - added by Robert 12 years ago.

Download all attachments as: .zip

Change History (30)

comment:1 Changed 12 years ago by Robert

Summary: Sorting contacts very difficult, Adium wants to combine contacts all the timeSorting contacts very difficult

comment:2 Changed 12 years ago by Jordan

I think this is the same problem as #10257 ... albeit a different incarnation of it (we just need to abstract the understanding of it slightly). Here's why:

What is actually happening here for me is best described as steps to reproduce:

  1. Drag a contact directly below a metacontact that is expanded (if it's collapsed, there is no problem - it works as expected)
  2. Notice the drop bar indicator appears (seemingly) where it should - between the last subcontact of the metacontact and the next contact in the list.
  3. When you actually drop the contact, it behaves like you're just dropping it in the group, and not specifying position, which is why it does not sort properly.

In #10257 dropping a contact to the last position in a group drops it in the first group in the list. Think of the metacontact as the group, and the parent group (that the metacontact belongs in) as the entire contact list, then we're reproducing the same thing as #10257 describes - attempting to drop a contact into the last position of a group (in this case a metacontact), and it's actually getting placed in the first group of the list (in this case, the parent group).

Hopefully that makes sense to someone other than me... :P

comment:3 Changed 12 years ago by Jordan

After updating to [24109] which includes the fix for #10257, I no longer have any problems with this (ie: I cannot reproduce the problem in this ticket) as long as my list is configured for manual sort.

Fixed for you Robby?

comment:4 Changed 12 years ago by Robert

No, not in the slightest. :(

comment:5 in reply to:  2 Changed 12 years ago by Robert

Replying to jas8522:

  1. Drag a contact directly below a metacontact that is expanded (if it's collapsed, there is no problem - it works as expected)
  2. Notice the drop bar indicator appears (seemingly) where it should - between the last subcontact of the metacontact and the next contact in the list.
  1. When you actually drop the contact, it behaves like you're just dropping it in the combined contact.

That's my issue!

This happens no matter whether I wait for the combined contact to expand while I hover or I manage to drop it before it does so.

comment:6 Changed 12 years ago by Jordan

Perhaps you should do a video screen capture to show this in action... I can't get this to happen no matter what I do...

comment:7 Changed 12 years ago by Evan Schoenberg

Robby, have you really updated to [24109] or later? I could reproduce this readily before fixing #10257. I can not reproduce it now.

comment:8 Changed 12 years ago by Evan Schoenberg

Resolution: worksforme
Status: newclosed

Please reopen if you can reproduce this with a current build.

comment:9 Changed 12 years ago by Robert

Resolution: worksforme
Status: closedreopened

Yes, that was [24110]. Can't update to latest because of the broken Tiger build just now.
Would a video be helpful to you, Evan?

comment:10 Changed 12 years ago by Evan Schoenberg

(Is there a ticket for the build problem?) A video would definitely be helpful. :)

comment:11 Changed 12 years ago by Robert

(The build problem has been thematised in the mailing list.;))
Ok, I'll try to get a video done.

comment:12 Changed 12 years ago by Robert

You can download it here: http://www.mediafire.com/?bmt5mylyxly. :)

comment:13 Changed 12 years ago by Jordan

I just attempted to reproduce this in my 10.4.11 install and I could not... Robbie: wanna try fresh prefs again? I know how much you enjoy doing that :)

comment:14 Changed 12 years ago by Jordan

Oh, in case you haven't done so already, try removing the build directory, then rebuilding Adium... perhaps before the fresh prefs.

comment:15 Changed 12 years ago by Robert

I'm not going to do the fresh prefs, I doubt that will help. I'll try removing the build directory.

comment:16 Changed 12 years ago by Robert

Ok, did that, no change.

comment:17 Changed 12 years ago by Robert

Which preferences files could account for this problem? I certainly don't want set up Adium from scratch.

comment:18 Changed 12 years ago by Robert

Ok, I did do start on a fresh set of preferences after all, to no avail.

comment:19 Changed 12 years ago by Robert

priority: normalhighest
Severity: normalblocker

comment:20 Changed 12 years ago by Evan Schoenberg

What are your sorting settings?

comment:21 Changed 12 years ago by Robert

"Sort contacts by status". More details in the following screenshot.
When I sort my contacts, though, I unhide all contacts and set contact sorting to "manually".

Changed 12 years ago by Robert

Attachment: Configure Status Sort.png added

comment:22 Changed 12 years ago by Evan Schoenberg

Does this problem exist in 1.2.7?

comment:23 Changed 12 years ago by Robert

Before I check, let me ask: How could it when in 1.2.7 meta-contacts are not expanded in the contact list?

comment:24 Changed 12 years ago by Evan Schoenberg

Drag & drop to combine contacts has always existed, and drag & drop to reorder has, as well. Also, it isn't clear to me from this ticket that this only happens for you when dragging to a location below a metacontact... is that the case? Dragging works okay if you drop below a non-metacontact?

comment:25 in reply to:  24 Changed 12 years ago by Robert

Replying to evands:

Drag & drop to combine contacts has always existed, and drag & drop to reorder has, as well.

I know that, of course. :)

Also, it isn't clear to me from this ticket that this only happens for you when dragging to a location below a metacontact... is that the case? Dragging works okay if you drop below a non-metacontact?

Yes, that is exactly what I mean. I thought I had mentioned that in the original description but perhaps I could have stressed that a little more.

comment:26 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [24425]) A drop just below a metacontact will appear to be in the group (and should be). In 10.4, however, this incorrectly targets the bottommost index of the metacontact. Adjust to fit reality accordingly. Fixes #10255, finally.

comment:27 Changed 12 years ago by Robert

Milestone: Adium X 1.3SVN issues

Confirmed, thanks a lot, Evan! Great work! :)

comment:28 Changed 11 years ago by (none)

Milestone: SVN issues

Milestone SVN issues deleted

comment:29 Changed 11 years ago by Zachary West

Component: MetaContactAdium UI

Removing 'Meta Contact' component.

Note: See TracTickets for help on using tickets.