Adium

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#10254 closed defect (fixed)

Dragging a contact over a metacontact expands it automatically but it never collapses

Reported by: jas8522 Owned by:
Milestone: Adium 1.3 Component: Adium UI
Version: Severity: minor
Keywords: Cc:
Patch Status:

Description (last modified by Jordan)

Steps to reproduce:

  1. Click and hold on a contact in order to manually move it elsewhere
  2. Drag it over a metacontact and (while still holding down the mouse button) leave it hovered for a couple seconds
  3. The metacontact directly underneath your cursor will expand automatically (good behaviour)
  4. Continue dragging away from the metacontact that is below your cursor so you are no longer hovering over it
  5. The metacontact continues to behave like a group, and does not automatically collapse after passing over it (having decided not to drop the contact you're dragging on the metacontact)
  6. Drop the contact you're dragging wherever you'd like
  7. The previously collapsed metacontact that we dragged over top of in step 3 will remain expanded, and not automatically collapse.

I believe one of two things should occur here:

  1. Once you drop the contact, the metacontacts you hovered over should collapse (but I think the next solution is much better and can be made consistent)
  2. Once you no longer remain hovered over top of a metacontact or any of it's subcontacts for 1 second (or so?) it should automatically collapse.

I also believe that groups should behave in exactly the same manner as my second solution, such that if you are relocating a contact to a new group, you shouldn't be able to expand every single group in the list (and have all of them remain expanded following the drag and drop action) if you only wanted to get to the last group.

Interestingly when dragging and dropping emails in mail folders, if you hover over a collapsed folder, all the folders that you hover over will remain expanded until you drop the email in any folder (ie: there is no auto collapsing until the drop is completed). While this functionality (my first suggestion above) would maintain this consistency, I also believe that in cases where users have many contacts in each group, having them all remain open would fill up much (if not all) of the screen very quickly. Additionally, I don't see why it's necessary to have them remain open like Mail does because if you no longer are hovering over them, you obviously don't need to see their contents.

Setting this to 1.3, not because it's a regression (since the problem has been there with groups for a while), but because it is much more noticeable and annoying now that we have expanding metacontacts. Feel free to bump this to a later release.

Change History (6)

comment:1 Changed 12 years ago by Jordan

Description: modified (diff)

comment:2 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [24127]) Automatically collapse items expanded within the contact list during a drag&drop operation when the operation is completed. Fixes #10254

comment:3 Changed 12 years ago by Robert

Milestone: Adium X 1.3SVN issues

comment:4 Changed 12 years ago by Jordan

Milestone: SVN issuesAdium X 1.3

Actually this is new to 1.3 for groups, and extends to metacontacts now that they're in-list.

comment:5 Changed 12 years ago by Robert

Spot on. :)

comment:6 Changed 11 years ago by Zachary West

Component: MetaContactAdium UI

Removing 'Meta Contact' component.

Note: See TracTickets for help on using tickets.