Adium

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#10204 closed defect (fixed)

Edges between differently sized horizontally placed displays trigger showing a hidden contact list

Reported by: modern Owned by: nobody
Milestone: Adium 1.3.1 Component: Adium UI
Version: Severity: regression
Keywords: hide on screen edge multiple monitors Cc:
Patch Status:

Description

I have two screens, main on the right second on the left and they are not exactly the same size so the second is lower than the right and moving my cursor to the top left of the main screen will hit a wall rather than go onto the second screen.

I keep adium hidden off to the left of my second screen so it slides in when my mouse touches that side.

However if my mouse touches the wall between the screens as shown in the diagram then Adium will become very confused and start rapidly sliding itself on and off the screen.

Attachments (1)

adiumdiagram.gif (1.2 KB) - added by modern 12 years ago.
screen layout and cursor position that causes problem

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by modern

Attachment: adiumdiagram.gif added

screen layout and cursor position that causes problem

comment:1 Changed 12 years ago by Jordan

Milestone: Adium X 1.3.1
priority: normallow
Severity: normalregression
Summary: Multiple Screens and hide on screen edgesEdges between differently sized horizontally placed displays trigger showing a hidden contact list

Confirmed. I believe there was another ticket about this, and I asked someone to do a diagram exactly like that to help demonstrate, but I cannot find it now. Either way this is exactly what is needed. :)

This is a regression from our previous horizontally placed displays code (I think) and was likely caused by the changes for vertically stacked display support. I see no reason to block 1.3 on this; hence the 1.3.1 milestone (good place as it *is* a regression).

comment:2 Changed 12 years ago by Reed Kennedy

Note that this bug is especially troublesome when using Teleport: http://teleport.abyssoft.com/

I have two screens to the left of my main screen, which are stacked vertically. If I move my cursor off the lower half of the left side of my main screen, it moves to my secondary screen. If I move my cursor off the upper half of the left side of my main screen, it is captured by Teleport and moved to my other computer via VNC.

When my cursor is "moved off the screen" by Teleport, I believe it actually remains at the screen border. In combination with this bug, it causes Adium to persistently show and hide the contacts list until the cursor is returned to my main screen.

In previous versions, the contacts list would move to the left edge of my main (right) screen after about 10 seconds of showing and hiding, but I can no longer reproduce this behavior in 1.3b5.

comment:3 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [24988]) Only look at the edges of the screen the window slid off of when determining if the contact list should slide back onto the screen. I think this is right, but I can't test it on a multiscreen setup right now. Fixes #10204, I believe, as well as the ticket like it which I can't (and jas8522 couldn't) find

comment:4 Changed 11 years ago by Evan Schoenberg

(In [24989]) Merged [24988]: Only look at the edges of the screen the window slid off of when determining if the contact list should slide back onto the screen. I think this is right, but I can't test it on a multiscreen setup right now. Fixes #10204, I believe, as well as the ticket like it which I can't (and jas8522 couldn't) find

comment:5 Changed 11 years ago by Evan Schoenberg

Please try Adium_1.3.1svn20080826 and let us know if it fixes this issue for you.

comment:6 Changed 11 years ago by Jordan

I can't reproduce it anymore with [24999] :)

Note: See TracTickets for help on using tickets.