Adium

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#102 closed enhancement (fixed)

Highlighting color of contact in Contact List is not customizable

Reported by: ChrisSnell Owned by: boredzo
Milestone: Adium X 1.0 Component: Adium UI
Version: Severity: normal
Keywords: highlight highlighting contact color colour theme Cc:
Patch Status:

Description

The color of a contact in the Contact List, when selected, is drawn from the system's settings (System Preferences -> Appearance -> Highlighting color). Because of this, color themes may clash with the current highlighting color.

I think that highlighting color would be a great inclusion in the color theme customization preferences.

Change History (13)

comment:1 Changed 15 years ago by Peter Hosey

Keywords: colour added

colour for teh win!

and I second this ticket, btw :)

comment:2 Changed 15 years ago by Synapse-

Correct me if I'm wrong, but, isn't the highlight *colour* based upon the system highlight colour? I'm not saying don't change it, but first step is to understand the existing system, at least that's what my SDD teacher would say.

comment:3 Changed 15 years ago by ChrisSnell

Yes, the highlight color (or colour, for those across the pond) is based on the system's setting. The problem is, one may wish to use a theme which does not mesh well with the system highlight color. Imagine if you had a theme consisting of shades of red and you wanted to use yellow as the highlight color. It may look great within Adium but yellow as a system highlighting color may not be a good choice.

comment:4 Changed 15 years ago by Chris Forsythe

Milestone: Adium X 0.90
priority: normallowest
Severity: normalenhancement

comment:5 Changed 15 years ago by David Smith

Component: Core AdiumAdium UI
Milestone: Adium X 0.90 (Old)Adium X 0.90

comment:6 Changed 14 years ago by Chris Forsythe

field_haspatch: 0
Milestone: Adium X 1.0Sometime after 1.0

comment:7 Changed 14 years ago by Chris Forsythe

Owner: changed from anybody to Peter Hosey

comment:8 Changed 14 years ago by Peter Hosey

(In [14382]) Basis for user-settable highlight colour in contact list.

comment:9 Changed 14 years ago by Peter Hosey

Status: newassigned

comment:10 Changed 14 years ago by Peter Hosey

(In [14395]) Rubbing #102's basic code more shiny. Refs #102.

comment:11 Changed 14 years ago by Peter Hosey

(In [14398]) UI for the ability to change the highlight colour in the contact list. Refs #102. (Doesn't fix it yet, because I just noticed that it doesn't work yet in Borderless and Regular Window. Oops.)

comment:12 Changed 14 years ago by Peter Hosey

Resolution: fixed
Status: assignedclosed

(In [14400]) We now use the custom highlight colour in the 'Contact Bubbles' (and to-fit by inheritance) group cell, and in the 'Mockie'/'Group Bubbles' group cell. Also, I figured out what was drawing the highlight in 'Regular Window' and 'Borderless Window' (the outline view itself), and fixed that too. Fixes #102.

comment:13 Changed 14 years ago by Peter Hosey

Milestone: Sometime after 1.0Adium X 1.0
Note: See TracTickets for help on using tickets.