Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#10181 closed crash (fixed)

Crash in oscar_send_im when disconnecting if an action is set to send a message when a user is no longer seen

Reported by: jsailor Owned by: nobody
Milestone: Adium 1.3 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Adium has crashed a number of times in the last few days when I've not been looking at my computer. In every case, the crash is in oscar_send_im, called indirectly as a result of a hostReachabilityChangedCallback.

I don't think I have any events with actions to send an IM, though my AIM account is usually away.

I've got no idea whether what component this bug is in, so I'm leaving it at core for now. I've seen this with 1.3b2 and 1.3b3 and never before 1.3b1, which I never used. (Thankfully, now than #9425 is fixed, it's the only crash I've seen in the 1.3b series! :-) )

Attachments (2)

Adium.crash.log (107.4 KB) - added by Jonathan Sailor 12 years ago.
crash reports
2008-06-19.log (2.5 KB) - added by Jonathan Sailor 12 years ago.
tail of debug log

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by Jonathan Sailor

Attachment: Adium.crash.log added

crash reports

comment:1 Changed 12 years ago by Jonathan Sailor

*Just* after submitting this, I discovered that I could also reproduce the crash merely by disconnecting the AIM account; the debug log shows it's a crash caused by a message sent as a result of a "Send a Message" action triggered by a "Contact No Longer Seen" event on one of my contacts.

Changed 12 years ago by Jonathan Sailor

Attachment: 2008-06-19.log added

tail of debug log

comment:2 Changed 12 years ago by Jordan

Milestone: Adium X 1.3

comment:3 in reply to:  2 Changed 12 years ago by Jonathan Sailor

Replying to jas8522:

milestone set to Adium X 1.3.

It's worth saying that, while I'd only ever seen this crash with 1.3b, I've almost certainly never tried to send a message to a just-disconnected-from contact as an event action before (and certainly didn't intend to do that this time), and it's a use case should probably be pretty low-priority.

comment:4 Changed 12 years ago by Evan Schoenberg

So the event is supposed to be sending a message as soon as a contact goes offline? :P

comment:5 Changed 12 years ago by Jordan

I think he's saying that he went offline, not his contact, then immediately sent a message. But I could be wrong...

comment:6 Changed 12 years ago by Evan Schoenberg

(In [24057]) Remove all contacts after noting that we are now offline, not after, so that code responding to this knows that the account is offline. Refs #10181

comment:7 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [24058]) Only attempt to do the Send Message action if the chat can actually receive the message. Fixes #10181

comment:8 Changed 12 years ago by Robert

Was this in 1.3 only?

comment:9 Changed 12 years ago by Evan Schoenberg

Summary: Crash in oscar_send_im in 1.3b2, 1.3b3Crash in oscar_send_im when disconnecting if an action is set to send a message when a user is no longer seen
Version: 1.3b31.0.6

No, the description implied it was, but there was nothing new about this crash other than the user not previously setting Adium such that it would happen :)

Note: See TracTickets for help on using tickets.