Adium

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#10152 closed defect (fixed)

wrong messageclasses on notifications

Reported by: mathuaerknedam Owned by:
Milestone: Adium 1.3.3 Component: Message View
Version: Severity: regression
Keywords: Cc:
Patch Status:

Description

I'm pretty sure this used to be correct, but as of r24008, 1.3b2 and 1.2.5 the messageclasses on incoming notifications (BUZZ!) is incorrect. Incoming is now "libpurplemessage event" and outgoing is "outgoing message notification". The specific messageclasses are different for 1.2.5 because the messageclasses spec were intentionally changes for 1.3, but I've verified with CFM that this wasn't part of the intentional changes.

Change History (9)

comment:1 Changed 12 years ago by Jordan

Milestone: Adium X 1.3.2

Placing a bit later, since this is not a 1.3 regression.

comment:2 Changed 11 years ago by Jordan

Milestone: Adium 1.3.2Adium 1.3.3

comment:3 Changed 11 years ago by Robert

Severity: normalregression

comment:4 Changed 11 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

This was the case for Jabber buzzes only, the result of a libpurple mistake which I fixed in [f94ddf7fa975e3a39a53fccae31b7e73f892fd57] for libpurple 2.5.4.

comment:5 Changed 11 years ago by mathuaerknedam

I thought I had seen this in Yahoo too, but sure enough, Yahoo doesn't get classed with "libpurplemessage". However, Now that I've tested both, I can see another difference in the behaviors between yahoo and jabber. With jabber, the outgoing message is a message and the incoming message is an event. With yahoo, they are both messages. I'd think they should both be events (even though neither one does this currently) or at least be consistent across protocols. Does your libpurple fix address this too?

comment:6 Changed 11 years ago by Evan Schoenberg

The fix will make them uniform... we can now consider how best to display the uniform information. I agree that it's more an event than a message... could you please make a ticket for displaying incoming and outgoing buzz-style notifications as events?

comment:7 Changed 11 years ago by mathuaerknedam

Cool. It's #11528.

comment:8 Changed 11 years ago by mathuaerknedam

Evan, think your change might also resolve #11333?

comment:9 in reply to:  8 Changed 11 years ago by mathuaerknedam

Replying to mathuaerknedam:

Evan, think your change might also resolve #11333?

It does not.

Note: See TracTickets for help on using tickets.