Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#10086 closed patch (fixed)

Chat transcript viewer doesn't display italics

Reported by: zacw Owned by: nobody
Milestone: Adium 1.3 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status: Accepted

Description

The chat transcript viewer will display bold and underline, but text formatted with italics does not display regardless of the font used. This is not a regression, but it is annoying.

Attachments (1)

DecodeItalics(#10086).diff (72.1 KB) - added by Jeremy W. Sherman 12 years ago.
Patch AIHTMLDecoder.m to handle font-style in the style attribute of a span element.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Jeremy W. Sherman

Attachment: DecodeItalics(#10086).diff added

Patch AIHTMLDecoder.m to handle font-style in the style attribute of a span element.

comment:1 Changed 12 years ago by Zachary West

Patch Status: NoneNeeds Dev Review
Type: defectpatch

comment:2 Changed 12 years ago by Jeremy W. Sherman

Verified bug appears in both log viewer and recent message context. XML log files correctly encode italics. Tracked problem to -processSpanTagArgs:attributes: in AIHTMLDecoder.m. There, the method handled font-weight: but not font-style: .

It sufficed to mimic how font-weight: was handled. I have verified this resolves the bug for messages displayed in both the log viewer and recent message context. A patch is attached.

(The patch file includes a lot of noise about changes Xcode must have made to .xcodeproj. Should I be editing that out of the svn-generated diff prior to attaching it here? I also didn't see any patch checkbox to check.)

comment:3 Changed 12 years ago by Zachary West

You can diff certain files by using svn diff <file1> <file2> <...>. I've set the patch flag, and I'll probably take a look at the patch later today (simple enough that it's probably valid anyway, since it's very nearly exactly font-weight).

comment:4 Changed 12 years ago by Zachary West

Resolution: fixed
Status: newclosed

(In [24020]) Patch from jeremyw.sherman to add italics to the HTML decoder. Fixes #10086.

comment:5 Changed 12 years ago by Robert

Patch Status: Needs Dev ReviewAccepted
Note: See TracTickets for help on using tickets.