Adium

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#10082 closed defect (fixed)

"go online with message" applescript fails

Reported by: larse Owned by: applmak
Milestone: Component: AppleScript
Version: Severity: regression
Keywords: Cc:
Patch Status:

Description

tell application "Adium"
	go online with message "test"
end tell

fails with "Adium got an error: AppleEvent handler failed."

Change History (6)

comment:1 Changed 12 years ago by Jordan

Milestone: Adium X 1.3

comment:2 Changed 12 years ago by Matt Handley

Resolution: fixed
Status: newclosed

(In [23992]) go online with message works again. The problem was the assumption that the passed messagae would be an NSAttributedString when, really it would be either an NSString or an NSAttributedString. Fixes #10082.

comment:3 Changed 12 years ago by Robert

Was this a regression?

comment:4 Changed 12 years ago by Matt Handley

I think at some point, it did work. So, yes.

comment:5 Changed 12 years ago by Robert

Milestone: Adium X 1.3SVN issues
Severity: normalregression

comment:6 Changed 11 years ago by (none)

Milestone: SVN issues

Milestone SVN issues deleted

Note: See TracTickets for help on using tickets.